Bug 36505 - RFE: qla2x00 detected before aic7xxx in installer
RFE: qla2x00 detected before aic7xxx in installer
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
: FutureFeature
: 36578 44567 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-18 12:17 EDT by Michael E Brown
Modified: 2007-04-18 12:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-09 23:58:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael E Brown 2001-04-18 12:17:22 EDT
In the 7.1 installer, the aic7xxx driver needs to be loaded prior to the
qla2x00, or the system won't install properly on systems connected to Fibre
Storage. Worse, if no storage is connected, and the system is installed,
the system will no longer boot after fibre strorage is attached because the
system can then no longer find /.
Comment 1 Matt Domsch 2001-04-18 17:45:13 EDT
*** Bug 36578 has been marked as a duplicate of this bug. ***
Comment 2 Michael Fulbright 2001-04-20 11:34:33 EDT
There appear to be two different issues here:

  1) The installer loads the kernel modules in a bad order, causing drivers
     on the aic7xxx card to be shadowed during the install process.

  2) If you have a working system with a aic7xxxx card, then go and add the
     qla2x00 later, kudzu discovers the qla2x00 on the next bootup and causes
     the drivers on the aic7xxx card to disappear?

Is this correct?
Comment 3 Michael E Brown 2001-04-23 01:54:02 EDT
Number (1) is the issue that I am concerned with at this time. I have not 
tested for number (2), although I can test this out later.

I know that this isn't something that can be fixed right away, so I think this 
needs to be turned into an RFE in the installer. The workaround (for now) is 
"expert noprobe", and manually specifybng the drivers. Our SAN folks think 
this is too complicated for the new user.

What I would like to see is:

1) Separate detection of drivers from actually loading driver.
2) Installer switch that lets the user pick from the list of _detected_ 
devices and put them in the correct load order. Similar to the following:

Boot: linux expert
...
...
Red Hat Installer:
 I detected the following devices in your system. Please select the drivers 
you would like to load, and use CTRL-(ARROW) to place them in the correct load 
order.
	[ ] Adaptec ... AIC7xxx
	[ ] Qlogic Fibre ... qla2x00
	[ ] Intel EEPRO100 ... eepro100


Comment 4 Brent Fox 2001-04-23 09:13:56 EDT
I'm marking this as an RFE.
Comment 5 Brent Fox 2001-06-14 10:57:55 EDT
*** Bug 44567 has been marked as a duplicate of this bug. ***
Comment 6 Brent Fox 2001-07-09 23:58:51 EDT
I've talked with the other developers and the situation is that the installer
scans the PCI bus in ascending order, and it uses the first controller it finds
as the default controller to install to.  You might try setting the bus order of
the controllers in the BIOS.

Note You need to log in before you can comment on or make changes to this bug.