Bug 36542 - Fails to re-download corrupt files
Fails to re-download corrupt files
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
: 36541 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-18 15:44 EDT by Richard D. Payne
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-18 16:15:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard D. Payne 2001-04-18 15:44:52 EDT
Upgrade from 6.2, FTP install. 2 files were missing from our mirror, upon
finding the installer trying to download a nonexistant file I went to the
mirror and manually copied the file into the install tree. Unfortunatly 
the machine doing the install grabbed the file before it was entirly 
copied. The install then put up a window saying:

The file /mnt/sysimage/var/tmpxxxxx.arch.rpm can not be installed
due to the file missing, bad package, press <return> to try again
(somewhat paraphrased).

I pressed enter several times but it seems since the file was already
present the installer did not bother to download it again. Instead it
just kept trying to install the corrupt file. It struck me that the least
the installer could do would be to delete the corrupt version and try
downloading again.
Comment 1 Brent Fox 2001-04-18 15:51:33 EDT

*** This bug has been marked as a duplicate of 36540 ***
Comment 2 Brent Fox 2001-04-18 15:52:04 EDT
*** Bug 36540 has been marked as a duplicate of this bug. ***
Comment 3 Brent Fox 2001-04-18 15:56:20 EDT
The installer has to assume that the installation media is clean.  If we start
trying to catch all the errors that result from a corrupted download, we open up
a real can of worms.  Given all the files that are included in the distribution,
checking and verifying each and every file creates way too much overhead.
Comment 4 Brent Fox 2001-04-18 15:56:23 EDT
*** Bug 36540 has been marked as a duplicate of this bug. ***
Comment 5 Brent Fox 2001-04-18 15:57:06 EDT
*** Bug 36541 has been marked as a duplicate of this bug. ***
Comment 6 Richard D. Payne 2001-04-18 16:15:44 EDT
Retrying a download 2 or 3 times is to much effort? I'm not talking about
checking every package
as it comes down, just doing a retry if the file seems corrupt. How many retires
do you do for
a CD install?
Comment 7 Brent Fox 2001-04-18 16:23:57 EDT
We do one try for the cd install.  We are not going to add more code to the
installer just to check if the user has set up the ftp server correctly.  That
is the user's responsibility.

Note You need to log in before you can comment on or make changes to this bug.