Bug 36627 - Ananconda bug during installation /creation of first partition for Linus on dual-boot
Summary: Ananconda bug during installation /creation of first partition for Linus on d...
Status: CLOSED DUPLICATE of bug 16686
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 7.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-19 11:44 UTC by Richard Adams
Modified: 2007-04-18 16:32 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2001-04-19 20:10:48 UTC


Attachments (Terms of Use)
Error message from Red Hat Linux 7 installation program (1.38 KB, text/plain)
2001-04-19 11:46 UTC, Richard Adams
no flags Details

Description Richard Adams 2001-04-19 11:44:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (Win98; U)

This is similar to bug 36604 (same error message).
Basically first installation gets to a certain point and crashes.
(I also don't understand why the installer program reads the created partition as full)

Reproducible: Always
Steps to Reproduce:
1. Prior to installation, created partition on hard drive in preparation running Windows 98 using Fips 2.0.
2. Red Hat installer read partition as full and would not allow automatic partitionless installation.
3. Attempted to use manual partition installation using Disk Druid.
4. Attempt to mount / in selected partition, accepted. Two dialogue boxes, then installer does not ask size of swap.
5. On clicking Next, error message appears (see below).
	

Actual Results:  This is resulting error message:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 336, in run
    self.icw.run ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 678, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2554, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 428, in nextClicked
    self.setScreen (self.currentScreen, self.nextClicked)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 466, in setScreen
    new_screen = screen.getScreen ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/rootpartition_gui.py", line 133, in getScreen
    avail = apply(isys.spaceAvailable, self.todo.fstab.getRootDevice())
  File "/usr/lib/anaconda/isys.py", line 10, in spaceAvailable
    mount(device, "/mnt/space", fstype = fsystem)
  File "/usr/lib/anaconda/isys.py", line 99, in mount
    rc = _isys.mount(fstype, device, location, readOnly)
SystemError: (22, 'Invalid argument')

Local variables in innermost frame:
fstype: vfat
location: /mnt/space
devName: /tmp/hda2
readOnly: 0
device: /tmp/hda2

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>



Expected Results:  Should have dialogue box asking what space to allow for swap (according to documentation).

This is using installation distributed with book Red Hat Linux 7 For Dummies (We've all got to start somewhere.....)
I was attempting to do the standard workstation installation, the first problem being that the installer read the partition I'd created as full (at the 
Automatic Partitioning stage) and would not allow automatic partition (it saw the partition as having 0 mb empty, despite allocating 2.3G to the 
partition). So I tried using Disk Druid to create a root partition, and two steps on from that the installation crashes.

Comment 1 Richard Adams 2001-04-19 11:46:05 UTC
Created attachment 15724 [details]
Error message from Red Hat Linux 7 installation program

Comment 2 Brent Fox 2001-04-19 20:10:44 UTC

*** This bug has been marked as a duplicate of 16686 ***


Note You need to log in before you can comment on or make changes to this bug.