Bug 371911 - Anaconda crashes on x86_64 DVD
Anaconda crashes on x86_64 DVD
Status: CLOSED DUPLICATE of bug 374311
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-08 16:45 EST by Mike Duncan
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-12 13:45:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of error message (71.87 KB, image/jpeg)
2007-11-11 08:01 EST, Pascal Oberacker
no flags Details

  None (edit)
Description Mike Duncan 2007-11-08 16:45:13 EST
Description of problem:
Anaconda crashes right after screen to check the media

Version-Release number of selected component (if applicable):
Fedora 8

How reproducible:
Boot DVD

Steps to Reproduce:
1.  Merely boot the DVD
2.
3.
  
Actual results:
Crash (looks like a dump)

Expected results:
Smooth install

Additional info:
Performed the media check within Anaconda.  It passed.  Here is the sha1sum:
88168a5fce834463944ffa714b6c1cf2c81824ea
Comment 1 Chris Lumens 2007-11-08 16:54:01 EST
Please attach the complete error to this bug report.
Comment 2 Pascal Oberacker 2007-11-08 17:07:49 EST
I'm getting exactly the same error.
Immediately after the disc check (no matter if it's executed or not) the
installer seems to crash, with this message:

http://img.photobucket.com/albums/v227/angahito/P1000359.jpg
Comment 3 Mike Duncan 2007-11-08 17:33:08 EST
(In reply to comment #1)
> Please attach the complete error to this bug report.

Please see comment #2.  This screen shot looks exactly like what I am getting.
Comment 4 Mike Duncan 2007-11-08 17:36:33 EST
(In reply to comment #1)
> Please attach the complete error to this bug report.

On further research, I inserted the DVD into the drive without mounting it.  I
then performed a sha1sum on /dev/hda (the dvd drive).  The result is:
6cbca30ea6363831c9ba429a55c265765dc3b496

which is different than the ISO image.  Thinking I had a bad burn, I re-burned
the iso, and performed the same sha1sum check.  I received the exact same sum. 
I have a difficult time believing the image could have had an error at the exact
same spot in both burns.

Am I misunderstanding SHA1SUM in thinking that the /dev/hda sum and the iso sum
should be identical?
Comment 5 Pascal Oberacker 2007-11-09 03:51:57 EST
Just for clarification, this happens with both, graphical and text install option.

The burn was verified and the disc check was successful, so it's highly unlikely
that the media is at fault.

While i haven't found any reports about incompatibility, maybe information about
my system could be helpful.
The machine, i'm trying to install it on, is an FSC Amilo A1630 notebook with
the following specs: 
AMD Athlon 64 Mobile 3700+
1024 MB PC3200 Corsair DDR RAM 
Uniwill 258KA0 Motherboard
SIS 755 Chipset
ATI Radeon 9700 Mobility

Thanks
Comment 6 Jeremy Katz 2007-11-09 09:36:42 EST
Can you switch to tty3 and see what the last messages there are?
Comment 7 Mike Duncan 2007-11-09 10:49:21 EST
(In reply to comment #6)
> Can you switch to tty3 and see what the last messages there are?

Here's my output:
INFO : trying to mount CD device scd0 on /mnt/source
INFO : mntloop loop0 on /mnt/runtime as /mnt/source/images/stage2.img fd is 8
INFO : support = 0
INFO : Loading SELinux policy
INFO : getting ready to spawn shell now
INFO : modules to insert ide-cd
INFO : load module set done
INFO : modules to insert
INFO : load module set done
INFO : modules to insert
INFO : load module set done
INFO : modules to insert pcmcia_core p* pcmcia

On the last line above, the p* is actually a "p" followed immediately by a
square block, indicative of an unprintable character.  The two lines above it
show some kind of modules being inserted, but it does not list what that module
is.  Those lines are transcribed as is.

Any typos are mine, as I wrote these messages down and re-typed them here.

Per the poster above, I will also list my equipment:

Dell Latitude D830 Centrino Duo with 2G of RAM
NVidia Video
I use the ipw3945 wireless driver, but it sux

Hope that helps!
Comment 8 Jeremy Katz 2007-11-09 11:17:18 EST
Can you boot adding 'loglevel=debug' to the kernel command line and do the same?
Comment 9 Mike Duncan 2007-11-09 11:40:03 EST
(In reply to comment #8)
> Can you boot adding 'loglevel=debug' to the kernel command line and do the same?

Here we go:

INFO  : trying to mount CD device scd0 on /mnt/source
INFO  : mntloop loop0 on /mnt/runtime as /mnt/source/images/stage2.img fd is 8
DEBUG : MD%SUM -> 15055ae76b9f3a2503c7a9af9792aa05
DEBUG : skipsectors = 15
INFO  : support = 0
INFO  : Loading SELinux policy
INFO  : getting ready to spawn shell now
INFO  : modules to insert ide-cd
DEBUG : getModuleLocation: 2.6.23.1-42.fc8/x84_64
DEBUG : module(s) ide-cd not found
INFO  : load module set done
INFO  : modules to insert
DEBUG : getModuleLocation: 2.6.23.1-42.fc8/x84_64
INFO  : load module set done
INFO  : modules to insert
DEBUG : getModuleLocation: 2.6.23.1-42.fc8/x84_64
INFO  : load module set done
INFO  : modules to insert pcmcia_core pcmcia
DEBUG : getModuleLocation: 2.6.23.1-42.fc8/x84_64

It looks like Anaconda cannot find the ide CD drive, or the module isn't being
loaded correctly.  Fedora 7 actually failed gracefully here, asking where the
location of the install media could be found.  Now it's gotten worse, and just
puking all over the screen.

Also, I noticed in the last line that the unprintable character is not being
output any more.
Comment 10 Mike Duncan 2007-11-09 13:47:20 EST
As states above, typos are mine.  For instance, x84_64 should be x86_64
Comment 11 Pascal Oberacker 2007-11-09 15:32:28 EST
I don't think the CD drive is the issue. I just tried installing it with
"askmethod" and using the iso i still got on my hd.  Same result.
Comment 12 Franck Waechter 2007-11-09 15:48:33 EST
Same problem.
I hadn't this problem on F8T3
With Askmethod and FTP, Anaconda start starts.
Comment 13 Mike Clayton 2007-11-09 16:42:57 EST
I am having this same problem with the i386 DVD, Media check comes back ok,
sha1sums checked ok
Comment 14 Mike Duncan 2007-11-09 17:08:38 EST
Askmethod seems to fix the issue here, even installing from DVD
Comment 15 Pasi Sjöholm 2007-11-10 08:13:43 EST
Seems the same as https://bugzilla.redhat.com/show_bug.cgi?id=372291
Comment 16 Pascal Oberacker 2007-11-11 08:01:27 EST
Created attachment 254631 [details]
screenshot of error message

As already mentioned, using "askmethod" doesn't fix the bug for me, but i just
noticed that i actually get this error message, when using "askmethod" in text
mode.
Comment 17 Francis Kung 2007-11-11 16:35:19 EST
Another possible fix is the "nopcmcia" option - that worked for me, see
https://bugzilla.redhat.com/show_bug.cgi?id=374311

The original cause of the crash for me was "invalid pointer", not "doubly-linked
list error" (which "askmethod" seems to get around?), so there are probably two
different crashes we're seeing here.
Comment 18 Pascal Oberacker 2007-11-11 18:53:04 EST
I tried out random things, earlier.
Running the installer with resolution=1280x800, which is my screen's native
resolution, made it run perfectly. Not even editing the packages (which was
still reported as problematic by others) caused any trouble.

I'm posting from F8 right now.
Comment 19 Jeremy Katz 2007-11-12 13:45:48 EST

*** This bug has been marked as a duplicate of 374311 ***

Note You need to log in before you can comment on or make changes to this bug.