Bug 372291 - /bin/loader crashes with glibc corrupted doubly-linked list error
/bin/loader crashes with glibc corrupted doubly-linked list error
Status: CLOSED DUPLICATE of bug 374311
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: 374151 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2007-11-09 03:49 EST by tomi ollila
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-11-12 13:47:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
camera shot on tty3 window (79.95 KB, image/jpeg)
2007-11-10 10:17 EST, tomi ollila
no flags Details

  None (edit)
Description tomi ollila 2007-11-09 03:49:30 EST
Description of problem:

Fedora 8 installation dvd /sbin/loader crashes with

*** glibc detected *** /sbin/loader: corrupted doubly-linked list: 0x09fcc1f0

On IBM ThinkPad T43  

Version-Release number of selected component (if applicable):

Original Fedora 8 DVD Installation Image released 20071008

How reproducible:

Every time I try to install, after CD/DVD test (skipped), the above
error message arrives. No X window (if it still works like before)
ever appears.

Steps to Reproduce:
1. Put installation DVD in
2. Install/upgrade (either graphical/text mode)
3. Skip CD/DVD test
Actual results:

See above error message

Expected results:

Installation proceeds.

Additional info:

DVD test OK. Memory test OK. I presume bittorrent took care dvd image is OK
Comment 1 tomi ollila 2007-11-09 03:50:28 EST
Tried both graphical and text mode installs. many times
Comment 2 tomi ollila 2007-11-09 03:56:15 EST
I am going to try this DVD on another machine and try Fedore 7 installation
DVD on this machine, but not before Saturday morning...
Comment 3 Jeremy Katz 2007-11-09 09:37:02 EST
Can you switch to tty3 and see what the last messages there are?
Comment 4 Pasi Sjöholm 2007-11-10 08:07:27 EST
I can confirm this on my T43-laptop.

Last messages on tty3 are:

INFO: getting ready to spawn shell now
INFO: modules to insert ide-cd
INFO: load module set done
INFO: modules to insert
INFO: load module set done
INFO: modules to insert
INFO: load module set done
INFO: modules to insert pcmcia_core [][]4    xh3 [][][][][][][][] pcmcia
INFO: load module set done

[] == box.

Comment 5 Pasi Sjöholm 2007-11-10 10:17:20 EST
Tried installing with "askmethod"-option and loader did not crash anymore.
However.. package selselection crashed many times. ;)

Now running with F8.
Comment 6 tomi ollila 2007-11-10 10:17:51 EST
Created attachment 253941 [details]
camera shot on tty3 window
Comment 7 tomi ollila 2007-11-10 11:26:37 EST
"askmethod" worked for me too. Thanks. I did not dare to choose anything else
than default set of applications as installing F8 on another machine used to
just halt when I added anything more (like "Software Develompent").
Well, I can use "jummi jammi) to install the additional packages I need.

If there is anything more to debug the problem, just ask. 
Comment 8 Mary Ellen Foster 2007-11-10 15:46:21 EST
*** Bug 374151 has been marked as a duplicate of this bug. ***
Comment 9 Mary Ellen Foster 2007-11-10 15:53:07 EST
I've got a picture of the output on tty1 on a laptop that crashes with a similar
error under bug 374151. Will try with "askmethod" tonight or tomorrow and see if
it resolves my issue too.
Comment 10 Jeremy Katz 2007-11-12 13:47:31 EST

*** This bug has been marked as a duplicate of 374311 ***

Note You need to log in before you can comment on or make changes to this bug.