Bug 374311 - (f8pcmciasegv) Install segfaults during pcmcia probe
Install segfaults during pcmcia probe
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
i386 Linux
high Severity urgent
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
: 371911 372291 375461 410521 413271 426795 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-10 00:03 EST by Francis Kung
Modified: 2008-01-09 10:05 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-09 10:05:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Francis Kung 2007-11-10 00:03:28 EST
Description of problem:
Anaconda crashes when trying to install F8. 

Version-Release number of selected component (if applicable):
F8 i386 DVD ISO

How reproducible:
Always

Steps to Reproduce:
1. Boot off DVD
  
Actual results:
Crash

Expected results:
No crash

Additional info:
Crashes after the disk check (similar to
https://bugzilla.redhat.com/show_bug.cgi?id=371911 but with a different
backtrace values):

*** glibc detected ***
/sbin/loader: munmap_chunck(): invalid pointer: 0x09fd5190
Backtrace:
0x81a4083
0x805b750
0x805c153
(etc)

loader received AIGABRT! Backtrace:
0x804a030
0x110420
0x81e7f80
0x8182a30
0x819930b
etc

Debug messages:
INFO: Loading SELinux policy
INFO: getting ready to spawn shell now
INFO: modules to insert ide-cd
DEBUG: getModuleLocation: 2.6.23.1-42.fc8/i586
DEBUG: module(s) ide-cd not found
INFO: load module set done
INFO: modules to insert
DEBUG: getModuleLocation: 2.6.23.1-42.fc8/i586
INFO: load module set done
INFO: modules to insert
DEBUG: getModuleLocation: 2.6.23.1-42.fc8/i586
INFO: load module set done

Media check passes, am upgrading from F7 (though it never gets far enough for
that to matter), happens on both graphical and text installs.

HP/Compaq nc6000 laptop
Intel P3 processor
Comment 1 Francis Kung 2007-11-11 16:31:04 EST
Passing the nopcmcia kernel option resolved this issue, if that helps narrow
down the problem.

Hardware information:
lspcmcia
Socket 0 Bridge:        [yenta_cardbus]         (bus ID: 0000:02:06.0)
Socket 1 Bridge:        [yenta_cardbus]         (bus ID: 0000:02:06.1)
Socket 2 Bridge:        [yenta_cardbus]         (bus ID: 0000:02:06.3)

lspci
00:00.0 Host bridge: Intel Corporation 82855PM Processor to I/O Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 82855PM Processor to AGP Controller (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI
Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 83)
00:1f.0 ISA bridge: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge
(rev 03)
00:1f.1 IDE interface: Intel Corporation 82801DBM (ICH4-M) IDE Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus
Controller (rev 03)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
00:1f.6 Modem: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97
Modem Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon
9600 M10]
02:04.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC
(rev 01)
02:06.0 CardBus bridge: O2 Micro, Inc. OZ711M3/MC3 4-in-1 MemoryCardBus Controller
02:06.1 CardBus bridge: O2 Micro, Inc. OZ711M3/MC3 4-in-1 MemoryCardBus Controller
02:06.2 System peripheral: O2 Micro, Inc. OZ711Mx 4-in-1 MemoryCardBus Accelerator
02:06.3 CardBus bridge: O2 Micro, Inc. OZ711M3/MC3 4-in-1 MemoryCardBus Controller
02:0e.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5705M_2 Gigabit
Ethernet (rev 03)
Comment 2 Jeremy Katz 2007-11-12 13:45:49 EST
*** Bug 371911 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2007-11-12 13:47:32 EST
*** Bug 372291 has been marked as a duplicate of this bug. ***
Comment 4 Chris Lumens 2007-11-12 14:16:13 EST
Once you have the machine installed, what does kudzu -p -c SOCKET show you? 
Also are you seeing corrupt strings on tty3 when trying to load pcmcia modules
as well?
Comment 5 Francis Kung 2007-11-12 22:51:12 EST
[root@fkung-lpt ~]# kudzu -p -c SOCKET
-
class: SOCKET
bus: PCI
detached: 0
driver: yenta_socket
desc: "O2 Micro, Inc. OZ711M3/MC3 4-in-1 MemoryCardBus Controller"
vendorId: 1217
deviceId: 7223
subVendorId: 103c
subDeviceId: 0890
pciType: 1
pcidom:    0
pcibus:  2
pcidev:  6
pcifn:  3
-
class: SOCKET
bus: PCI
detached: 0
driver: yenta_socket
desc: "O2 Micro, Inc. OZ711M3/MC3 4-in-1 MemoryCardBus Controller"
vendorId: 1217
deviceId: 7223
subVendorId: 103c
subDeviceId: 0890
pciType: 1
pcidom:    0
pcibus:  2
pcidev:  6
pcifn:  1
-
class: SOCKET
bus: PCI
detached: 0
driver: yenta_socket
desc: "O2 Micro, Inc. OZ711M3/MC3 4-in-1 MemoryCardBus Controller"
vendorId: 1217
deviceId: 7223
subVendorId: 103c
subDeviceId: 0890
pciType: 1
pcidom:    0
pcibus:  2
pcidev:  6
pcifn:  0
[root@fkung-lpt ~]# 
[root@fkung-lpt ~]# 
[root@fkung-lpt ~]# 
[root@fkung-lpt ~]# 
[root@fkung-lpt ~]# kudzu -p -c SOCKET
-
class: SOCKET
bus: PCI
detached: 0
driver: yenta_socket
desc: "O2 Micro, Inc. OZ711M3/MC3 4-in-1 MemoryCardBus Controller"
vendorId: 1217
deviceId: 7223
subVendorId: 103c
subDeviceId: 0890
pciType: 1
pcidom:    0
pcibus:  2
pcidev:  6
pcifn:  3
-
class: SOCKET
bus: PCI
detached: 0
driver: yenta_socket
desc: "O2 Micro, Inc. OZ711M3/MC3 4-in-1 MemoryCardBus Controller"
vendorId: 1217
deviceId: 7223
subVendorId: 103c
subDeviceId: 0890
pciType: 1
pcidom:    0
pcibus:  2
pcidev:  6
pcifn:  1
-
class: SOCKET
bus: PCI
detached: 0
driver: yenta_socket
desc: "O2 Micro, Inc. OZ711M3/MC3 4-in-1 MemoryCardBus Controller"
vendorId: 1217
deviceId: 7223
subVendorId: 103c
subDeviceId: 0890
pciType: 1
pcidom:    0
pcibus:  2
pcidev:  6
pcifn:  0
[root@fkung-lpt ~]# 

I didn't see any corrupt strings in tty3, only the "getModuleLocation" / "load
module set done" messages from my last report.

Cheers,
Francis
Comment 6 tomi ollila 2007-11-14 09:54:43 EST
Here is my info:

localhost# kudzu -p -c SOCKET
-
class: SOCKET
bus: PCI
detached: 0
driver: yenta_socket
desc: "Ricoh Co Ltd RL5c476 II"
vendorId: 1180
deviceId: 0476
subVendorId: 1014
subDeviceId: 056c
pciType: 1
pcidom:    0
pcibus:  4
pcidev:  0
pcifn:  0
localhost# 

localhost# lspcmcia
Socket 0 Bridge:        [yenta_cardbus]         (bus ID: 0000:04:00.0)
localhost#

localhost# lspci
00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express
Processor to DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 915GM/PM Express PCI Express Root
Port (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 1 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 3 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3)
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW
(ICH6 Family) AC'97 Audio Controller (rev 03)
00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem
Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus
Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Mobility Radeon X300]
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751M Gigabit
Ethernet PCI Express (rev 11)
04:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev 8d)
04:02.0 Network controller: Intel Corporation PRO/Wireless 2915ABG Network
Connection (rev 05)
localhost#
Comment 7 Chris Lumens 2007-11-15 16:25:06 EST
For our future reference:

clumens@exeter:/usr/lib/debug/usr/lib/anaconda-runtime/loader$ eu-addr2line -e
loader.debug 
0x81a4083
/usr/src/debug/anaconda-11.3.0.50/stubs/unicode-lite.c:28
0x805b750
/usr/src/debug/anaconda-11.3.0.50/loader2/pcmcia.c:143
0x805c153
/usr/src/debug/anaconda-11.3.0.50/loader2/hardware.c:222





0x804a030
/usr/src/debug/anaconda-11.3.0.50/loader2/loader.c:1463
0x110420
??:0
0x81e7f80
/usr/src/debug/anaconda-11.3.0.50/stubs/unicode-lite.c:28
0x8182a30
/usr/src/debug/anaconda-11.3.0.50/stubs/unicode-lite.c:28
0x819930b
/usr/src/debug/anaconda-11.3.0.50/stubs/unicode-lite.c:28
Comment 8 Chris Lumens 2007-11-19 13:00:58 EST
*** Bug 375461 has been marked as a duplicate of this bug. ***
Comment 9 Chris Lumens 2007-12-07 12:46:22 EST
*** Bug 410521 has been marked as a duplicate of this bug. ***
Comment 10 Chris Lumens 2007-12-07 12:46:30 EST
*** Bug 413271 has been marked as a duplicate of this bug. ***
Comment 11 Bryan Taylor 2007-12-08 17:21:54 EST
Adding nopcmcia to the boot command line (by hitting tab at the "at the Welcome
to Fedora 8 screen") eliminated the crash for me and allow the install to
proceed normally. This appears to have broken between F8Test3 and F8 final, as I
initially worked around this by installing from F8Test3 and then upgrading with
yum. Of course, my traceback was slightly different (see Bug 413271).
Comment 12 Jeremy Katz 2007-12-26 14:06:34 EST
*** Bug 426795 has been marked as a duplicate of this bug. ***
Comment 13 Chris Lumens 2008-01-09 10:05:11 EST
This should be fixed in rawhide and the F9 test releases.  Thanks for the many
bug reports on this one.

Note You need to log in before you can comment on or make changes to this bug.