Bug 37218 - Installer hangs: VFS: Cannot open root device
Installer hangs: VFS: Cannot open root device
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
: 51898 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-23 12:52 EDT by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-26 15:09:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-04-23 12:52:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1-0.1.9 i686; Nav)


When I'm trying to install RedHat 7.1 I got the following error:
VFS: Cannot open root device "" or 08:41
Pleae append a correct "root=" boot option
Kernel panic: VFS: unable to mount root fs on 08:41

I've tried the option "Graphic" and "expert" with the same result as
mentioned above.
I've also tried to add the following line after the 'boot: ' prompt:
linux root=/dev/hdb1, /dev/hdb2   
I get then the error:
No init found.

My current version is RedHat 7.1 beta (wolverine) and the install program
works here fine.

Reproducible: Always
Steps to Reproduce:
1. Put 1st cd rom in pc and boot
2.
3.
	

Actual Results:  See error above

Expected Results:  A normal installation procedure

This error is only occuring with the 'real' RedHat 7.1 version, not with
the 7.1 beta
Comment 1 Craig White 2001-04-23 13:08:01 EDT
Indeed - I have the same issue - after booting from seawolf CD -1, after I select US & English, it asks me if my installer files are on a hard drive or cd and 
after selecting cd, I get the same question again and again.

Craig
Comment 2 Brent Fox 2001-04-23 14:04:16 EDT
These errors seem similar, but I don't think that they are the exact same
problem.  Do you have any other machines available?  I'm curious if the same
thing happens on different machines.
Comment 3 Need Real Name 2001-04-23 15:20:53 EDT
No, I'm sorry due to harddisk problems I can't test it to an other machine. But
again, I'm having NO problems with the 7.1 beta!!!
I hope there will be a patch soon, because I want to play DVD's on Linux, so I
don't have to reboot my machine again to watch some DVD's.
Comment 4 Brent Fox 2001-04-23 15:39:37 EDT
Can you do an md5sum on the isos that you downloaded?  Something may have gone
wrong during the download.  Other than that, I can't think of a reason why this
is happening.  You're trying to install, right?  Not upgrade?
Comment 5 Need Real Name 2001-04-23 16:45:28 EDT
need to change the operating system for this, can you give me the command to 
run??

BTW i'm trying to upgrade my excisting system, don't want to through away my 
settings now.

Comment 6 Need Real Name 2001-04-25 05:48:23 EDT
As far I can see now the iso was corrupted (although the size was exactly the 
same as the original one) but the md5sum showed a different result.
Currently I'm burning a new iso file, the md5sum was this time ok.
Comment 7 Need Real Name 2001-04-25 13:08:25 EDT
I have the same problem on a Compaq Proliant 2500R. 

Installer stops because it can't install on a machine with 14megs of memory.  
My server has 512 megs of memory.

If I give the mem parameter "linux mem=512M" it gives me

VFS: Cannot open root device "" or 08:41
Pleae append a correct "root=" boot option
Kernel panic: VFS: unable to mount root fs on 08:41

Happens every time I try.  And I've tried all kinds of memory settings,  64, 
128, 256 etc..  no go.  This is RH 7.1,  not the beta.

If I were to include the "root=" statement,  what should I set it to?  it 
didn't like /dev/hda (My cdrom).  

I can recreate this problem ad nauseum if you want to get more details

My email is lafont02@cn.ca

Don Lafontaine
Canadian National Railways
Comment 8 Brent Fox 2001-04-25 14:35:47 EDT
Don, have you checked the md5sums of the isos that you downloaded to make sure
that nothing got corrupted?  It looks like that was the problem for the original
poster.
Comment 9 Need Real Name 2001-04-26 14:51:40 EDT
Hi,

Problem is solved, it was indeed the difference in the md5sum (although the
filesize and date were the same). I've dpwnloaded an other iso file from a
different ftp server.
I have now a fine working machine (only a small problem with my mouspointer this
is now instead of a 'normal' arrow a 1.5 cm square block with stripes, so it's a
little bit difficult to use the mouse, but I think this is caused by my
videocard (Viper II, Savage2000 chipset).

Comment 10 Bill Negrelli 2001-05-13 10:24:59 EDT
*** Bug 40393 has been marked as a duplicate of this bug. ***
Comment 11 Brent Fox 2001-08-16 14:27:37 EDT
*** Bug 51898 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.