Bug 37292 - Sawfish does not start and Gnome complains of no Window Manager
Sawfish does not start and Gnome complains of no Window Manager
Status: CLOSED DUPLICATE of bug 56506
Product: Red Hat Linux
Classification: Retired
Component: sawfish (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-23 23:56 EDT by Need Real Name
Modified: 2013-04-02 00:15 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-11 18:32:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-04-23 23:56:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16-22 i586)


Upon start up (just after install), the Gnome display shows all the
components as they load. After several more boots, it would appear that
Sawfish slowly begins to get corrupted (each boot seems to take longer),
until finally it no longer loads. After this, once Gnome starts up, it
complains of a non-compliant window manager. All windows display the
contents within the window frame, but there are no window gadgets.

I had thought that maybe this was due to my running Gnome as 'root', so I
reinstalled (complete reinstall), and only would use Gnome as an ordinary
user. This did not seem to make any difference.

I also tried to delete all the files in ~/.sawfish (and the folder). I
thought this would recreate the runtime data that Sawfish needs. This did
not work. I figured that I would try deleteing all of the ~/.gnome* files
and folders. This seemed to work the first time that I tried it, but after
that, nothing, nada, zip...

I am with my running the machine booting into the graphical mode (not using
text mode).

Having installed RedHat 7.1 (and the previous beta) about 4 times, I get
the same results on two different machines. One machine is a Gateway 2000
and the other is an AMD based system.

Reproducible: Always
Steps to Reproduce:
1. Install the System
2. Repeatedly boot using Graphical mode
3. As the system degrades, Sawfish should stop functioning.
	

Actual Results:  Sawfish slowly degrades and eventually will not boot.

Expected Results:  Sawfish should operate normally.
Comment 1 Need Real Name 2001-04-24 00:08:14 EDT
My comments on bug 37285 may be relevant.  Sounds very similar to what I
experienced
during my upgrade.  Did you use ANY part of a previous installation - user
configration
files, etc?
Comment 2 Need Real Name 2001-04-24 10:37:59 EDT
Everytime I installed (either RH 7.1 or the beta), they were clean installs. The
only thing that I brought from a previous system was my email (which was tar'ed
and and then copied over, and not present during the install). I use Netscape
for email, if that really matters.
Comment 3 remolacha 2001-04-25 14:19:30 EDT
for what it's worth, my gnome displayed the above symptoms the first time I 
started X after upgrading from 7.0 to 7.1 (P3 system).
Comment 4 Need Real Name 2001-04-25 21:01:13 EDT
Per a request from bfox, I'm adding comments to this bug that had originally
been posted
under bug 37285.  I'm inclined to agree that the problem is related to GNOME
packaging
under the 7.1 distro.  The system in question is a K6-2.  Comments follow...

 My 7.1 upgrade experience was similarly problematic, and ultimately required a
clean 7.1
 install due to a plethora of more recent Gnome content in my 7.0 install.  I
beefed my 7.0
 Gnome setup w/ Helix Gnome, and I've recently been keeping up to date on the
Gnome 1.4
 beta w/ Red Carpet.

 After the 7.1 upgrade I experienced serious problems w/ SB16 support (see bug
35052) and
 general flakiness w/ Gnome - sluggishness, crashing, problems w/ Sawfish
becoming
 deselected, trashing my desktop settings at random, etc.  When I started
rooting through
 gnorpm, I realized that there were multiple X/Gnome libraries and desktop files
- some of
 which were holdovers from my Helix install, and some were from the new 7.1
install.  I
 removed all the Helix stuff I could find, but the X/Gnome stability continued
to deteriorate.
 At one point, I had 3 instances of Sawfish starting up when logging in to
Gnome.  Weird!

 I decided to bite the bullet w/ a fresh install.  Things were markedly improved
as root, and
 got a little weird once I tried using the contents of a personal account I'd
backed up.  Ultimately,
 I ended up blowing away all Gnome and Sawfish related init files in that
account, kickstarted
 X, and things were good.

 Not the painless upgrade I'd hoped for, but I got there.  On the bright side,
 7.1 along w/ 2.4 made short work of that reinstall.  Devices I've typically had
 to fidget w/ to make work all ran out of the box.  Excellent!  My recently
 trashed 3dfx drivers also seem to be showing signs of life under 7.1, although
 they need a little tweaking.  The only outstanding issue remains a complete
lack
 of sound support - per bug 35052.

 The short of it all?  Be cautious doing a 7.1 upgrade from 7.0 w/ any recent
 Gnome updates.  (Ximian, Helix, or otherwise)  The resulting Gnome halfbreed
 will be ill-behaved at best.


 ------- Additional comments from bfox@redhat.com 2001-04-24 10:52:06 -------

 The second bug is unreleated to the first and sounds like a packaging problem
 with Gnome.  Please file a separate bug report under Gnome.
Comment 5 Christopher Johnson 2001-05-17 09:11:11 EDT
This may not be the cause of your problem but it's worth a check.  I experienced
similar corruption problems, and occasional other symptoms which I just proved
last Monday were caused by an ide controller firmware or kernel driver bug. See
bug 27614. In my case (Compaq Armada laptop) it can't be the cable, so I'm
reasonably sure it's a bug.

Indications in syslog were:
May 15 10:14:07 cjohnsonPC kernel: hda: status error: status=0x58 { DriveReady
SeekComplete DataRequest }
May 15 10:14:07 cjohnsonPC kernel: hda: drive not ready for command

Kernel boot option ide=nodma prevents these errors and I've not had a desktop
problem since using the option. I booted once since without the option and had
immediat desktop symptoms as you describe.
Comment 6 Brian Brock 2001-06-26 17:14:59 EDT
I'm finding similar symptoms on my desktop workstation (7.1 + latest errata). 
.xsession-errors contains:

sawfish: error while loading shared libraries: /usr/lib/libgmp.so.3: unsupported
version 0 of Verneed record

Also possibly relevent:
[bbrock@deviance:~]$ rpm -V gmp
..5.....   /usr/lib/libgmp.so.3.1.1
[bbrock@deviance:~]$ ls -l /usr/lib/libgmp*
lrwxrwxrwx    1 root     root           15 Feb 19 15:49 /usr/lib/libgmp.so.3 ->
libgmp.so.3.1.1*
-rwxr-xr-x    1 root     root       492976 Feb  5 10:11
/usr/lib/libgmp.so.3.1.1*

gmp verifies cleanly after removal and reinstallation, checking to see if that
was the possibly culprit.
Comment 7 Need Real Name 2001-08-25 04:12:48 EDT
This information might help in working out what's going on with this
problem:


I installed RH7.1 on my /dev/hdb/ an 8 Gb disk which had no problem.

I then installed (a total clean install -- I don't trust upgrades) to
a 15 Gb /dev/hdc.  I then experienced similar difficulties to do with
the non-Gnome compliant window manager that others have described.

My /dev/hdc installation runs KDE without a problem, not that I'm a
great fan of KDE.  

The fact that I don't have the problem on a smaller disk might be a
clue to someone who is knowledgable in these matters.
Comment 8 Rene 2001-09-07 17:33:03 EDT
I have also expereinced the problem in this bug report (37292). It is VERY 
reproducible for me. I think I have freshly installed RHv7.1 about 7x (from 
downloaded RPMs (seawolf) and each time sawfish seems to break with the 
symptoms described in this report. I tried troubleshooting the problem by 
upgrading my sawfish to v1.0 and upgrading my libprep to current version...all 
to no avail.

Looks like a similar bug has been filed on an Eazel list:
http://bugzilla.eazel.com/show_bug.cgi?id=8549

Has anybody on this forum contacted John Harper the product author for his 
thoughts on this?

Comment 9 Need Real Name 2001-09-10 10:50:51 EDT
I4ve been experiencing the same problem with sawfish.
it needed a full re-install of the operating system to fix it.
Event was reproducible after starting sawfish several times.
I had the impression, but really i4m not sure becouse i didn4t test it, that this bug happened after
a standard period of time as if some scheduled process would delete or modify the state of some sawfish config files.
On the terminal session i got the message:
file not found "rep/lang/interpreter"
and got another msg:
unable to access the imagic-cookie
when trying to start sawfish  manually got the msg:
sawfish error can4t open display.
A security problem or what?

Comment 10 Rene 2001-09-25 22:47:08 EDT
If it makes any difference there are quite a number of people reporting this
issue at the Red Hat Support Forums. Just do a Search with keyword ' sawfish '.
Can anyone from RedHat give us an update on this issue? Will it be fixed in 7.2
?
Comment 11 Need Real Name 2001-09-25 23:03:17 EDT
Further to what I mentioned earlier:....

I gave up on sawfish and used enlightenment instead.  It works most of the time,
but there are occasions when panels refuse to start for a similar reason to the
problem with sawfish.  The difference is that rebooting the computer will not
replicate the problem -- at least not right away.  I have had occasions where
everything would lock up a la Windoze requiring the reset button to be used.  On
restarting, all manner of things are screwed up, but they seem to be fixed by
running e2fsck on any partitions so affected.
Comment 12 Need Real Name 2001-10-03 19:12:21 EDT
Ditto.  Worked fine after install and then died after two or three logins. Check your .gnomerc-errors file.  I'm also seeing the "No such file or directory" "rep/lang/interpeter".
Comment 13 Need Real Name 2001-10-03 21:50:28 EDT
So it turns out the whole problem is nothing but
filesystem corruption.  For the specific interpeter problem,
run fsck (touch /forcefsck; reboot) then remove and reinstall the
librep package via rpm.  This cleaned everything for me.  

It's possible the filesystem was corrupt to begin with, but it's odd
that other folks are seeing the exact same thing....

Comment 14 Patrice Guay 2001-10-04 10:39:52 EDT
As a solution to this problem with gnome/sawfish, I've installed RH 7.1 without
Gnome.
Then, I performed a minimal installation of the ximian-gnome desktop
(www.ximian.com). 
Since then, sawfish is running well without any problem.
Comment 15 Need Real Name 2001-10-06 04:37:22 EDT
I've now tired the Ximian idea.  Thanks for the suggestion.

It worked, but not without ANY problem.  Now
I can't get RealPlayer to work.  Perhaps the minimal (70-odd Mb)
removes and does not substitute for the	necessaries of RP.  Going back
to Enlightenment will not work either, so something got lost along the
way.
Comment 16 Need Real Name 2001-10-31 02:06:03 EST
I can't see why this would be so, but it definitely is:

After many attempts, some of which are mentioned earlier, I moved
my disk so that instead of being /dev/hdc it is now /dev/hda.  
Now everything works fine.  I've rebooted it at least 8 times now
and the sawfish problem hasn't returned.  3 is about the most
I got to any other time.

Does this experience concur with anyone else's experience?
Comment 17 Rene 2001-10-31 19:21:29 EST
i made the switch to RH 7.2 and sawfish has been fine ever since. i gave up on 
rh 7.1 ... but come to think of it, my linux partition was also on /dev/hdc 
(i'm running Windoze98 on /dev/hda). if i had switched linux to /dev/hda...who 
knows... my results could've matched yours.
Comment 18 Need Real Name 2002-01-11 18:32:21 EST
the librep reinstall worked for me.  i just forced the librep (0.13.3-1.i386, 
devel too), set the /forcecheck, and reboot 3 times.  working so far.

by the way, i did download the librep 0.15.2-1.i386 versions, but rpm 
complained that the ...13.. version (already installed) was newer, so i didn't 
force that issue (another bug to track down).

i'll post again if the librep fails me later.

this is a simple fix that works so far.
Comment 19 Havoc Pennington 2002-03-04 14:49:38 EST
I'm not sure what to do with this other than dup it on #56506 which is rapidly
becoming the "my desktop doesn't work because my hard disk or kernel ate 
my files" bug.

*** This bug has been marked as a duplicate of 56506 ***

Note You need to log in before you can comment on or make changes to this bug.