Bug 373101 - Crashes of pirut
Crashes of pirut
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
: 428315 440317 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-09 11:35 EST by Andris Pavenis
Modified: 2008-04-11 09:35 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.3.28-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-26 13:56:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash log of pirut (2.60 KB, application/octet-stream)
2007-11-09 11:35 EST, Andris Pavenis
no flags Details
pirut crash dump. Array Index out of bounds (5.14 KB, application/octet-stream)
2007-12-24 19:29 EST, joseph A
no flags Details

  None (edit)
Description Andris Pavenis 2007-11-09 11:35:06 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:

After fresh installation and following adding packages using pirut, both pirut
and pup begin to crash.

Initially it crashes sometimes when I try to add more packages. One more visible
problem (often with following crash) was incorrectly disabled button "Optional
Packages" for groups Applications-->Educational Software and
Applications->Engineering and Scientific.

Later soon after start when getting before displaying main window. The same
(crash at startup) happens also with pup.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
pirut crashes

Expected results:
it should not crash


Additional info:

I'm now installing Fedora 8 on other system (this time x86_64). Observed some
problems with incorrectly disabled "Optional Packages" button for the same
groups, some crashes, but generally pirut is still able to do it's work. To do
things differently, I haven't added Livna repository yet for this case (x86_64).
It was added on the begin for i686.

I understand that this is not a good bug report, but I don't have better error
information yet.
Comment 1 Andris Pavenis 2007-11-09 11:35:06 EST
Created attachment 253001 [details]
Crash log of pirut
Comment 2 Andris Pavenis 2007-11-10 06:01:05 EST
Rebooting fixed the crashes. There should however be some instructions for user
what to do (perhaps added to error dialog):

1) reboot and retry (or something similar)
2) if that does not help then report bug

Some other idea: if pirut or pup crashes, there could be some extra actions on
the next run (like running ldconfig and maybe something more).
Comment 3 Jeremy Katz 2007-11-12 10:48:02 EST
Do you know if hal was running when you hit this crash?
Comment 4 Andris Pavenis 2007-11-12 11:52:34 EST
Unfortunately not. The crashes no more happened after rebooting and I'm not
going to do fresh install Fedora 8 in near future (so I could try to reproduce
problem once more).
Comment 5 Jeremy Katz 2007-11-12 15:58:30 EST
Okay.  Committed something that will serve as a fix, although it's a bit more
coarse than I would have liked
Comment 6 Fedora Update System 2007-11-20 12:49:58 EST
pirut-1.3.26-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pirut'
Comment 7 Fedora Update System 2007-11-28 20:33:56 EST
pirut-1.3.27-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pirut'
Comment 8 Fedora Update System 2007-12-06 15:45:23 EST
pirut-1.3.28-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2007-12-06 15:55:01 EST
pirut-1.3.28-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 joseph A 2007-12-24 19:29:16 EST
Created attachment 290367 [details]
pirut crash dump. Array Index out of bounds
Comment 11 Jeremy Katz 2007-12-26 13:56:27 EST
The new traceback is a different bug (bug 426736) and related to the use of a
specific plugin rather than pirut itself
Comment 12 Jeremy Katz 2008-01-14 10:52:30 EST
*** Bug 428315 has been marked as a duplicate of this bug. ***
Comment 13 Jeremy Katz 2008-04-11 09:35:26 EDT
*** Bug 440317 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.