Bug 373911 - KDM Infinity theme is broken
KDM Infinity theme is broken
Status: CLOSED DUPLICATE of bug 253889
Product: Fedora
Classification: Fedora
Component: kdmtheme (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Chitlesh GOORAH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-09 17:06 EST by milady
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-12 07:24:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
KDM with infinity-kdm theme (145.62 KB, image/jpeg)
2007-11-09 17:07 EST, milady
no flags Details
KDM with infinity theme (154.76 KB, image/jpeg)
2007-11-09 17:08 EST, milady
no flags Details

  None (edit)
Description milady 2007-11-09 17:06:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.9) Gecko/20071105 Fedora/2.0.0.9-1.fc8 Firefox/2.0.0.9

Description of problem:
See the screenshots attached.

The text boxes are too long for the layout.

First screenshot is taken with infinity-kdm theme and the second one with infinity theme.

My screen resolution is 1280x800 (I can't change it, it's a LCD laptop panel).

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Start F8 KDE with KDM infinity theme.

Actual Results:


Expected Results:


Additional info:
Comment 1 milady 2007-11-09 17:07:59 EST
Created attachment 253631 [details]
KDM with infinity-kdm theme
Comment 2 milady 2007-11-09 17:08:36 EST
Created attachment 253641 [details]
KDM with infinity theme
Comment 3 Alexei Podtelezhnikov 2007-11-09 18:58:41 EST
Looks like some fonts are missing.
Particularly, do you have liberation-fonts and dejavu-lgc-fonts?
Post your rpm -qa '*font*'
Comment 4 milady 2007-11-10 03:38:47 EST
I have both of them. Here's the output of rpm -qa '*font*':

$ rpm -qa '*font*'
tetex-fonts-3.0-41.fc8
lohit-fonts-tamil-2.1.5-3.fc8
lohit-fonts-punjabi-2.1.5-3.fc8
xorg-x11-fonts-ISO8859-1-100dpi-7.2-3.fc8
urw-fonts-2.4-1.fc8
lohit-fonts-bengali-2.1.5-3.fc8
lohit-fonts-gujarati-2.1.5-3.fc8
dejavu-fonts-2.20-1.fc8
fontconfig-2.4.2-5.fc8
dejavu-lgc-fonts-2.19-1
paktype-fonts-2.0-2.fc8
cjkunifonts-uming-0.1.20060928-4.fc8
jomolhari-fonts-0.003-4.fc8
lohit-fonts-kannada-2.1.5-3.fc8
xorg-x11-font-utils-7.2-2.fc8
xorg-x11-fonts-misc-7.2-3.fc8
xorg-x11-fonts-truetype-7.2-3.fc8
libXfont-1.3.1-1.fc8
libXfontcache-1.0.4-3.fc8
lohit-fonts-malayalam-2.1.5-3.fc8
baekmuk-ttf-fonts-gulim-2.2-6.fc8
lohit-fonts-telugu-2.1.5-3.fc8
lohit-fonts-oriya-2.1.5-3.fc8
xorg-x11-fonts-100dpi-7.2-3.fc8
fontconfig-2.4.2-5.fc8
sazanami-fonts-gothic-0.20040629-4.20061016.fc8
lklug-fonts-0.2.2-5.fc8
ghostscript-fonts-5.50-18.fc8
baekmuk-ttf-fonts-common-2.2-6.fc8
libfontenc-1.0.4-4.fc8
liberation-fonts-0.2-3.fc8
bitmap-fonts-0.3-5.1.2.fc7
lohit-fonts-hindi-2.1.5-3.fc8
kacst-fonts-1.6.2-2.fc8
xorg-x11-fonts-Type1-7.2-3.fc8

Comment 5 Alexei Podtelezhnikov 2007-11-10 15:59:36 EST
Strange. My resolution 1280x1024, so it's the same horizontally, and I don't 
see this. Maybe, font DPI is wrongly set. I have it disabled by default.
Comment 6 Alexei Podtelezhnikov 2007-11-10 21:31:41 EST
In bug 372201, this is related to NVIDIA driver. What do you use?
Comment 7 milady 2007-11-11 02:27:19 EST
My video card is Mobile Intel 945GM Integrated Graphics Controller. I think
Intel is providing free drivers so, it is allegedly fully supported.

How do you disable font DPI?
Comment 8 Alexei Podtelezhnikov 2007-11-11 09:20:31 EST
check you current DPI first
$ xdpyinfo | grep -B1 dot

Or better, find it out from log
$ grep DPI /var/log/Xorg.0.log

Does it correspond to your actual 1280 / horizontal monitor inches?
If not, it is a bug in the intel driver, and you should set it manually as 
described here:
http://gentoo-wiki.com/HOWTO_Set_DPI_(Dots_Per_Inch)

Comment 9 milady 2007-11-11 11:10:43 EST
My DPI seems to be approximately right:

$ xdpyinfo | grep -B1 dot
  dimensions:    1280x800 pixels (261x163 millimeters)
  resolution:    125x125 dots per inch

1280 x 25.4 / 125 = 260.096
 800 x 25.4 / 125 = 162.56

However, I get a different thing from the log:
(==) intel(0): DPI set to (100, 100)
...
(II) intel(0): Setting screen physical size to 261 x 163

Comment 10 Alexei Podtelezhnikov 2007-11-11 13:02:17 EST
So, xdpyinfo gets it right after, I suspect, KDE is loaded. 
What about KDM stage? Can you check it from vt console (ctrl-alt-F1) without
logging into a KDE session?

X.org itself clearly gets it wrong at 100x100 or picks wrong resolution. So you
should definitely try to set Mode, DisplaySize, and DPI in xorg.conf.
Comment 11 Alexei Podtelezhnikov 2007-11-11 13:08:37 EST
Bug 375311 is exactly like yours, and also with Intel 945GM.
You guys should work on this together.
Comment 12 milady 2007-11-11 14:14:37 EST
Here's the output of xdpyinfo in vt console:

$ xdpyinfo
xdpyinfo:  unable to open display "".

So, I guess you're right. xdpyinfo does not get any info if an X server is not
running.

I took a look at bug 375311. It really is exactly the same. If I hadn't replaced
the default hostname, I would probably have the text problem as well.

Unfortunately for me, it's not easy to modify my xorg.conf because I usually
dock my laptop and I use the dual head. I would rather keep my dual head than
have a pretty kdm.

Anyway, I tried to modify the DPI (Option DPI in Device section) and DisplaySize
 (in Monitor section) with my laptop off dock and it didn't do anything,
visually speaking. As far as the Xorg log is concerned, it now displays:

(**) intel(0): DPI set to (199,319)
(WW) intel(0): Option "DPI" is not used

I couldn't find enough info on setting the Mode in the xorg.conf manual...

Thank you very much for all your suggestions, I really appreciate your help.
Comment 13 Kevin Kofler 2007-11-12 07:24:59 EST

*** This bug has been marked as a duplicate of 253889 ***

Note You need to log in before you can comment on or make changes to this bug.