Bug 374711 - Kernel does not update with kmod
Kernel does not update with kmod
Status: CLOSED DUPLICATE of bug 330711
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
All Linux
low Severity urgent
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-10 10:05 EST by Adrin Jalali
Modified: 2014-01-21 18:00 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-14 15:15:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrin Jalali 2007-11-10 10:05:15 EST
Description of problem:
I reported this bug for last kernel release of development repository. When
using kmod, yum can not update kernel.This is the message : 

# yum update
Loading "fedorakmod" plugin
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package acl.i386 0:2.2.39-12.fc8 set to be updated
---> Package libacl-devel.i386 0:2.2.39-12.fc8 set to be updated
---> Package mono-data-oracle.i386 0:1.2.5.1-3.fc8 set to be updated
--> Processing Dependency: kernel-i686 = 2.6.23.1-42.fc8 for package:
kmod-fglrx-2.6.23.1-42.fc8
--> Processing Dependency: kernel-i686 = 2.6.23.1-42.fc8 for package:
kmod-ndiswrapper-2.6.23.1-42.fc8
---> Package mono-data-sqlite.i386 0:1.2.5.1-3.fc8 set to be updated
---> Package openldap-devel.i386 0:2.3.39-1.fc8 set to be updated
---> Package mono-core.i386 0:1.2.5.1-3.fc8 set to be updated
---> Package kdegraphics-libs.i386 7:3.5.8-7.fc8 set to be updated
--> Processing Dependency: kdegraphics = 7:3.5.8-7.fc8 for package: kdegraphics-libs
---> Package kernel.i686 0:2.6.23.1-49.fc8 set to be updated
---> Package mono-nunit.i386 0:1.2.5.1-3.fc8 set to be updated
---> Package selinux-policy.noarch 0:3.0.8-47.fc8 set to be updated
---> Package mono-web.i386 0:1.2.5.1-3.fc8 set to be updated
---> Package mono-data-postgresql.i386 0:1.2.5.1-3.fc8 set to be updated
---> Package openldap.i386 0:2.3.39-1.fc8 set to be updated
---> Package kernel-headers.i386 0:2.6.23.1-49.fc8 set to be updated
---> Package selinux-policy-targeted.noarch 0:3.0.8-47.fc8 set to be updated
---> Package mono-data.i386 0:1.2.5.1-3.fc8 set to be updated
---> Package bytefx-data-mysql.i386 0:1.2.5.1-3.fc8 set to be updated
---> Package mono-data-sybase.i386 0:1.2.5.1-3.fc8 set to be updated
---> Package mono-winforms.i386 0:1.2.5.1-3.fc8 set to be updated
---> Package kernel-devel.i686 0:2.6.23.1-49.fc8 set to be updated
---> Package kmod-fglrx.i686 0:8.42.3-8.lvn8 set to be updated
--> Processing Dependency: kmod-fglrx-2.6.23.1-49.fc8 for package: kmod-fglrx
--> Processing Dependency: kdegraphics = 7:3.5.8-5.fc8 for package: kdegraphics-libs
---> Package libacl.i386 0:2.2.39-12.fc8 set to be updated
---> Package openldap-clients.i386 0:2.3.39-1.fc8 set to be updated
--> Running transaction check
---> Package kdegraphics.i386 7:3.5.8-7.fc8 set to be updated
--> Processing Dependency: kernel-i686 = 2.6.23.1-42.fc8 for package:
kmod-fglrx-2.6.23.1-42.fc8
--> Processing Dependency: kernel-i686 = 2.6.23.1-42.fc8 for package:
kmod-ndiswrapper-2.6.23.1-42.fc8
---> Package kmod-fglrx-2.6.23.1-49.fc8.i686 0:8.42.3-8.lvn8 set to be updated
--> Finished Dependency Resolution
--> Running transaction check
---> Package acl.i386 0:2.2.39-12.fc8 set to be updated
---> Package libacl-devel.i386 0:2.2.39-12.fc8 set to be updated
---> Package kdegraphics.i386 7:3.5.8-7.fc8 set to be updated
---> Package mono-data-oracle.i386 0:1.2.5.1-3.fc8 set to be updated
--> Processing Dependency: kernel-i686 = 2.6.23.1-42.fc8 for package:
kmod-fglrx-2.6.23.1-42.fc8
--> Processing Dependency: kernel-i686 = 2.6.23.1-42.fc8 for package:
kmod-ndiswrapper-2.6.23.1-42.fc8
---> Package mono-data-sqlite.i386 0:1.2.5.1-3.fc8 set to be updated
---> Package openldap-devel.i386 0:2.3.39-1.fc8 set to be updated
---> Package mono-core.i386 0:1.2.5.1-3.fc8 set to be updated
---> Package kmod-fglrx-2.6.23.1-49.fc8.i686 0:8.42.3-8.lvn8 set to be updated
---> Package kdegraphics-libs.i386 7:3.5.8-7.fc8 set to be updated
---> Package kernel.i686 0:2.6.23.1-49.fc8 set to be installed
---> Package mono-nunit.i386 0:1.2.5.1-3.fc8 set to be updated
---> Package selinux-policy.noarch 0:3.0.8-47.fc8 set to be updated
---> Package mono-web.i386 0:1.2.5.1-3.fc8 set to be updated
---> Package kernel-devel.i686 0:2.6.23.1-35.fc8 set to be erased
---> Package mono-data-postgresql.i386 0:1.2.5.1-3.fc8 set to be updated
---> Package openldap.i386 0:2.3.39-1.fc8 set to be updated
---> Package kernel-headers.i386 0:2.6.23.1-49.fc8 set to be updated
---> Package selinux-policy-targeted.noarch 0:3.0.8-47.fc8 set to be updated
---> Package mono-data.i386 0:1.2.5.1-3.fc8 set to be updated
---> Package bytefx-data-mysql.i386 0:1.2.5.1-3.fc8 set to be updated
---> Package mono-data-sybase.i386 0:1.2.5.1-3.fc8 set to be updated
---> Package mono-winforms.i386 0:1.2.5.1-3.fc8 set to be updated
---> Package kernel-devel.i686 0:2.6.23.1-49.fc8 set to be installed
---> Package kmod-fglrx.i686 0:8.42.3-8.lvn8 set to be updated
---> Package libacl.i386 0:2.2.39-12.fc8 set to be updated
---> Package openldap-clients.i386 0:2.3.39-1.fc8 set to be updated
--> Finished Dependency Resolution
Error: Missing Dependency: kernel-i686 = 2.6.23.1-42.fc8 is needed by package
kmod-ndiswrapper-2.6.23.1-42.fc8
Error: Missing Dependency: kernel-i686 = 2.6.23.1-42.fc8 is needed by package
kmod-fglrx-2.6.23.1-42.fc8


As you see, i've installed fedorakmod plugin for yum. But still the problem
exists and packages can be installed in suitable order with rpm -i.
Comment 1 Takanori MATSUURA 2007-11-13 21:24:44 EST
Bug 375421 and Bug 362071 are the dup. of this Bug.

We should add something to recognize
  kernel-%{_target_cpu} = %{rpmversion}-%{pkg_release}%{?1}
in yum/config.py.

To escape this problem:
# yum install kernel-2.6.23.1-49.fc8
# yum update
Comment 2 Thorsten Leemhuis 2007-11-14 15:15:29 EST

*** This bug has been marked as a duplicate of 330711 ***

Note You need to log in before you can comment on or make changes to this bug.