Bug 375791 - parameter warning for smartd in logwatch output
parameter warning for smartd in logwatch output
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: smartmontools (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Smetana
Fedora Extras Quality Assurance
:
: 425975 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 06:41 EST by Bernd Bartmann
Modified: 2008-01-29 00:19 EST (History)
3 users (show)

See Also:
Fixed In Version: 5.37-7.3.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-29 00:19:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernd Bartmann 2007-11-11 06:41:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.8) Gecko/20071030 Fedora/2.0.0.8-2.fc8 Firefox/2.0.0.8

Description of problem:
The logwatch results that I get by email on my F8 system show the following warning about the smartd parameters:

--------------------- Smartd Begin ------------------------ 

 
 /dev/sda :
    Usage: Temperature_Celsius (194) changed to 
      175, 148, 151, 145, 151, 
 
 **Unmatched Entries**
 Problem creating device name scan list
 Device /dev/sda: ATA disk detected behind SAT layer
   Try adding '-d sat' to the device line in the smartd.conf file.
   For example: '/dev/sda -a -d sat'
 
 ---------------------- Smartd End ------------------------- 

BTW: Why is smartd not enabled by default?

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. enable smartd
2. wait for the logwatch email and look at the section for smartd
3.

Actual Results:


Expected Results:


Additional info:
Comment 1 Tomas Smetana 2007-11-12 03:29:07 EST
Have you configured the smartd?  Do you have smartd-config installed?  Could you
please attach your /etc/smartd.conf and provide additional info about what disk
you want to have monitored (type, device node...)?  Thanks.
Comment 2 Bernd Bartmann 2007-11-12 10:28:07 EST
I did not configure anything, so there is no /etc/smartd.conf I just enabled
smartd with ntsysv so that it is always started automatically.
IIRC /etc/smartd.conf was auto-generated in earlier versions.

The only config file I found is /etc/sysconfig/smartmontools:

[root@beverly vdr]# more /etc/sysconfig/smartmontools 
# command line options for smartd
smartd_opts="-q never"
# autogenerated config file options
# smartd_conf_opts="-H -m root"

smartd seems to be running fine in the background as I'm seeing lots of smart
infos in the logrotate emails. Here's the output of another system with 6 SATA
HDDs, 2 WDs and 4 Maxtors:

--------------------- Smartd Begin ------------------------ 

 
 /dev/sda :
    Usage: Temperature_Celsius (190) changed to 
      70, 71, 70, 69, 70, 70, 69, 70, 
    Usage: Temperature_Celsius (194) changed to 
      120, 121, 120, 119, 120, 119, 120, 
 
 /dev/sdb :
    Usage: Temperature_Celsius (194) changed to 
      120, 121, 119, 121, 120, 119, 121, 120, 121, 118, 122, 121, 
      122, 121, 120, 121, 121, 
 
 /dev/sdc :
    Prefailure: Seek_Time_Performance (8) changed to 
      252, 253, 252, 251, 250, 251, 253, 250, 247, 245, 244, 243, 
 
 /dev/sdd :
    Prefailure: Seek_Time_Performance (8) changed to 
      253, 252, 251, 250, 251, 253, 250, 247, 245, 244, 243, 
 
 /dev/sde :
    Prefailure: Seek_Time_Performance (8) changed to 
      253, 252, 251, 250, 251, 253, 249, 246, 245, 244, 243, 
 
 /dev/sdf :
    Prefailure: Seek_Time_Performance (8) changed to 
      253, 252, 251, 250, 251, 253, 250, 247, 245, 244, 243, 
 
 **Unmatched Entries**
 Problem creating device name scan list
 Device /dev/sda: ATA disk detected behind SAT layer
   Try adding '-d sat' to the device line in the smartd.conf file.
   For example: '/dev/sda -a -d sat'
 Device /dev/sdb: ATA disk detected behind SAT layer
   Try adding '-d sat' to the device line in the smartd.conf file.
   For example: '/dev/sdb -a -d sat'
 Device /dev/sdc: ATA disk detected behind SAT layer
   Try adding '-d sat' to the device line in the smartd.conf file.
   For example: '/dev/sdc -a -d sat'
 Device /dev/sdd: ATA disk detected behind SAT layer
   Try adding '-d sat' to the device line in the smartd.conf file.
   For example: '/dev/sdd -a -d sat'
 Device /dev/sde: ATA disk detected behind SAT layer
   Try adding '-d sat' to the device line in the smartd.conf file.
   For example: '/dev/sde -a -d sat'
 Device /dev/sdf: ATA disk detected behind SAT layer
   Try adding '-d sat' to the device line in the smartd.conf file.
   For example: '/dev/sdf -a -d sat'
 Problem creating device name scan list
 Device /dev/sda: ATA disk detected behind SAT layer
   Try adding '-d sat' to the device line in the smartd.conf file.
   For example: '/dev/sda -a -d sat'
 Device /dev/sdb: ATA disk detected behind SAT layer
   Try adding '-d sat' to the device line in the smartd.conf file.
   For example: '/dev/sdb -a -d sat'
 Device /dev/sdc: ATA disk detected behind SAT layer
   Try adding '-d sat' to the device line in the smartd.conf file.
   For example: '/dev/sdc -a -d sat'
 Device /dev/sdd: ATA disk detected behind SAT layer
   Try adding '-d sat' to the device line in the smartd.conf file.
   For example: '/dev/sdd -a -d sat'
 Device /dev/sde: ATA disk detected behind SAT layer
   Try adding '-d sat' to the device line in the smartd.conf file.
   For example: '/dev/sde -a -d sat'
 Device /dev/sdf: ATA disk detected behind SAT layer
   Try adding '-d sat' to the device line in the smartd.conf file.
   For example: '/dev/sdf -a -d sat'
 
 ---------------------- Smartd End ------------------------- 

 
Comment 3 Derkjan de Haan 2007-11-15 08:01:35 EST
I have run into this issue as well. The problem seems to me that the init 
script tries to generate /etc/smartd.conf from a file called smartd-conf.py, 
but fails as this file is not installed (it is not part of the smartmontools 
package).

It is however part of the smartmontools-config package, but this package is not 
installed when doing a fresh install.

IMHO the solution is to make smartmontools require the smartmontools-config 
package. Or merge the smartmontools and smartmontools-config packages, I think 
it's a bit overzealous to have separate packages for this.

Comment 4 Tomas Smetana 2007-11-27 05:29:57 EST
The packages were split because the python script has awful dependencies and the
users who can create their own config file don't want the load of useless
packages.  The bug is that the smartd.conf file is actually not installed with
the base package.  Will be fixed in the next release.
Comment 5 Bernd Bartmann 2007-12-11 12:41:40 EST
I'm now on smartmontools-5.37-7.1.fc8. Yesterday the messages in the logwatch
email were ok:

 --------------------- Smartd Begin ------------------------ 

 
 /dev/sda :
    Usage: Temperature_Celsius (194) changed to 
      145, 151, 145, 151, 145, 151, 
 
 ---------------------- Smartd End ------------------------- 

But today the errors are back:

--------------------- Smartd Begin ------------------------ 

 
 /dev/sda :
    Usage: Temperature_Celsius (194) changed to 
      169, 151, 
 
 **Unmatched Entries**
 Problem creating device name scan list
 Device /dev/sda: ATA disk detected behind SAT layer
   Try adding '-d sat' to the device line in the smartd.conf file.
   For example: '/dev/sda -a -d sat'
 
 ---------------------- Smartd End ------------------------- 
Comment 6 Tomas Smetana 2007-12-12 09:59:09 EST
The problem is that the /etc/smartd.conf is missing or contains some errors. 
You need to configure smartd in order to use it.  You can write the config file
yourself (the man page contains a sample configuration) or install the
smartmontools-config package.

I'm building an update that will contain the sample config file and write it in
/etc/smartd.conf.
Comment 7 Ville Skyttä 2007-12-12 11:17:50 EST
Hm, I suggested in bug 241389 that smartmontools-config would be included in the
default installation, maybe that was forgotten?

I suppose changing smartmontools to smartmontools-config in comps-f[89].xml's
"base" group would do the trick.
Comment 8 Fedora Update System 2007-12-12 14:59:46 EST
smartmontools-5.37-7.2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update smartmontools'
Comment 9 Bernd Bartmann 2007-12-13 12:30:50 EST
Hmm, either yum ignores the updates-testing repo although it has been specified
or  the updates is not available:

[root@riker ~]# yum clean all
Cleaning up Everything

[root@riker ~]# yum --enablerepo=updates-testing update smartmontools
updates-testing           100% |=========================| 2.3 kB    00:00     
livna                     100% |=========================| 2.1 kB    00:00     
primary.sqlite.bz2        100% |=========================| 153 kB    00:01     
fedora                    100% |=========================| 2.1 kB    00:00     
primary.sqlite.bz2        100% |=========================| 4.9 MB    00:03     
adobe-linux-i386          100% |=========================|  951 B    00:00     
primary.xml.gz            100% |=========================| 1.3 kB    00:00     
adobe-linu: ################################################## 2/2
updates                   100% |=========================| 2.3 kB    00:00     
primary.sqlite.bz2        100% |=========================| 898 kB    00:00     
Setting up Update Process
Could not find update match for smartmontools
No Packages marked for Update
Comment 10 Bernd Bartmann 2007-12-16 06:39:54 EST
Ok, yesterday I got smartmontools-5.37-7.2.fc8 from updates-testing. Today I
have this in my logwatch report:

--------------------- Smartd Begin ------------------------ 

 
 /dev/sda :
    Usage: Temperature_Celsius (194) changed to 
      175, 148, 151, 
 
 **Unmatched Entries**
 Drive: DEVICESCAN, implied '-a' Directive on line 28 of file /etc/smartd.conf
 Problem creating device name scan list
 Device /dev/sda: ATA disk detected behind SAT layer
   Try adding '-d sat' to the device line in the smartd.conf file.
   For example: '/dev/sda -a -d sat'
 
 ---------------------- Smartd End ------------------------- 
Comment 11 Tomas Smetana 2007-12-17 02:42:28 EST
You're out of luck: DEVICESCAN can't detect your hardware properly and you'll
have to configure the program yourself -- comment #6, first paragraph.
Comment 12 Tomas Smetana 2008-01-02 02:05:24 EST
*** Bug 425975 has been marked as a duplicate of this bug. ***
Comment 13 Bernd Bartmann 2008-01-02 07:19:17 EST
Ok, now I made the smartd.conf manually and everything works as expected.
Anyway, I think that smartd should be able to detect all disks correctly by
itself. Is there any technical reason that this is not possible?

The excerpt from comment #10 is a Samsung SATA disk attached to a Intel ICH5
chipset which I think can be called a "standard controller".
Comment 14 Need Real Name 2008-01-02 09:20:06 EST
The smartd-conf.py did NOT generate a correct script for me.
It detected my devices as:
/dev/sdc -d ata -H -m root
/dev/sdb -d ata -H -m root
/dev/sda -d ata -H -m root

which gave me syslog errors of form:
smartd[4138]: smartd version 5.37 [i386-redhat-linux-gnu] Copyright (C) 2002-6
Bruce Allen
smartd[4138]: Home page is http://smartmontools.sourceforge.net/#012
smartd[4138]: No configuration file /etc/smartd.conf found, scanning devices
smartd[4138]: Problem creating device name scan list
smartd[4138]: Device: /dev/sda, opened
smartd[4138]: Device /dev/sda: ATA disk detected behind SAT layer
smartd[4138]:   Try adding '-d sat' to the device line in the smartd.conf file.
smartd[4138]:   For example: '/dev/sda -a -d sat'
smartd[4138]: Device: /dev/sdb, opened
smartd[4138]: Device /dev/sdb: ATA disk detected behind SAT layer
smartd[4138]:   Try adding '-d sat' to the device line in the smartd.conf file.
smartd[4138]:   For example: '/dev/sdb -a -d sat'
smartd[4138]: Device: /dev/sdc, opened
smartd[4138]: Device /dev/sdc: ATA disk detected behind SAT layer
smartd[4138]:   Try adding '-d sat' to the device line in the smartd.conf file.
smartd[4138]:   For example: '/dev/sdc -a -d sat'

Note that in FC6 I used /dev/hda and /dev/hdb (without any -d) for my IDE
devices and /dev/sda -d ata for a third pata device mounted on a third connector.

My guess is this change has something to do with the way /dev/hda was changed to
/dev/sda in recent release. Has the smartd config script been updated to take
that into account?

Thanks
Comment 15 Need Real Name 2008-01-02 09:24:09 EST
In fact, the smartd man page notes this:

       # An ATA disk may appear as a SCSI device to the
       # OS. If a SCSI to ATA Translation (SAT) layer
       # is between the OS and the device then this can be
       # flagged with the '-d sat' option. This situation
       # may become common with SATA disks in SAS and FC
       # environments.
         /dev/sda -a -d sat

So, it seems that smartd-conf.py does not yet know how to properly deal with the
SCSI to ATA translation (SAT) layer. Though interestingly, the smartd daemon
itself can identify the issue.

Can someone verify whether smartd-conf.py indeed has been updated to take this
into account?
Comment 16 Tomas Smetana 2008-01-02 09:43:29 EST
(In reply to comment #14)

> smartd[4138]: Problem creating device name scan list
> smartd[4138]: Device: /dev/sda, opened
> smartd[4138]: Device /dev/sda: ATA disk detected behind SAT layer
> smartd[4138]:   Try adding '-d sat' to the device line in the smartd.conf file.
> smartd[4138]:   For example: '/dev/sda -a -d sat'

Despite these messages smartd seems to be running and monitoring the device (at
least on my system with DEVICESCAN in the config file). The next message is:

smartd[9561]: Monitoring 1 ATA and 0 SCSI devices

But you're right that the 'ata' option should be changed to 'sat' in the script
to get rid of the messages.
Comment 17 Fedora Update System 2008-01-18 18:57:08 EST
smartmontools-5.37-7.3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update smartmontools'
Comment 18 Fedora Update System 2008-01-29 00:18:58 EST
smartmontools-5.37-7.3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.