Bug 376881 - Gramps fails to start from gnome
Gramps fails to start from gnome
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gramps (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
: 252356 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 22:14 EST by Skip Egdorf
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.2.8-6.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-12 19:13:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Skip Egdorf 2007-11-11 22:14:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.8) Gecko/20071030 Fedora/2.0.0.8-2.fc8 Firefox/2.0.0.8

Description of problem:
Gramps fails to start.
Installed on a newly-loaded FC8, Gramps fails with a bug-buddy window.
I re-installed on a new system, "gilly" in the transcript below, from FC8 DVD, New disk with standard layout, only customization was to include both user and developer, no other package customization. Patches updated to November 11, Then "yum install gramps"
Console output with a few annotations follows:

[joe-user@gilly ~]$ su -
Password: 
[root@gilly ~]# uname -a
Linux gilly.egdorf.home 2.6.23.1-49.fc8 #1 SMP Thu Nov 8 21:41:26 EST 2007 i686 athlon i386 GNU/Linux
[root@gilly ~]# logout

[joe-user@gilly ~]$ su -
Password: 
[root@gilly ~]# uname -a
Linux gilly.egdorf.home 2.6.23.1-49.fc8 #1 SMP Thu Nov 8 21:41:26 EST 2007 i686 athlon i386 GNU/Linux
[root@gilly ~]# yum list gramps
Available Packages
gramps.noarch                            2.2.8-3.fc8            fedora          
[root@gilly ~]# yum install gramps
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package gramps.noarch 0:2.2.8-3.fc8 set to be updated
--> Processing Dependency: freefont for package: gramps
--> Processing Dependency: gnome-python2-gtkspell for package: gramps
--> Processing Dependency: graphviz for package: gramps
--> Running transaction check
---> Package gnome-python2-gtkspell.i386 0:2.19.1-9.fc8 set to be updated
---> Package freefont.noarch 0:20060126-4.fc7 set to be updated
---> Package graphviz.i386 0:2.14.1-3.fc8 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 gramps                  noarch     2.2.8-3.fc8      fedora             17 M
Installing for dependencies:
 freefont                noarch     20060126-4.fc7   fedora            2.0 M
 gnome-python2-gtkspell  i386       2.19.1-9.fc8     fedora             16 k
 graphviz                i386       2.14.1-3.fc8     fedora            1.1 M

Transaction Summary
=============================================================================
Install      4 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 20 M
Is this ok [y/N]: y
Downloading Packages:
(1/4): graphviz-2.14.1-3. 100% |=========================| 1.1 MB    00:07     
(2/4): freefont-20060126- 100% |=========================| 2.0 MB    00:12     
(3/4): gnome-python2-gtks 100% |=========================|  16 kB    00:00     
(4/4): gramps-2.2.8-3.fc8 100% |=========================|  17 MB    01:48     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: graphviz                     ######################### [1/4] 
  Installing: gnome-python2-gtkspell       ######################### [2/4] 
  Installing: freefont                     ######################### [3/4] 
  Installing: gramps                       ######################### [4/4] 

Installed: gramps.noarch 0:2.2.8-3.fc8
Dependency Installed: freefont.noarch 0:20060126-4.fc7 gnome-python2-gtkspell.i386 0:2.19.1-9.fc8 graphviz.i386 0:2.14.1-3.fc8
Complete!
[root@gilly ~]# ^D
[joe-user@gilly ~]$ which gramps
/usr/bin/gramps
[joe-user@gilly ~]$ gramps
143977b1-481f-74d7-7ae449e6-334372aa is dumped
[joe-user@gilly ~]$ 

        At this point bug-buddy tells me that Gramps isn't in the list of support Gnome stuff,
        But I might save a bug report. I Cancel.

[joe-user@gilly ~]$ python -V
Python 2.5.1
[joe-user@gilly ~]$ 

        A little more information comes from running the Gramps python code directly with a -v.

[joe-user@gilly ~]$ python -v /usr/share/gramps/gramps.py
        ...
        Several pages of imports removed
        ...
import hashlib # precompiled from /usr/lib/python2.5/hashlib.pyc
dlopen("/usr/lib/python2.5/lib-dynload/_hashlib.so", 2);
import _hashlib # dynamically loaded from /usr/lib/python2.5/lib-dynload/_hashlib.so
# /usr/share/gramps/DisplayTabs/_LocationEmbedList.pyc matches /usr/share/gramps/DisplayTabs/_LocationEmbedList.py
import DisplayTabs._LocationEmbedList # precompiled from /usr/share/gramps/DisplayTabs/_LocationEmbedList.pyc
# /usr/share/gramps/DisplayTabs/_LocationModel.pyc matches /usr/share/gramps/DisplayTabs/_LocationModel.py
import DisplayTabs._LocationModel # precompiled from /usr/share/gramps/DisplayTabs/_LocationModel.pyc
# /usr/share/gramps/DisplayTabs/_MediaBackRefList.pyc matches /usr/share/gramps/DisplayTabs/_MediaBackRefList.py
import DisplayTabs._MediaBackRefList # precompiled from /usr/share/gramps/DisplayTabs/_MediaBackRefList.pyc
# /usr/share/gramps/DisplayTabs/_NameEmbedList.pyc matches /usr/share/gramps/DisplayTabs/_NameEmbedList.py
import DisplayTabs._NameEmbedList # precompiled from /usr/share/gramps/DisplayTabs/_NameEmbedList.pyc
# /usr/share/gramps/DisplayTabs/_NameModel.pyc matches /usr/share/gramps/DisplayTabs/_NameModel.py
import DisplayTabs._NameModel # precompiled from /usr/share/gramps/DisplayTabs/_NameModel.pyc
# /usr/share/gramps/DisplayTabs/_NoteTab.pyc matches /usr/share/gramps/DisplayTabs/_NoteTab.py
import DisplayTabs._NoteTab # precompiled from /usr/share/gramps/DisplayTabs/_NoteTab.pyc
# /usr/share/gramps/Spell.pyc matches /usr/share/gramps/Spell.py
import Spell # precompiled from /usr/share/gramps/Spell.pyc
dlopen("/usr/lib/python2.5/site-packages/gtk-2.0/gtkspell.so", 2);
import gtkspell # dynamically loaded from /usr/lib/python2.5/site-packages/gtk-2.0/gtkspell.so
4c714209-08dd-6865-3dc8f915-798b0708 is dumped
[joe-user@gilly ~]$ 

      It seems that gramps dies just after gtkspell is imported.
      At this point, I send this to you guys.
[egdorf@dilbert ~]$ 





Version-Release number of selected component (if applicable):
gramps-2.2.8-3.fc8

How reproducible:
Always


Steps to Reproduce:
1.Install Fedora 8 i386. I used two different Athlon XPs
2.Yum install gramps
3./usr/bin/gramps

Actual Results:
Gramps fails to start with a bug-buddy window.

Expected Results:
Grapms should have started.

Additional info:
The two systems tried were both i386 Athlon XP's, plenty of memory, IDE disk.

I'll be glad to provide any help I can including (if needed) ssh access to the clean-build system. Let me know what I can do.
Comment 1 Brian Pepple 2007-11-11 23:06:36 EST
I can reproduce this bug on my test machine.  Marking as ASSIGNED.
Comment 2 Skip Egdorf 2007-11-11 23:07:59 EST
he ubuntu folks have seen this as well. Seems to be a gtkspell problem.

I can reproduce the problem more simply with:

[egdorf@dilbert .gramps]$ python
Python 2.5.1 (r251:54863, Oct 30 2007, 13:54:11) 
[GCC 4.1.2 20070925 (Red Hat 4.1.2-33)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import gtk
>>> import gtkspell
>>> import locale
>>> lang = locale.getlocale()[0]
>>> if lang == None: print "lang is None"
... else: gtkspell.Spell(gtk.TextView()).set_language(lang)
... 
61338e87-99be-1658-0c098d80-74c8d99a is dumped
[egdorf@dilbert .gramps]$ 
Comment 3 Skip Egdorf 2007-11-11 23:10:55 EST
This has been submitted to the gtkspell folks at sourceforge as
http://sourceforge.net/tracker/index.php?func=detail&aid=1802122&group_id=7896&atid=107896
Comment 4 Skip Egdorf 2007-11-11 23:19:32 EST
Following the Ubuntu discussion, i can workaround the problem in gramps by the
following edit that disables gtkspell checking.
in /usr/share/gramps, comment out three lines in Spell.py that access gtkspell

[root@dilbert gramps]# diff Spell.py Spell.py.orig
52,54c52,54
< #    else:
< #        gtkspell.Spell(gtk.TextView()).set_language(lang)
< #        success = True
---
>     else:
>         gtkspell.Spell(gtk.TextView()).set_language(lang)
>         success = True
[root@dilbert gramps]#

Gramps then starts and seems to run correctly.
It is a hack, and the real problem seems to be with gtkspell, but if anyone
really needs to trace their ancestors, this is a way...
Comment 5 Skip Egdorf 2007-11-11 23:31:47 EST
And following through to the end,
The gramps folks have a workaround for the gtkspell bug That I have tried in
Spell.py

[root@dilbert gramps]# diff Spell.py Spell.py.orig
53,54c53
<         tv = gtk.TextView()
<         gtkspell.Spell(tv).set_language(lang)
---
>         gtkspell.Spell(gtk.TextView()).set_language(lang)
[root@dilbert gramps]# 

With this fix, spelling is left turned on and gramps works.

This is gramps bug 0001272 and they seem to have the workaround in 2.2.9.
Perhaps fedora just needs to update.
Comment 6 Brian Pepple 2007-11-11 23:35:20 EST
Yeah, this is a pretty easy one to fix.  I know the fix is already in
gramp-2.2.9,  and it's a simple backport to do.  I should have something ready
later tonight to kick out to fedora-updates.
Comment 7 Skip Egdorf 2007-11-11 23:49:20 EST
Brian, Thanks for looking at this. If this is the worst thing we find in FC8,
we'll be in good shape! I appreciate all the hard work!
Comment 8 Brian Pepple 2007-11-12 00:41:53 EST
(In reply to comment #7)
> Brian, Thanks for looking at this. If this is the worst thing we find in FC8,
> we'll be in good shape! I appreciate all the hard work!

No problem.  Thanks for the bug report, and all the leg work you did on this. 
With any luck, I can get this fix in tomorrow's fedora-updates push.

Comment 9 Brian Pepple 2007-11-12 13:51:01 EST
*** Bug 252356 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2007-11-12 19:13:09 EST
gramps-2.2.8-6.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.