This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 382251 - perl-POE-Component-IRC uses nonexistent %{_fixperms} macro
perl-POE-Component-IRC uses nonexistent %{_fixperms} macro
Status: CLOSED DUPLICATE of bug 382091
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
: 382221 382241 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-14 06:39 EST by Lubomir Kundrak
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 03:48:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubomir Kundrak 2007-11-14 06:39:49 EST
Description of problem:

sh: line 0: fg: no job control
sh: line 0: fg: no job control
Building target platforms: i686
Building for target i686
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.25289
+ umask 022
+ cd /usr/src/redhat/BUILD
+ LANG=C
+ export LANG
+ unset DISPLAY
+ cd /usr/src/redhat/BUILD
+ rm -rf POE-Component-IRC-5.29
+ /bin/gzip -dc /usr/src/redhat/SOURCES/POE-Component-IRC-5.29.tar.gz
+ tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd POE-Component-IRC-5.29
+ '%{_fixperms}' Changes MANIFEST MANIFEST.SKIP META.yml Makefile.PL README docs
examples inc lib t
/var/tmp/rpm-tmp.25289: line 36: fg: no job control
error: Bad exit status from /var/tmp/rpm-tmp.25289 (%prep)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.25289 (%prep)

Version-Release number of selected component (if applicable):

Today's rawhide
Comment 1 Chris Weyl 2007-11-14 11:05:40 EST
%{_fixperms} has been around since the dim mists of antiquity.  (at least RH7.x;
I wasn't playing with rpms in my RH4.x days :))

If %{_fixperms} has disappeared from today's rawhide, this isn't a PoCo::IRC
problem; it's an rpm bug that the rpm package isn't delivering this macro.
Comment 2 Chris Weyl 2007-11-14 11:53:29 EST
*** Bug 382221 has been marked as a duplicate of this bug. ***
Comment 3 Chris Weyl 2007-11-14 11:53:37 EST
*** Bug 382241 has been marked as a duplicate of this bug. ***
Comment 4 Panu Matilainen 2007-11-14 14:30:53 EST
%{_fixperms} macro hasn't gone anywhere. Whatever the problems here, it starts
earlier than that:
sh: line 0: fg: no job control
sh: line 0: fg: no job control
Comment 5 Panu Matilainen 2007-11-15 03:48:20 EST
This is a side-effect of the switch to NSS - crypto isn't initialized early
enough in case of mock and such, so packages fail to install due to (false)
md5sum failures.

*** This bug has been marked as a duplicate of 382091 ***

Note You need to log in before you can comment on or make changes to this bug.