Bug 388701 - RFE: integrated PPP support
RFE: integrated PPP support
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
i386 Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: 136662 380771 (view as bug list)
Depends On: 296851
  Show dependency treegraph
Reported: 2007-11-17 14:15 EST by Kevin DeKorte
Modified: 2009-01-09 02:26 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-01-09 02:26:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Kevin DeKorte 2007-11-17 14:15:03 EST
Description of problem:
ppp connections are no longer shown in nm-applet - regression

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. open up nm-applet and dialup/ppp connections are not shown
Actual results:
no ppp connections in drop down menu

Expected results:
ppp connections were listed in dropdown, worked fine in F7

Additional info:
yum upgrade from f7 to f8
Comment 1 Kevin DeKorte 2007-11-25 10:03:13 EST
Is there any information I can provide to progress on solving this regression?
Comment 2 Andrea Santilli 2007-11-25 18:47:42 EST
it looks like this is the same bug i reported at 380771 2 weeks ago
still no answers there either...

and of course no alternatives to network manager
Comment 3 Dan Williams 2007-12-03 10:25:51 EST
The PPP support in NM never worked well (didn't allow VPN overlays because it
was really just calling "ifup <connection>" underneath); it's been ripped out
and replaced with a more robust mechanism which will be coming along soon.  It's
already in uptsream SVN and works with 3G connections.  What specific type of
PPP are you using?  3G card?  serial modem?  ISDN?  PPPoE?
Comment 4 Kevin DeKorte 2007-12-03 10:37:01 EST
It is a 3G card. 
Specifically a Sprint EX720 which Linux sees as /dev/ttyUSB0 (thinks it is a GSM
Comment 5 Dan Poler 2007-12-03 10:44:26 EST
3G card here as well that Linux sees as /dev/ttyACM0.
Comment 6 Dan Williams 2007-12-03 11:17:32 EST
Mobile broadband cards are the current target of the upstream PPP work that
landed last week.  It's currently GSM-based cards only, but since I have access
to CDMA cards only (and they are less complicated than GSM-based cards) it won't
be hard to add support for CDMA cards too.

@dan: which specific card do you have?  Sierra? Novatel?  What bus does it use,
PCMCIA, CardBus, etc?  I don't immediately recognize what bus creates devices
with the ACM prefix...
Comment 7 Dan Poler 2007-12-03 11:28:41 EST
Hi Dan,

It's a Verizon Wireless PC5750, which appears to be manufactured by Audiovox
based on this link: http://www.evdoinfo.com/content/view/863/40/

EV-DO Rev. A. It's extremely simple; With Verizon cards I have always just
addressed the device (be it ttyUSB0 or ttyACM0) as a modem and for Verizon
dialed #777. No special init string is required like for the GSM cards.

Let me know if you need more info.
Comment 8 Dan Williams 2007-12-03 11:33:13 EST
That looks good, I have a Sierra Wireless Aircard 860 which is also PCMCIA which
I'm using for testing, so PCMCIA support should work fine when we're all said
and done.

I'm going to use this bug as a tracker for the well-integrated PPP support
that's coming soon.  There will be another bug for Mobile Broadband card support
specifically (bug 296851).  Please put all 3G type stuff in that bug, and we'll
keep this one as a general PPP tracker (on which the 3G support obviously depends).
Comment 9 Dan Williams 2007-12-03 11:33:43 EST
*** Bug 380771 has been marked as a duplicate of this bug. ***
Comment 10 Dan Williams 2007-12-03 12:04:30 EST
*** Bug 136662 has been marked as a duplicate of this bug. ***
Comment 11 Jim Webb 2007-12-03 12:38:45 EST
Dan W., I have a Sierra Wireless Aircard 875 through Cingular/At&T.  Using F8 on
a Thinkpad T60.  Let me know if I can be of any assistance testing or whatever.
Comment 12 Kevin DeKorte 2007-12-03 14:44:40 EST
Should have todays update for F8
0.7.0-0.6.6.svn3109 done anything for this issue?
Comment 13 Dan Williams 2007-12-03 16:15:57 EST
@kevin: no, the upstream PPP stuff dropped after 3109 was rolled.
Comment 14 Dan Poler 2007-12-04 21:00:04 EST
I can confirm no change of behavior with regard to PPP in the 3109 version;
other issues with this version documented under other tickets (411411) as well. 
Comment 15 Dan Williams 2007-12-05 14:28:31 EST
Note that while I will work on PPP bugs in _Fedora_ NM as I have time and when
more important things aren't breathing down my neck, the PPP functionality is
present in the latest builds.  You can try it out by doing the right thing with
a .fdi file to attach the modem capability to your card.
Comment 16 Kevin DeKorte 2007-12-06 20:25:12 EST
Can you explain what these .fdi files are and where they go. I got the latest
version of NM from Koji and I still don't see NM picking up my 3G card and I
don't see any .fdi files in the package so I don't have anything to see as an
Comment 17 Miroslav Pragl 2007-12-28 08:14:30 EST
Same problem here. NM in FC7 automatically offered ppp connections created 
using system-config-network but the FC8 version lacks ppp support

Comment 18 Nikolay Vladimirov 2008-04-09 13:03:24 EDT
Any progress?
I'm using latest rawhide and NetworkManager doesn't recognise my PPPoE
connection made by system-config-network with enabled NM control .
It's not in the DSL tab in NM "Edit Connections...".

Comment 19 Dan Williams 2008-04-10 13:02:43 EDT
@nikolay: NM does not recognize PPPoE system connections yet.

@miroslav: is this for normal modems, 3G cards, Bluetooth DUN, or PPPoE?
Comment 20 Miroslav Pragl 2008-07-31 07:07:34 EDT
for any generic (/dev/modem) modems

Comment 21 Bug Zapper 2008-11-26 03:32:21 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 22 Bug Zapper 2009-01-09 02:26:52 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.