Bug 396891 - touchpad fails to work, synaptics is missing symbols
touchpad fails to work, synaptics is missing symbols
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: synaptics (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
: Reopened
: 384311 396291 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-23 10:20 EST by Caolan McNamara
Modified: 2008-04-04 00:45 EDT (History)
6 users (show)

See Also:
Fixed In Version: synaptics-0.14.6-11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 00:45:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to add to make work (2.84 KB, patch)
2007-11-23 10:20 EST, Caolan McNamara
no flags Details | Diff
Patches for current git snapshot (2.03 KB, application/x-bzip)
2007-11-24 18:45 EST, Quentin Armitage
no flags Details

  None (edit)
Description Caolan McNamara 2007-11-23 10:20:18 EST
Description of problem:

My mouse doesn't work, symbols like miPointerGetMotionEvents etc are logged as
missing in my X.log. So attached is a patch to add to synaptics to make it build
and get my mousepad working again against rawhide X.
Comment 1 Caolan McNamara 2007-11-23 10:20:18 EST
Created attachment 267581 [details]
patch to add to make work
Comment 2 Quentin Armitage 2007-11-24 18:45:22 EST
Created attachment 268151 [details]
Patches for current git snapshot
Comment 3 Alexandre Oliva 2007-11-25 12:33:59 EST
*** Bug 384311 has been marked as a duplicate of this bug. ***
Comment 4 Alexandre Oliva 2007-11-25 12:34:17 EST
*** Bug 396291 has been marked as a duplicate of this bug. ***
Comment 5 Caolan McNamara 2007-11-30 13:42:43 EST
I wonder why we don't use the latest upstream version of synaptics-0.14.6.tar as
our base. Nevertheless I just built the old one tweaked to build and work again
so I have a working touchpad.
Comment 6 Alexandre Oliva 2007-12-07 07:45:29 EST
Things got much worse with synaptics-0.14.6-11, now the touchpad doesn't work at
all, and its backup emulation doesn't kick in because the module is loaded
successfully :-(  I don't see anything relevant in the X log files.
Comment 7 Alexandre Oliva 2008-02-18 01:40:38 EST
FWIW, changing my xorg.conf from this (that works on F8 and earlier):

Section "ServerLayout"
        Identifier     "nv"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Synaptics" "AlwaysCore"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

to:

Section "ServerLayout"
	Identifier     "nv"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
	InputDevice    "Synaptics" "CorePointer"
	InputDevice    "Mouse0" "AlwaysCore"
EndSection

makes it work again.

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "yes"
EndSection

Section "InputDevice"
	Identifier  "Synaptics"
	Driver      "synaptics"
	Option	    "Device" "/dev/input/mice"
	Option	    "Protocol" "auto-dev"
	Option	    "Emulate3Buttons"   "yes"
        [a bunch of other options touchpad options omitted]
EndSection

Any reason why we can't keep both working?
Comment 8 Charles R. Anderson 2008-04-04 00:45:37 EDT
Works for me with your config above, or with my config below, or without any
config file at all on latest rawhide.  I no longer see any differences at all no
matter which method I use.  Closing.

Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Synaptics" "CorePointer"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us+inet"
EndSection

Section "InputDevice"
        Identifier  "Synaptics"
        Driver      "synaptics"
        Option      "Device" "/dev/input/mice"
        Option      "Protocol" "auto-dev"
        Option      "Emulate3Buttons" "yes"
EndSection

Note You need to log in before you can comment on or make changes to this bug.