Bug 399041 - If a map entry is > 255 chars, automounter fails
If a map entry is > 255 chars, automounter fails
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: autofs (Show other bugs)
5.1
All Linux
medium Severity high
: rc
: ---
Assigned To: Ian Kent
Brock Organ
: Regression
Depends On:
Blocks: 425915
  Show dependency treegraph
 
Reported: 2007-11-25 23:10 EST by Ian Kent
Modified: 2008-05-21 10:38 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0354
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:38:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix off-by-one error for lookup of map keys exactly 255 characters long. (1.86 KB, patch)
2007-11-25 23:10 EST, Ian Kent
no flags Details | Diff

  None (edit)
Comment 1 Ian Kent 2007-11-25 23:10:17 EST
Created attachment 268451 [details]
Patch to fix off-by-one error for lookup of map keys exactly 255 characters long.
Comment 2 Ian Kent 2007-11-25 23:20:37 EST
The RHTS test for bz195679 has uncovered a bug in autofs
version 5 for lookups of keys that are exactly the maximum
length allowed. This length is 255 and is defined in kernel
include files and is used in the definition of the autofs
kernel request packet.

The test, bz195679, itself creates a test map with a key
greater than 255 characters and so needs to be corrected
to create a key of exactly 255 characters to test for this
bug. Since bug 195679 concerns map entries (key plus mount
target) greater than 255 characters the test will continue
to verify the original issue.
Comment 3 RHEL Product and Program Management 2007-11-25 23:24:17 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 RHEL Product and Program Management 2007-11-25 23:25:17 EST
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 6 Ian Kent 2007-12-09 20:44:37 EST
A correction for this issue has been included in
autofs-5.0.1-0.rc2.68 and later.

The rhts test bugzillas/bz195679 within the autofs
workflow has been updated and can be used to verify
this bug.
Comment 10 errata-xmlrpc 2008-05-21 10:38:36 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0354.html

Note You need to log in before you can comment on or make changes to this bug.