Bug 410651 - New flash plugin not working for konqueror
New flash plugin not working for konqueror
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lukáš Tinkl
Fedora Extras Quality Assurance
:
: 426361 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-04 11:45 EST by Sammy
Modified: 2015-07-13 13:36 EDT (History)
6 users (show)

See Also:
Fixed In Version: 3.5.8-30.fc7.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-27 02:10:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
gtk_init for nsplugin (3.13 KB, patch)
2007-12-04 11:46 EST, Sammy
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 132138 None None None Never
Novell 348088 None None None Never

  None (edit)
Description Sammy 2007-12-04 11:45:01 EST
Just release flash plugin 9.0.115.0 crashes with gtk_init(0,0) message
in konqueror. This had been a known problem with the beta versions since
the 9.0.48 release, which seems to work.

One of the problems is that flash plugin is not calling gtk_init. There
is a patch for this which seems to solve this problem BUT I still do not
get a working flash after this. I will attach this patch. For testing
youtube videos one can look at:

           http://www.youtube.com/swf_test.html

This should give the plugin version and have a black video screen with busy
signal.
Comment 1 Sammy 2007-12-04 11:46:12 EST
Created attachment 277151 [details]
gtk_init for nsplugin
Comment 2 Rex Dieter 2007-12-04 11:50:35 EST
Our gtk2 is patched to workaround that, the problem lies elsewhere.
Comment 3 Sammy 2007-12-04 11:59:02 EST
Are you sure for F8+updates? Because I tried it and got the gtk_init error? I am
on a x86_64.
Comment 4 Rex Dieter 2007-12-04 12:02:42 EST
That's what fedora's gtk2 maintainer told me.

Regardless, Konq currently lacks XEmbed support, which is what recent
flash-plugin versions use.  I'll go dig up the upstream bug reference.
Comment 5 Rex Dieter 2007-12-04 12:09:42 EST
See also:
http://bugs.kde.org/132138  
http://bugs.kde.org/146784
Comment 6 Lukáš Tinkl 2007-12-12 06:43:42 EST
Escalate and assign to me, I'm working with Seli on this
Comment 7 Rex Dieter 2007-12-12 10:20:12 EST
See also:
bug #306311 and past discussion around gtk2 mainloop issues.
Comment 8 Sammy 2007-12-12 11:19:13 EST
Is QXEmbed the solution to XEmbed support in KDE ? 
or is it something different? The reason I am asking is that some
patches for QXEmbed was checked into KDE 3.5 branch few hours ago.
Comment 9 Lukáš Tinkl 2007-12-12 11:23:04 EST
Yes, KDE svn contains some patches now, altho it's not complete yet, stay 
tuned
Comment 10 Rex Dieter 2007-12-13 11:47:46 EST
See also:
https://bugzilla.novell.com/show_bug.cgi?id=348088

I'll see about whipping up some test builds for feedback.
Comment 11 Kevin Kofler 2007-12-13 11:50:56 EST
I think Lukas has test builds already.
Comment 12 Kevin Kofler 2007-12-13 11:53:38 EST
(By the way, I don't see why this "bug" should be a priority at all for us. How 
is it our problem if proprietary software which is not part of Fedora stops 
working? Especially given that it's a regression in that proprietary software. 
IMHO this is a case for NOTABUG or WONTFIX.)
Comment 13 Sammy 2007-12-13 14:35:14 EST
The kdebase3 patch from the reference in Comment #10 is not applying
cleanly. There are code lines in there that are not in original or
the svn kdebase3 branch. Could there be a mixup with kde4?
Comment 14 Rex Dieter 2007-12-13 14:48:00 EST
Right, we've adjusted things, and are now generating some test builds.
Comment 15 Rex Dieter 2007-12-13 15:37:19 EST
Hrm, using test builds with patches supplied by Lukas:
$ rpm -q flash-plugin kdelibs kdebase
kdelibs-3.5.8-19.fc7.i386
kdebase-3.5.8-19.fc7.i386
flash-plugin-9.0.115.0-release.i386

Things aren't working much better than before, I'm afraid.  konq doesn't show
anything, and crashes on window close.

While running, I (still) see:
-------------------------------
GLib-GObject-CRITICAL **: gtype.c:2242: initialization assertion failed, use
IA__g_type_init() prior to this function

Gtk-CRITICAL **: gtk_clipboard_get_for_display: assertion `GDK_IS_DISPLAY
(display)' failed

Adobe Flash Player: gtk_clipboard_get(GDK_SELECTION_PRIMARY); failed. Trying to
call gtk_init(0,0)
-------------------------------
Comment 16 Sammy 2007-12-13 16:48:30 EST
Hmmm, could kmplayer interfere with the flash plugin? Or should one use
the kmplayer? I never understood this interaction, at least with 0.10.0b.

There is a separate patch for gtk_init(0,0) problem but not in KDE3 SVN
so if it is working for Lunak he must have something else.
Comment 17 Rex Dieter 2007-12-13 17:00:07 EST
Re: kmplayer.  
dunno, but excellent questions.  ask kmplayer devs?

Hmm... these patches don't seem to address the gtk_init issue (see comment #1),
which is apparently what I'm seeing on F-7.  I'll see about whipping up another
set of test builds integrating that as well.

In the meantime, here are some test builds I just queued with the flash patches
we have as-is:

F-8 kdelibs scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=292251

F-8 kdebase scratch build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=292289
Comment 18 Sammy 2007-12-14 11:17:39 EST
Any luck?

I have rebuilt kdebase including the gtk_init patch so I am no longer getting
any crashes. Doing about:plugins shows 9.0.115 plugin (I removed kmplayer)
but none of the tests work. I am not even getting the gray box anymore. At
some point I got this message on the konsole:

ASSERT: "firstOption == listItems.size() || found" in render_form.cpp (1254)
Comment 19 Rex Dieter 2007-12-14 16:38:19 EST
Here are our update candidate builds for F-8, 
https://admin.fedoraproject.org/updates/F8/pending/kdelibs-3.5.8-19.fc8,kdebase-3.5.8-22.fc8
feedback please.

F-7 builds will come shortly.
Comment 20 Sammy 2007-12-14 19:02:36 EST
It seems to be working fine on i386. It looks good and also plays with the
kmplayer 0.10.0b. I will investigate further. These are the F8 rpms from Koji.
Thanks
Comment 21 Sammy 2007-12-15 10:29:43 EST
Now that this is working fine can someone tell me how to watch videos on
cnn.com? If you have a setup working with konqueror I would like to know
about it.
Thanks
Comment 22 Kevin Kofler 2007-12-20 09:39:36 EST
*** Bug 426361 has been marked as a duplicate of this bug. ***
Comment 23 Kevin Kofler 2007-12-20 09:45:51 EST
Updated link to the update (which is now in testing): 
https://admin.fedoraproject.org/updates/F8/FEDORA-2007-4633
F7 version: https://admin.fedoraproject.org/updates/F7/FEDORA-2007-4602
Comment 24 Fedora Update System 2007-12-20 14:50:07 EST
kdebase-3.5.8-25.fc7, kdelibs-3.5.8-19.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdebase kdelibs'
Comment 25 Fedora Update System 2007-12-20 15:16:37 EST
kdebase-3.5.8-25.fc8, kdelibs-3.5.8-19.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdebase kdelibs'
Comment 26 Thomas Bartschies 2007-12-22 03:25:21 EST
It doesn't work if one has enabled the load plugin only on demand option
in konqueror. The plugin area is left empty, when the "Start Plugin"
Button is pressed.
Comment 27 Laurent Rineau 2008-01-15 07:36:50 EST
It seems to be fixed using the following packages:
kdebase-3.5.8-25.fc8.i386
kdelibs-3.5.8-19.fc8.i386
flash-plugin-9.0.115.0-release.i386

Comment 28 Fedora Update System 2008-01-15 17:54:15 EST
kdebase-3.5.8-30.fc7, kdelibs-3.5.8-19.fc7, gtk-qt-engine-0.8-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdebase kdelibs gtk-qt-engine'
Comment 29 Fedora Update System 2008-01-15 18:11:23 EST
gtk-qt-engine-0.8-2.fc8, kdelibs-3.5.8-19.fc8, kdebase-3.5.8-30.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gtk-qt-engine kdelibs kdebase'
Comment 30 Fedora Update System 2008-01-18 19:01:08 EST
kdebase-3.5.8-30.fc7.1, kdelibs-3.5.8-19.fc7, gtk-qt-engine-0.8-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdebase kdelibs gtk-qt-engine'
Comment 31 Fedora Update System 2008-01-27 02:10:12 EST
kdebase-3.5.8-30.fc7.1, kdelibs-3.5.8-19.fc7, gtk-qt-engine-0.8-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 32 Fedora Update System 2008-01-27 02:25:26 EST
kdebase-3.5.8-30.fc8, kdelibs-3.5.8-19.fc8, gtk-qt-engine-0.8-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 33 Fedora Update System 2008-02-07 07:20:16 EST
kdebase-3.5.8-32.fc8 has been submitted as an update for Fedora 8
Comment 34 Fedora Update System 2008-02-07 07:21:28 EST
kdebase-3.5.8-32.fc7 has been submitted as an update for Fedora 7
Comment 35 Fedora Update System 2008-02-13 00:12:16 EST
kdebase-3.5.8-32.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 36 Fedora Update System 2008-02-13 00:18:47 EST
kdebase-3.5.8-32.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.