Bug 422151 - freenx 0.7.1 showing unrelated VNC sessions
freenx 0.7.1 showing unrelated VNC sessions
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: freenx-server (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-12 12:47 EST by Helge Deller
Modified: 2008-07-26 02:04 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.7.2-8.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-10 09:56:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nxclient screenshot showing VNC sessions (19.62 KB, image/jpeg)
2007-12-12 12:47 EST, Helge Deller
no flags Details

  None (edit)
Description Helge Deller 2007-12-12 12:47:22 EST
In Bug 379761 a logrotate file was added, and thus now instead of 
freenx-0.7.0-2.fc7 a new (updated) version freenx-0.7.1-3.fc7 is available.
Sadly this version seeems very much broken.
If I try to login with nxclient, I get a list of all active VNC-connections 
which other users have opened. (We allow connections with VNC and NX).
Attached is a screenshot (taken from the Windows client).
Before everything worked with 0.7.0-2 nicely and the VNC sessions were not 
shown.
Comment 1 Helge Deller 2007-12-12 12:47:22 EST
Created attachment 285961 [details]
nxclient screenshot showing VNC sessions
Comment 2 Helge Deller 2007-12-12 12:49:41 EST
freenx-0.7.1-2.fc7 is broken the same way as well. freenx-0.7.1-1.fc7 isn't 
available for fc7, but only for fc9
Comment 3 Jack Tanner 2008-03-15 15:49:19 EDT
This is apparently fixed upstream:

http://news.gmane.org/gmane.network.freenx.general/cutoff=6809
Comment 4 Helge Deller 2008-04-10 12:14:19 EDT
Jack, the link you posted here seems wrong. Could you please verify and give a 
direct link to where you saw that this bug is fixed ? THX, Helge
Comment 5 Jack Tanner 2008-04-10 16:54:44 EDT
My apologies for the bogus link. Please see the thread starting with 

http://thread.gmane.org/gmane.network.freenx.general/6330

Also see the freenx-0.7.2 release announcement

http://thread.gmane.org/gmane.network.freenx.general/6810
Comment 6 Axel Thimm 2008-04-11 12:20:42 EDT
This is a collective comment for freenx bugs. There is a new release packaged as
freenx-server-0.7.2-7 in rawhide and soon in updates-testing. Please test it and
see whether it fixed your report.

Also note that freenx has been split into freenx-server and freenx-client. All
current open bug reports will move to freenx-server once it is created in bugzilla.
Comment 7 Axel Thimm 2008-04-24 04:37:44 EDT
freenx has been split into freenx-server and freenx-client. Most open bugs for
freenx addressed parts of the current freenx-server package. See also bug #438660.

freenx-server is currently in testing repos. Please give it a try as it will
soon replace the freenx package.
Comment 8 Helge Deller 2008-04-28 09:23:11 EDT
Hi Axel,

I have problems installing freenx-server:

[root@ls3162 ~]# yum install freenx-server
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package freenx-server.i386 0:0.7.2-7.fc7 set to be updated
--> Processing Dependency: nx for package: freenx-server
--> Processing Dependency: /usr/share/nx for package: freenx-server
--> Processing Dependency: /usr/lib/nx for package: freenx-server
--> Running transaction check
---> Package nx.i386 0:3.1.0-25.1.fc7 set to be updated
---> Package freenx-server.i386 0:0.7.2-7.fc7 set to be updated
--> Processing Dependency: /usr/share/nx for package: freenx-server
--> Finished Dependency Resolution
Error: Missing Dependency: /usr/share/nx is needed by package freenx-server

Comment 9 Axel Thimm 2008-04-30 03:40:23 EDT
Yes, this was a known bug (bug #443329) and is fixed in testing for a couple of
days, please retry installing.
Comment 10 Helge Deller 2008-04-30 08:25:17 EDT
freenx-server-0.7.2-8.fc7 seems OK after some basic testing.
Full testing ist still outstanding and I sadly won't be able to do it in short 
time frame.

I don't understand the DISPLAY_BASE change (old:1000, new:2000) though:
+ #JJK: DISPLAY_BASE=1000
+ #JJK: Change DISPLAY_BASE to 2000 to avoid conflict of DISPLAY_BASE+7000 with 
nasd
+ DISPLAY_BASE=2000
(see: http://www.progressive-comp.com/?l=freenx-knx&m=119928349602913&w=3)

This requires, that we have to change a few scripts (although not complicated).

My current proposal would be: Push it to the updates repo, since this package 
is much better than what's currently in FC7 updates (and it works at least!!).

Thanks!
Helge
Comment 11 Axel Thimm 2008-04-30 09:05:41 EDT
OK, the push has been requested. Thanks for the feedback!
Comment 12 Fedora Update System 2008-05-10 09:56:47 EDT
freenx-server-0.7.2-8.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2008-05-13 11:29:47 EDT
freenx-server-0.7.2-8.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2008-07-26 02:04:58 EDT
freenx-server-0.7.2-8.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.