Bug 425796 - system-config-firewall won't run
Summary: system-config-firewall won't run
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-firewall   
(Show other bugs)
Version: 8
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 426247 426407 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-12-15 22:04 UTC by Andre Robatino
Modified: 2009-09-21 19:51 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 15:10:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andre Robatino 2007-12-15 22:04:13 UTC
Description of problem:
Attempting to run system-config-firewall from the command line fails with the
following errors.  Running the corresponding version of
system-config-firewall-tui works.

[root@localhost ~]# system-config-firewall

(system-config-firewall.py:22762): libglade-WARNING **: Error loading image:
Failed to open file
'/usr/share/system-config-firewall/system-config-firewall_48.png': No such file
or directory

(system-config-firewall.py:22762): libglade-WARNING **: could not convert string
to type `GdkPixbuf' for property `logo'
Traceback (most recent call last):
  File "/usr/share/system-config-firewall/system-config-firewall.py", line 41,
in <module>
    ui.run()
  File "/usr/share/system-config-firewall/fw_gui.py", line 1223, in run
    self.setupScreen()
  File "/usr/share/system-config-firewall/fw_gui.py", line 79, in setupScreen
    self.icon = icon_theme.load_icon("%s_48" % APP_NAME, 48, 0)
gobject.GError: Icon 'system-config-firewall_48' not present in theme
[root@localhost ~]#

Version-Release number of selected component (if applicable):
system-config-firewall-1.0.12-2.fc8

How reproducible:
always

Comment 1 Glenn Johnson 2007-12-16 15:07:05 UTC
It's the 1.0.12-2.fc8 update that is borking system-config-firewall.

Comment 2 circuithead64 2007-12-16 18:09:44 UTC
(In reply to comment #1)
> It's the 1.0.12-2.fc8 update that is borking system-config-firewall.

Nice to know i am not the only one. Anything i can contribute to the effort?log
files etc... let me know.

Comment 3 Andre Robatino 2007-12-16 18:46:49 UTC
> It's the 1.0.12-2.fc8 update that is borking system-config-firewall.

Yes, I should have mentioned that by downgrading to the original versions of
system-config-firewall and system-config-firewall-tui (the latter being
necessary only to satisfy dependencies) on the install DVD using 

rpm -Uvh --oldpackage

system-config-firewall works again.

Comment 4 Russell Harrison 2007-12-16 19:33:44 UTC
Creating a symlink from the icon's proper location to the path
system-config-firewall will also get you up and running until the package is
fixed to look for the file in the proper location.

$ sudo ln -s /usr/share/icons/hicolor/48x48/apps/system-config-firewall.png
/usr/share/system-config-firewall/system-config-firewall_48.png



Comment 5 Adam Pribyl 2007-12-18 08:29:03 UTC
Sad, that this can get past updates-testing... all users are confused by this.

Comment 6 Thomas Woerner 2007-12-18 10:35:08 UTC
A fixed package is on the way.

Comment 7 Thomas Woerner 2007-12-19 16:46:24 UTC
*** Bug 426247 has been marked as a duplicate of this bug. ***

Comment 8 Mehdi Bahri 2007-12-20 14:20:01 UTC
Commenting lines related to "self.icon" in the file fixes the bug but you don't
have the icon, of course make a backup of the file before doing this.

Comment 9 Thomas Woerner 2007-12-20 15:10:43 UTC
Fixed in updates in package system-config-firewall-1.0.12-3.1.fc8.

Comment 10 Fedora Update System 2007-12-20 19:49:04 UTC
system-config-firewall-1.0.12-3.1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Thomas Woerner 2007-12-21 10:30:49 UTC
*** Bug 426407 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.