This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 425998 - Tor claims to be running when it's not and will not start upon request
Tor claims to be running when it's not and will not start upon request
Status: CLOSED DUPLICATE of bug 432254
Product: Fedora
Classification: Fedora
Component: tor (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Enrico Scholz
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-17 12:44 EST by Jeff Rasmussen
Modified: 2008-02-12 15:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-12 15:06:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Rasmussen 2007-12-17 12:44:36 EST
Description of problem:
Tor claims to be running when it's not and will not start upon request

Version-Release number of selected component (if applicable):
tor-0.1-2.17-1.fc8.i386

How reproducible:
Every reboot

Actual results:
In Service Configuration, it reads "/usr/bin/tor is running" even though the
System Monitor does not list a PID.  Starting tor in Service Configuration gives
a "tor start successful" message but does not provide a corresponding PID. 
Starting tor from a terminal also does not provide a corresponding PID in System
Monitor.

Expected results:
In Service Configuration, it reads "tor is stopped" and starting tor gives a
"tor start successful" message with a corresponding PID.  Starting tor from a
terminal provides a corresponding PID in System Monitor.

Additional info:
Selinux is set to enforcing.  I have it set so that tor should not start
automatically upon reboot.
Comment 1 Ronald 2008-02-12 14:48:41 EST
So, from what I get is that you are trying to use Selinux to prevent tor from
booting (right?) and that you expect tor to boot correctly once you initiate:

service tor start

yourself (right?) (Sorry, it's not really clear to me)
Comment 2 Enrico Scholz 2008-02-12 15:04:31 EST

*** This bug has been marked as a duplicate of 432548 ***
Comment 3 Enrico Scholz 2008-02-12 15:06:12 EST

*** This bug has been marked as a duplicate of 432254 ***

Note You need to log in before you can comment on or make changes to this bug.