Bug 426564 - SDL_config.h is hosed
SDL_config.h is hosed
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: SDL (Show other bugs)
8
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
: 426569 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-22 02:39 EST by Braden McDaniel
Modified: 2007-12-24 08:41 EST (History)
8 users (show)

See Also:
Fixed In Version: 1.2.12-5.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-24 08:41:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Braden McDaniel 2007-12-22 02:39:40 EST
Description of problem:
After updating SDL, the contents of my /usr/include/SDL/SDL_config.h are:

# Temporary hack until SDL directly supports pulseaudio
# If alsa-plugins-pulseaudio is installed, force SDL to output sound to esd
[ -e /usr/lib*/alsa-lib/libasound_module_pcm_pulse.so ] && export
SDL_AUDIODRIVER=esd


Version-Release number of selected component (if applicable):
1.2.12-4.fc8
Comment 1 Jonathan Dieter 2007-12-22 05:14:09 EST
+1

I tried rebuilding bzflag from Rawhide and it failed because of this problem. 
When I downgraded to 1.2.12-3.fc9, it works.
Comment 2 Jonathan Dieter 2007-12-22 05:16:24 EST
*** Bug 426569 has been marked as a duplicate of this bug. ***
Comment 3 James Hogan 2007-12-22 10:53:22 EST
This bug is preventing me from working. Is there a workaround for it? "yum 
list SDL-devel" tells me that SDL-devel-1.2.12-2 is available, but when i try:
  yum install SDL-devel-1.2.12-2.fc8
yum says:
  Error: Missing Dependency: SDL = 1.2.12-2.fc8 is needed by package SDL-devel
Comment 4 Christoph Höger 2007-12-22 15:23:22 EST
Yes, I found a workaround: I cp'd /usr/include/SDL/SDL_config-i386.h to
SDL_config.h and it worked. May be you have to take x86 instead of i386 or
whatever fits your machine.

regards

christoph
Comment 5 Rex Dieter 2007-12-23 08:00:37 EST
Any objection to at least getting the fixed build:
http://koji.fedoraproject.org/koji/buildinfo?buildID=28930
tagged for the fedora buildsys buildroot?
Comment 6 Hans de Goede 2007-12-23 09:49:10 EST
Warren,

Adding you the the CC-list as your (very much welcome) fix for bug 426275, is
the cause of this (as you already know). Various people now have confirmed both
here and on fedora-devel list that
http://koji.fedoraproject.org/koji/buildinfo?buildID=28930 aka
http://koji.fedoraproject.org/packages/SDL/1.2.12/5.fc8/
fixes it.

Any chance this could get pushed to F-8 updates ?

I'll also be mailing rel-eng, hoping that atleast someone with the power to tag
things is still reading mail, asking them to tag:
http://koji.fedoraproject.org/koji/buildinfo?buildID=28930

Into the F-8 buildroot.

Note You need to log in before you can comment on or make changes to this bug.