Bug 426579 - Error message in terminal
Error message in terminal
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: SDL (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
: 426748 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-22 09:54 EST by Roland Wolters
Modified: 2008-01-22 10:47 EST (History)
9 users (show)

See Also:
Fixed In Version: 1.2.13-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 10:47:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Roland Wolters 2007-12-22 09:54:36 EST
Description of problem:
There is suddenly an error message in my terminal (konsole, gnome-terminal) 
whenever I open it up:
/etc/profile.d/SDL_pulseaudio_hack.sh:3: no matches 
found: /usr/lib*/alsa-lib/libasound_module_pcm_pulse.so

Version-Release number of selected component (if applicable):
$ rpm -qf /etc/profile.d/SDL_pulseaudio_hack.sh                                                                         
SDL-1.2.12-4.fc8

How reproducible:
I only have the the few pulseaudio packages installed which I have to have for 
a working system:
$ rpm -qa|grep pulse                                                                                                   
pulseaudio-core-libs-0.9.7-0.17.svn20071017.fc8
akode-pulseaudio-2.0.1-9.fc8
pulseaudio-libs-0.9.7-0.17.svn20071017.fc8

Additional info:
I guess a workaround would be to install the package "alsa-plugins-pulseaudio"
which contains such a file - however, Pulseaudio is not an option at all for 
my system. Additionally, if that pacakge is needed for SDL to work properly it 
should be a dependency!
Comment 1 Roland Wolters 2007-12-22 10:00:44 EST
Looking at the problematic script it might be that the error occurs due to the 
fact that I use zsh.

Would it not work in all shells if the brackets would be twice like
[[ -e ... ]]?
But I'm not an expert there...
Comment 2 Hans de Goede 2007-12-23 10:44:28 EST
Erm,

/etc/profile.d/foo.sh files are meant for bash, I don't know why zsh parses
them, but I guess if it does then it claims to be bash compatible.

But appearently it isn't. Using [[ does'n work in bash.

Comment 3 Remi Collet 2007-12-25 03:08:18 EST
Same problem on x86_64 and SDL-1.2.12-5.fc8

bash: [: /usr/lib64/alsa-lib/libasound_module_pcm_pulse.so: binary operator expected


This issue occurs because i have the library in lib and lib64.

A workaround :
[ -e /usr/lib/alsa-lib/libasound_module_pcm_pulse.so \
   -o -e /usr/lib64/alsa-lib/libasound_module_pcm_pulse.so ] \
   && export SDL_AUDIODRIVER=esd


Regards
Comment 4 Hans de Goede 2007-12-25 04:50:56 EST
Roland,

Can you check if Remi's fix fixes things with zsh too?

Warren, adding you to the CC, it seems your SDL pulseaudio hack shell script
syntax is not liked by zsh, nor does it work properly when both the x86_64 and
i386 version of the alsa pulseaudio plugin are installed, see previous comments.

Oh, and merry Christmas to all who celibrate it.

Comment 5 Roland Wolters 2007-12-25 07:37:08 EST
Hans: Looks like it works for me as well :)
Comment 6 Jens Petersen 2008-01-02 19:05:25 EST
(In reply to comment #2)
> /etc/profile.d/foo.sh files are meant for bash, I don't know why zsh parses
> them, but I guess if it does then it claims to be bash compatible.

I thought /etc/profile.d/*.sh was for Bourne shells in general not just bash.
They should not use any bash extensions I guess?

I use zsh too, and installing alsa-plugins-pulseaudio.x86_64 fixed the problem
for me FWIW.  Maybe SDL should require it?
Comment 7 Jens Petersen 2008-01-02 19:06:01 EST
*** Bug 426748 has been marked as a duplicate of this bug. ***
Comment 8 Hans de Goede 2008-01-03 04:44:09 EST
(In reply to comment #6)
> (In reply to comment #2)
> > /etc/profile.d/foo.sh files are meant for bash, I don't know why zsh parses
> > them, but I guess if it does then it claims to be bash compatible.
> 
> I thought /etc/profile.d/*.sh was for Bourne shells in general not just bash.
> They should not use any bash extensions I guess?
> 

My bad, I didn't know zsh was a bourne shell to, ignore the comment.

> I use zsh too, and installing alsa-plugins-pulseaudio.x86_64 fixed the problem
> for me FWIW.  Maybe SDL should require it?

Nope, the shell code is supposed to test for it to change the behaviour of SDL
depending on it being present or not.

Remi's fix see comment #3, should fix this for zsh and with sh when both the
i386 and x86_64 versions of the plugins are installed.
Comment 9 Fedora Update System 2008-01-11 17:11:13 EST
SDL-1.2.13-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update SDL'
Comment 10 Michel Alexandre Salim 2008-01-17 09:18:12 EST
*** Bug 428577 has been marked as a duplicate of this bug. ***
Comment 11 Fedora Update System 2008-01-22 10:47:10 EST
SDL-1.2.13-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.