Bug 42663 - Printing on HP LJ 1100 broken
Printing on HP LJ 1100 broken
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: foomatic (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
: 55804 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-29 04:54 EDT by Gerald Teschl
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-11 05:56:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ps file (10.63 KB, application/postscript)
2001-05-29 04:56 EDT, Gerald Teschl
no flags Details

  None (edit)
Description Gerald Teschl 2001-05-29 04:54:35 EDT
Printint to an HP Laserjet 1100 is broken in 7.1 (was fine in 7.0).
Certain postscript files will cause the printfilter to crash and
will block the queue (until they are removed by hand). Here this
will happen about once/twice a day in our secretary and hence makes
printing a pain.

The problem is reprodicible and I will a attatch a postscript file
which will block the printing system. The same file prints fine on
other printers (tested on HP Laserjet 4000).
Comment 1 Gerald Teschl 2001-05-29 04:56:21 EDT
Created attachment 19853 [details]
ps file
Comment 2 Gerald Teschl 2001-09-01 14:23:18 EDT
Still broken in RC2. It will print some pages and then stop at random. The light
is
blinking forever but no more pages come out of the printer. If I kill the job
and
send the job again begining with the page where it previously stopped, I get
a single page with
-------------------------------
@PJL SET MANUALFEED=OFF
                                              @PJL SET MEDIATYPE=NORMAL
                                                                                                
@PJL SET PRINTQUALITY=NORMAL

--------------------------------
and printing will resume and stop again after a random page.
Comment 3 Tim Waugh 2002-01-07 12:27:08 EST
Bug #50401 looks like a duplicate, and has some more information in it.
Comment 4 Tim Waugh 2002-01-07 12:27:52 EST
*** Bug 50401 has been marked as a duplicate of this bug. ***
Comment 5 Tim Waugh 2002-01-10 08:29:53 EST
*** Bug 55804 has been marked as a duplicate of this bug. ***
Comment 6 Tim Waugh 2002-01-18 16:38:42 EST
Do the packages at <ftp://people.redhat.com/twaugh/errata-candidate/> help?
Comment 7 Gerald Teschl 2002-01-28 04:33:55 EST
Yep. With these packages it works fine.
Comment 8 Terry A Jeeves 2002-02-07 20:42:10 EST
Maybe on version 7.2, but not on version 7.1.
I ran up2date after receiving the latest patch today:
[RHBA-2001:174-11] Updated printing packages available to fix minor bugs 
This bug started on 7.1 (5/2001). I am still running version 7.1 
Now instead of printing five of seven pages and dying, it prints only three 
pages of the same report and dies. I have to clear the "Queue" using 
lprm - <login name>. So something has changed, but it does not fix version 7.1.
Sorry.


Comment 9 Tim Waugh 2002-02-08 03:58:54 EST
tajeeves@att.net: this bug was filed against 7.2.  Please see bug #50401 for the
similar problem observed on 7.1.

For 7.2 though, this is now fixed by RHBA-2001:174.
Comment 10 Gerald Teschl 2002-02-20 03:46:02 EST
Unfortunately the problem is still not completely resolved. It works
*much* better now, but there are still some files where it hangs.

For example, I have a ps files (created with latex from dvi), where it
would print one page and then stop. The printer light will keep
blinking, but no further pages come out of the printer. lpq says:

Printer: lp@tomcat
 Queue: 1 printable job
 Server: pid 1871 active
 Unspooler: pid 1872 active
 Status: IF filter 'mf_wrapper' filter msg - 'closed *main::KID3' at 09:36:23.503
 Rank   Owner/ID                  Class Job Files                 Size Time
1      susanne@tomcat+870           A   870 Skriptum.ps          88632 09:36:16

I will mail the ps file to you.
Comment 11 Tim Waugh 2002-02-22 07:35:15 EST
(printer is directly connected to parallel port)

Can you try one of the other drivers please?  I'd like to try to eliminate
kernel problems.
Comment 12 Gerald Teschl 2002-02-23 05:15:08 EST
This is very strange: I just tested all three driveres (omni,stp,ljet4)
and it printed the document I sent you with all three drivers
(without problems)!? I have no clue what is going on.
Comment 13 Tim Waugh 2002-02-26 03:45:29 EST
*shrug*

I'll close this as WORKSFORME for now.  Please re-open if you see the problem again.
Comment 14 Gerald Teschl 2002-03-10 09:20:37 EST
Unfortunately the problem is still present. I found out that the
document will eventually print correctly. In fact, it will print
the first two pages, then the light will flash for about 20min
(with no output) and then suddenly another two or three pages
will come out of the printer. Then the light will flash agian for 20min, etc...

I tried kernel-2.4.18-0.1 as well, but same result. I don't think it is
a parport problem. Moreover, if I use cups everything works fine!

Here is a ps snapshot:

[root@tomcat root]# ps xauww|grep ^lp
lp         926  0.0  0.3  2580 1000 ?        S    14:53   0:00 lpd Waiting
lp        1577  0.0  0.4  2580 1212 ?        S    14:59   0:00 lpd (Server) 'lp'
lp        1578  0.0  0.4  2596 1248 ?        S    14:59   0:00 lpd (Worker -
Print) 'lp'
lp        1579  0.0  0.3  1984  908 ?        S    14:59   0:00 /bin/bash
/usr/share/printconf/util/mf_wrapper -Asusanne@tomcat+576 -CA
-D2002-03-10-14:59:14.041 -Ff -Htomcat.home -J(STDIN) -N(STDIN) -Plp -Qlp
-a/var/spool/lpd/lp/lp.acct -b253326 -d/var/spool/lpd/lp -edfA576tomcat.home
-f(STDIN) -htomcat.home -j576 -kcfA576tomcat.home -l66 -nsusanne -sstatus
-t2002-03-10-14:59:14.000 -w80 -x0 -y0 /var/spool/lpd/lp/lp.acct
lp        1589  0.0  0.3  1984  912 ?        S    14:59   0:00 /bin/bash
/usr/share/printconf/util/mf_postscript_wrapper --mfomatic ljet4-62816.foo
lp        1590  0.0  0.7  3312 2036 ?        S    14:59   0:00 /usr/bin/perl
/usr/sbin/lpdomatic --lprng ljet4-62816.foo
lp        1591  0.0  0.7  3320 2036 ?        S    14:59   0:00 /usr/bin/perl
/usr/sbin/lpdomatic --lprng ljet4-62816.foo
lp        1592  0.1  0.7  3316 2044 ?        S    14:59   0:01 /usr/bin/perl
/usr/sbin/lpdomatic --lprng ljet4-62816.foo
lp        1593  0.0  0.3  1964  860 ?        S    14:59   0:00 sh -c
foomatic-gswrapper -q -dBATCH -dSAFER -dNOPAUSE -sDEVICE=ljet4 -sOutputFile=- -
| perl -e "while (\$line = <>) { my \$b = \"\"; \$match |= ( \$line =~
s/\x1b&l\d+A/\$&\$b/ ); \$line =~ s/\x1b&l0H/\$b/g; print \$line }"
lp        1594  0.0  0.3  1964  868 ?        S    14:59   0:00 sh -c gs
'-dBATCH' '-dSAFER' '-dNOPAUSE' '-sDEVICE=ljet4' '-sOutputFile=/dev/fd/3' '-'
3>&1 1>&2
lp        1595  0.0  0.4  2592 1140 ?        S    14:59   0:00 perl -e while
($line = <>) { my $b = ""; $match |= ( $line =~ s/\x1b&l\d+A/$&$b/ ); $line =~
s/\x1b&l0H/$b/g; print $line }
lp        1596  0.3  3.6 14392 9432 ?        S    14:59   0:03 gs -dBATCH
-dSAFER -dNOPAUSE -sDEVICE=ljet4 -sOutputFile=/dev/fd/3 -
[root@tomcat root]# ls -l /dev/fd/3
ls: /dev/fd/3: No such file or directory
[root@tomcat root]# ls -l /dev/fd/
total 0
lrwx------    1 root     root           64 Mar 10 15:17 0 -> /dev/pts/1
lrwx------    1 root     root           64 Mar 10 15:17 1 -> /dev/pts/1
lrwx------    1 root     root           64 Mar 10 15:17 2 -> /dev/pts/1
lr-x------    1 root     root           64 Mar 10 15:17 3 -> /proc/1781/fd

Comment 15 Gerald Teschl 2002-03-10 09:43:49 EST
I just connected the printer to my laptop which runs beta2. And it
works just fine (using the gimp driver as suggested by printconf).
I will upgrade the other box and try again later.
Comment 16 Tim Waugh 2002-03-11 05:56:12 EST
Okay.  Perhaps this is fixed in the new packages then, whatever the problem was.
 Let me know the result of the other test.
Comment 17 Gerald Teschl 2002-05-24 07:51:46 EDT
It seems to work fine now. Closing bug.

Note You need to log in before you can comment on or make changes to this bug.