Bug 50401 - lpr to HP laserjet stalls
lpr to HP laserjet stalls
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-30 18:25 EDT by Michael Ben-Gershon
Modified: 2007-04-18 12:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-08 09:13:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Ben-Gershon 2001-07-30 18:25:29 EDT
Description of Problem:

Using 'lpr' to print to an HPLaserJet 6P printer often hangs midway. This may happen both
when the printer is used in its 'raw' mode and as a filter through ghostscript. It is apparent
both when printing locally, and using Samba over the network. There was no
such problem in my older installation (RedHat Linux 5.2 upgraded via rpm to about 6.2).
Using 'lpc status' gives a message tha the print job has stalled.

How Reproducible:

Difficult to say. It is intermittent, but very frequent. It is difficult to print more than about
20 sheets without it happening sometime.

Steps to Reproduce:
1. 
Use lpr to print
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Laurence Tyler 2001-08-09 11:59:12 EDT
I have exactly this same problem with my HP LaserJet 1100 - random stalls in
multi-page print jobs. The printer stops with the light on that normally
indicates data is left in the buffer that hasn't been printed yet. The print
queue eventually says it's stalled. Pressing the printer button to force out the
page gives a page of truncated output, then a second page with what looks like
some printer commands on it, starting with "@PJL SET RET=MEDIUM". After printing
this duff page, the printer is idle but the print queue is still stalled.
Re-starting lpd simply re-prints the same file again, starting from the
beginning, which then fails at some other random point in the file.

I had no trouble whatsoever with RedHat 6.2 or 7.0 and this printer. Now,
however, I can't reliably print anything other than a single page file - and
even that fails sometimes if other files are in the queue.

*PLEASE*  try to get a fix out for this.. it's been frustrating me ever since I
upgraded.
Comment 2 Todd Tibbetts 2001-10-08 13:40:19 EDT
I also have this problem.  I have found that if I use the Laserjet 1100 driver I get random 
stalls with exactly the same behavior as the previous commenter noted.  I have "resolved" 
my problem by switching to the generic laserjet driver which prevents the print queue from 
hanging.  Unfortunately I am limited to 300 dpi by this driver and cannot access the 
advanced features of the LJ 1100.
Comment 3 Need Real Name 2001-10-21 00:08:34 EDT
I also have the same problem with the HP LaserJet 1100. With the ljet4 driver,
it stalls after exactly 2 pages. This printer used to work very well in 6.2 and
it's a very nice printer so I hope this bug gets fixed soon.
Comment 4 jdalbec 2001-10-28 19:16:36 EST
I have the same problem printing to a LaserJet 6L.  The status line alternates
between "active" and "waiting for subserver to exit" and "cannot open '/dev/lp0'
- 'Device or resource busy', attempt <#>, sleeping 20".  If I wait a really long
time it eventually starts up again.  I have kernel 2.4.9-6 and glibc 2.2.4-19.
I stopped and restarted lpd and it seems to be working better now.  I also
deleted all but one job from the print queue.  Where it was previously freezing
once a page it now seems to go several pages without freezing and takes much
less time to recover from a freeze.  I have 32MB RAM in this box, which I
realize is tight, but it's the maximum the motherboard supports.  Naturally I
have ample swap space.
Comment 5 jdalbec 2001-12-01 23:52:14 EST
'fuser -v' shows that 'lpd (Worker-Print)', '/usr/share/printconf/mf_wrapper',
and '/usr/bin/magicfilter-t' all have the device file open.  Could one of these
be stepping on the others' toes?
Comment 6 jdalbec 2001-12-02 00:25:01 EST
If I 'strace -p' the magicfilter-t process, it unfreezes for a little while.  If
I break out of the strace, it also unfreezes for a little while.  When I do this
I get random characters on the page where the freeze occurred (in portrait
orientation, even if I'm printing in landscape mode).  I've also seen pages
split in two where the freeze occurred.  I think it may be time to follow the
advice from bug #43619:  delete all printer configurations, remove printconf and
printconf-gui, install printtool and rhs-printfilters from RH7.0, and
reconfigure the printers.
Comment 7 jdalbec 2001-12-02 11:56:43 EST
When I was strace'ing I found that the 'lpd' process had an outstanding read()
on fd 9 (not sure whether that's /dev/lp0).  The magicfilter-t process would
freeze in the middle of a write() call to stdout (presumably /dev/lp0).  Does
that mean this is a kernel bug?
Comment 8 Tim Waugh 2002-01-07 12:27:57 EST
This looks like a duplicate of #42663.


*** This bug has been marked as a duplicate of 42663 ***
Comment 9 Tim Waugh 2002-02-08 03:56:55 EST
This is fixed in 7.2 now, but 7.1 needs a different fix (which I don't yet know).

Note You need to log in before you can comment on or make changes to this bug.