Bug 426637 - rpm installing package exception "maximum recursion depth exceeded"
rpm installing package exception "maximum recursion depth exceeded"
Status: CLOSED DUPLICATE of bug 375221
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-23 10:09 EST by jiu ke
Modified: 2007-12-24 08:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-23 10:13:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash dump when installing opera rpm package (124.24 KB, application/octet-stream)
2007-12-23 10:09 EST, jiu ke
no flags Details

  None (edit)
Description jiu ke 2007-12-23 10:09:22 EST
Description of problem:

can not install rpm package by double-click the rpm file (e.g.
opera-9.25-20071214.6-shared-qt.i386-en.rpm). An error message box poped up saying 
"Component: pirut
Summary: TB3242b26e repos.py:278:getAttribute:RuntimeError: maximum recursion
depth exceeded
................
...............
 File "/usr/lib/python2.5/site-packages/yum/repos.py", line 278, in getAttribute
    return getattr(self, key, None)
RuntimeError: maximum recursion depth exceeded

Local variables in innermost frame:
self: atrpms
key: enabled
"

please see attached for detail.

 however, I can install the rpm using terminal by typing:
  "rpm -ivh opera-9.25-20071214.6-shared-qt.i386-en.rpm"


same error happened for other rpm package installtion



Version-Release number of selected component (if applicable):


How reproducible:

for every rpm packages tried

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 jiu ke 2007-12-23 10:09:22 EST
Created attachment 290304 [details]
crash dump when installing opera rpm package
Comment 2 Jeremy Katz 2007-12-23 10:13:35 EST

*** This bug has been marked as a duplicate of 375221 ***
Comment 3 jiu ke 2007-12-24 08:30:36 EST
I can not start yum (add/remove program) after install yum update today.

please see 426695 for details
https://bugzilla.redhat.com/show_bug.cgi?id=426695

Note You need to log in before you can comment on or make changes to this bug.