Bug 427349 - Fedora ships out-of-sync locale files
Summary: Fedora ships out-of-sync locale files
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
: 428418 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-03 12:22 UTC by Julian Sikorski
Modified: 2008-04-24 12:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-24 12:43:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
installed languages (99.77 KB, image/png)
2008-01-04 11:29 UTC, Martin Stransky
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 410612 None None None Never

Description Julian Sikorski 2008-01-03 12:22:14 UTC
Description of problem:
As reported at mozilla bugzilla: Download manager does not work when using
pl_PL.UTF-8 locale.

Version-Release number of selected component (if applicable):
firefox-3.0-0.beta2.5.fc9.x86_64

How reproducible:
always

Steps to Reproduce:
1. export LANG=pl_PL.UTF-8
2. start firefox
3. press CTRL-Y

Actual Results:  
A window containing the following appears:
Błąd parsowania XML: niezdefiniowana jednostka
Obszar: chrome://mozapps/content/downloads/downloads.xul
Numer linii: 79, kolumna 5:    <key id="key_info"   
key="&cmd.info.commandKey;"   oncommand="onDownloadShowInfo();"
modifiers="accel"/>
----^

Which means:
XML parsing error: undefined unit
Location: chrome://mozapps/content/downloads/downloads.xul
Line number: 79, column 5:    <key id="key_info"    key="&cmd.info.commandKey;"
  oncommand="onDownloadShowInfo();" modifiers="accel"/>
----^

Expected Results:  
Download manager starts normally

Additional info:
The bug was closed as invalid with the following comment:
You're using a third-party package which probably contains out of sync
localization files.

If you can't reproduce the bug with a recent, Mozilla.org-made build
(http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk-l10n/),
please report that bug to Fedora packagers.

On a side note, it seems that Fedora packaging process is probably broken,
since an issue like this one would be caught by compare-locales.pl at build
time.

Comment 1 Martin Stransky 2008-01-03 13:50:33 UTC
fixed in firefox-3.0-0.beta2.5.fc9

Comment 2 Julian Sikorski 2008-01-03 14:40:19 UTC
It's 3.0-0.beta2.5.fc9 that fails. To me, it looks like the Polish langpack
claims to be compatible, but it isn't.

Comment 3 Martin Stransky 2008-01-03 15:00:00 UTC
ahh, sorry, I missed it. I can reproduce it.

Comment 4 Martin Stransky 2008-01-03 15:00:27 UTC
Do you have the upstream bug somewhere?

Comment 5 Julian Sikorski 2008-01-03 15:05:31 UTC
In external bugzilla references: #410612

Comment 6 Martin Stransky 2008-01-03 15:07:22 UTC
Aha, thanks.

Comment 7 Martin Stransky 2008-01-03 15:13:31 UTC
I can't reproduce it with the upstream packages so it seems to be fedora bug....

Comment 8 Julian Sikorski 2008-01-03 15:19:34 UTC
Well, 3.0b3 isn't really a precise version yet, so possibly the translation is a
few days out of sync with the program.

Comment 9 Martin Stransky 2008-01-03 15:34:05 UTC
The upstream 3.0b3 (trunk) works fine...needs some investigation.

Comment 10 Martin Stransky 2008-01-03 16:34:08 UTC
It needs the lates xulrunner, too. Updating xulrunner in rawhide, will be fixed
in firefox-3.0-0.beta2.6.fc9 and xulrunner-1.9-0.beta2.5.fc9.

Comment 11 Martin Stransky 2008-01-04 10:26:01 UTC
should be fixed now.

Comment 12 Julian Sikorski 2008-01-04 10:45:24 UTC
This time no language packs seem to be available. Well, at least the download
manager is usable.

Comment 13 Martin Stransky 2008-01-04 10:57:28 UTC
Really? Because the localization (LC_ALL=pl_PL.utf8) works fine for me.

Comment 14 Julian Sikorski 2008-01-04 11:15:20 UTC
That's strange. I have no langpacks listed in Tools -> Add-ons, and firefox is
running in English.

Comment 15 Julian Sikorski 2008-01-04 11:24:29 UTC
For reference, I grabbed latest xulrunner and firefox from koji:
firefox-3.0-0.beta2.6.fc9.x86_64
xulrunner-1.9-0.beta2.6.fc9.x86_64
xulrunner-devel-1.9-0.beta2.6.fc9.x86_64

Comment 16 Martin Stransky 2008-01-04 11:26:48 UTC
Strange...the same packages work for me.

Comment 17 Martin Stransky 2008-01-04 11:29:40 UTC
Created attachment 290839 [details]
installed languages

Comment 18 Julian Sikorski 2008-01-04 11:33:57 UTC
Really weird. Do you happen to know which files contain the langpacks?

Comment 19 Martin Stransky 2008-01-04 13:29:28 UTC
I have them in /usr/lib64/firefox-3.0b3pre/extensions

Comment 20 Julian Sikorski 2008-01-04 14:57:51 UTC
Looks like something ate them:
[jsikorski@snowball ~]$ rpm -ql firefox | grep
/usr/lib64/firefox-3.0b3pre/extensions
/usr/lib64/firefox-3.0b3pre/extensions
/usr/lib64/firefox-3.0b3pre/extensions/inspector@mozilla.org
/usr/lib64/firefox-3.0b3pre/extensions/inspector@mozilla.org/chrome
/usr/lib64/firefox-3.0b3pre/extensions/inspector@mozilla.org/chrome.manifest
/usr/lib64/firefox-3.0b3pre/extensions/inspector@mozilla.org/chrome/inspector.jar
/usr/lib64/firefox-3.0b3pre/extensions/inspector@mozilla.org/components
/usr/lib64/firefox-3.0b3pre/extensions/inspector@mozilla.org/components/inspector-cmdline.js
/usr/lib64/firefox-3.0b3pre/extensions/inspector@mozilla.org/defaults
/usr/lib64/firefox-3.0b3pre/extensions/inspector@mozilla.org/defaults/preferences
/usr/lib64/firefox-3.0b3pre/extensions/inspector@mozilla.org/defaults/preferences/inspector.js
/usr/lib64/firefox-3.0b3pre/extensions/inspector@mozilla.org/install.rdf
/usr/lib64/firefox-3.0b3pre/extensions/inspector@mozilla.org/platform
/usr/lib64/firefox-3.0b3pre/extensions/inspector@mozilla.org/platform/Linux
/usr/lib64/firefox-3.0b3pre/extensions/inspector@mozilla.org/platform/Linux/chrome
/usr/lib64/firefox-3.0b3pre/extensions/inspector@mozilla.org/platform/Linux/chrome/icons
/usr/lib64/firefox-3.0b3pre/extensions/inspector@mozilla.org/platform/Linux/chrome/icons/default
/usr/lib64/firefox-3.0b3pre/extensions/inspector@mozilla.org/platform/Linux/chrome/icons/default/winInspectorMain.xpm
/usr/lib64/firefox-3.0b3pre/extensions/inspector@mozilla.org/platform/Linux/chrome/icons/default/winInspectorMain16.xpm
/usr/lib64/firefox-3.0b3pre/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
/usr/lib64/firefox-3.0b3pre/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}/install.rdf
[jsikorski@snowball ~]$ 

Comment 21 Martin Stransky 2008-01-04 15:10:45 UTC
Ahh, you're right. reopened.

Comment 22 Martin Stransky 2008-01-04 16:02:01 UTC
firefox-3.0-0.beta2.6.fc9.x86_64 contains a wrong langpack, I hope
firefox-3.0-0.beta2.7.fc9 will fix it.

Comment 23 Julian Sikorski 2008-01-04 17:29:13 UTC
Yay, looks like the langpacks are OK this time.

Comment 24 Julian Sikorski 2008-01-12 12:53:01 UTC
With latest rawhide, that is:
xulrunner-1.9-0.beta2.7.fc9.x86_64
firefox-3.0-0.beta2.8.fc9.x86_64
the problem appeared again, but this time the window which appear when you click
a link (Open with, Save) got broken.

Comment 25 Julian Sikorski 2008-01-15 19:44:58 UTC
Still present with firefox-3.0-0.beta2.10.nightly20080113.fc9.x86_64

Comment 26 Julian Sikorski 2008-01-15 19:48:37 UTC
%define tarball firefox-20080113.tar.bz2
--snip--
Source2:        firefox-langpacks-20080104.tar.bz2
I guess that's the reason.

Comment 27 Martin Stransky 2008-02-28 17:20:15 UTC
*** Bug 428418 has been marked as a duplicate of this bug. ***

Comment 28 Martin Stransky 2008-04-24 12:43:05 UTC
Should be fixed now.


Note You need to log in before you can comment on or make changes to this bug.