Bug 427369 - epiphany only uses plugins located in $HOME/.mozilla/plugins
epiphany only uses plugins located in $HOME/.mozilla/plugins
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: epiphany (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
: 436490 437697 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-03 10:34 EST by Joachim Frieben
Modified: 2008-03-31 14:15 EDT (History)
5 users (show)

See Also:
Fixed In Version: epiphany-2.22.0-3.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-31 14:15:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2008-01-03 10:34:34 EST
Description of problem:
After upgrading to epiphany-2.21.5-0.1.svn7844.fc9, gnash-plugin is
not used anymore on my x86_64 box, whereas it used to be for previous
releases of epiphany.

Version-Release number of selected component (if applicable):
epiphany-2.21.5-0.1.svn7844.fc9

How reproducible:
Always.

Steps to Reproduce:
1. Upgrade to epiphany-2.21.5-0.1.svn7844.fc9 and install gnash-plugin.
2. Launch epiphany.
3. Open a URL pointing to a flash animated webpage.
  
Actual results:
No flash animation on the respective webpage.

Expected results:
flash animation rendered [more or less] correctly.

Additional info:
- about:config only shows the two plugins which are present in
  /usr/lib64/xulrunner-1.9pre/plugins but not the gnash plugin
  in /usr/lib64/mozilla/plugins.
- after copying libgnashplugin.so to $HOME/.mozilla/plugins,
  flash is back and running.
Comment 1 Martin Sourada 2008-01-04 04:15:02 EST
Same here on F8 (with few devel pkgs), i386

$ rpm -q xulrunner
xulrunner-1.9-0.beta2.4.fc9

$ rpm -q epiphany
epiphany-2.21.5-0.1.svn7844.fc9

$ ls -l /usr/lib/mozilla/plugins
total 464
lrwxrwxrwx 1 root root    54 2007-12-19 14:16 libjavaplugin_oji.so ->
/usr/java/default/plugin/i386/ns7/libjavaplugin_oji.so
lrwxrwxrwx 1 root root    34 2007-10-01 15:44 libjavaplugin.so ->
/etc/alternatives/libjavaplugin.so
-rwxr-xr-x 1 root root 41112 2007-10-12 23:54 libswfdecmozilla.so
-rwxr-xr-x 1 root root 54276 2007-12-12 20:25 libtotem-basic-plugin.so
-rw-r--r-- 1 root root   167 2007-12-12 20:25 libtotem-basic-plugin.xpt
-rwxr-xr-x 1 root root 86040 2007-12-12 20:25 libtotem-complex-plugin.so
-rw-r--r-- 1 root root  3227 2007-12-12 20:25 libtotem-complex-plugin.xpt
-rwxr-xr-x 1 root root 90780 2007-12-12 20:25 libtotem-gmp-plugin.so
-rw-r--r-- 1 root root  4312 2007-12-12 20:25 libtotem-gmp-plugin.xpt
-rwxr-xr-x 1 root root 53732 2007-12-12 20:25 libtotem-mully-plugin.so
-rw-r--r-- 1 root root   167 2007-12-12 20:25 libtotem-mully-plugin.xpt
-rwxr-xr-x 1 root root 77572 2007-12-12 20:25 libtotem-narrowspace-plugin.so
-rw-r--r-- 1 root root  2211 2007-12-12 20:25 libtotem-narrowspace-plugin.xpt

about:plugins
libnullplugin.so
libunixprintplugin.so
Comment 2 Joachim Frieben 2008-03-03 03:32:19 EST
This issue should be added to the F9 blocker/target bug. Even the latest
epiphany/xulrunner combo is afflicted by this issue.
Only linking the *.so libraries symbolically to .mozilla/plugins does
actually allow the plugins to be used. Copying the libraries directly to
the user plugins directory fails at times, e.g. in the case of the
swfdec plugin where only a grey rectangle shows up.
Comment 3 Martin Stransky 2008-03-03 06:14:54 EST
Do you have the nspluginwrapper.i386 package installed?

Attach output of:

$ ls -l /usr/lib64/mozilla/plugins
Comment 4 Joachim Frieben 2008-03-07 15:41:21 EST
(In reply to comment #3)
> Do you have the nspluginwrapper.i386 package installed?

No, but I do have installed nspluginwrapper-0.9.91.5-24.fc9.x86_64.
Moreover, I have observed the same issue on some i386 install, and
even a friend of mine has reported the same issue for the current
Hardy Heron development version. Strange enough, the "Browse..."
button on the attachment page currently doesn't work [epiphany].
For this reason, the listing of the plugin directory follows in
plain text below:

-rwxr-xr-x 1 root root  40752 2007-10-28 00:53 libgnashplugin.so*
lrwxrwxrwx 1 root root     41 2008-01-25 11:09 libjavaplugin.so ->
/etc/alternatives/libjavaplugin.so.x86_64*
-rwxr-xr-x 1 root root   5624 2008-03-04 18:30
librhythmbox-itms-detection-plugin.so*
-rwxr-xr-x 1 root root  54000 2008-02-20 20:26 libswfdecmozilla.so*
-rwxr-xr-x 1 root root  79432 2008-03-03 21:27 libtotem-basic-plugin.so*
-rw-r--r-- 1 root root    191 2008-03-03 21:27 libtotem-basic-plugin.xpt
-rwxr-xr-x 1 root root 102984 2008-03-03 21:27 libtotem-complex-plugin.so*
-rw-r--r-- 1 root root   3251 2008-03-03 21:27 libtotem-complex-plugin.xpt
-rwxr-xr-x 1 root root  90008 2008-03-03 21:27 libtotem-cone-plugin.so*
-rw-r--r-- 1 root root   1339 2008-03-03 21:27 libtotem-cone-plugin.xpt
-rwxr-xr-x 1 root root 115416 2008-03-03 21:27 libtotem-gmp-plugin.so*
-rw-r--r-- 1 root root   4504 2008-03-03 21:27 libtotem-gmp-plugin.xpt
-rwxr-xr-x 1 root root  83208 2008-03-03 21:27 libtotem-mully-plugin.so*
-rw-r--r-- 1 root root   1237 2008-03-03 21:27 libtotem-mully-plugin.xpt
-rwxr-xr-x 1 root root 101136 2008-03-03 21:27 libtotem-narrowspace-plugin.so*
-rw-r--r-- 1 root root   2235 2008-03-03 21:27 libtotem-narrowspace-plugin.xpt
-rwxr-xr-x 1 root root  30488 2008-02-06 22:20 mozplugger.so*
Comment 5 Brian Pepple 2008-03-12 21:04:33 EDT
*** Bug 436490 has been marked as a duplicate of this bug. ***
Comment 6 Joachim Frieben 2008-03-13 02:32:33 EDT
Dude, when I chose the summary, I did it for a reason: epiphany actually
-does- use browser plugins but they have to be located in the user owned
$HOME/.mozilla/plugins directory. Btw, a valid workaround until the bug
itself has been resolved.
Comment 7 Bastien Nocera 2008-03-16 13:08:46 EDT
*** Bug 437697 has been marked as a duplicate of this bug. ***
Comment 8 Sindre Pedersen Bjørdal 2008-03-17 10:31:47 EDT
I worked around this bug by symlinking the /usr/lib/mozilla/plugins/ dir to
/usr/lib/xulrunner-1.9pre/plugins 

Flash, totem, java plugins now work in epiphany for me. 
Comment 9 Christopher Aillon 2008-03-31 10:43:12 EDT
This problem likely stems from the following scenario:

nspluginwrapper is installed for a different architecture than epiphany is.  The
code checks for whether nspluginwrapper is installed and if so, wraps plugins
appropriately and uses $libdir/mozilla/plugins-wrapped else falls back to
$libdir/mozilla/plugins

However if the wrapping environment doesn't wrap the correct arch because of
arch mismatch, then this bug is quite likely.

A possible fix would be to perhaps make mozilla-plugin-config be a stub file
which checks uname and runs mozilla-plugin-config-{32,64} appropriately.  If
running the expected version were to fail, we can return EXIT_FAILURE and the
current code in epiphany would fall back to using $libdir/mozilla/plugins which
should be the desired behavior.
Comment 10 Bastien Nocera 2008-03-31 11:23:19 EDT
(In reply to comment #9)
> This problem likely stems from the following scenario:
> 
> nspluginwrapper is installed for a different architecture than epiphany is.

Unlikely (or my bug was wrongly marked as a dupe), I can reproduce this bug on
an i686 installation.
Comment 11 Bastien Nocera 2008-03-31 12:11:51 EDT
MOZ_PLUGIN_PATH gets set to:
/usr/lib/mozilla/plugins:/plugins:/usr/lib/mozilla/plugins-wrapped:/usr/lib/epiphany/2.22/plugins

The /plugins is clearly wrong (MOZILLA_HOME is empty, because GECKO_HOME is
empty as well).

This patch fixes it, feel free to apply it to the nspluginwrapper plugins path
patch, or the xulrunner patch that already changes the order of the
gtk_moz_embed_push_startup() call:

--- epiphany-2.22.0/embed/mozilla/mozilla-embed-single.cpp.orig	2008-03-31
17:09:03.000000000 +0100
+++ epiphany-2.22.0/embed/mozilla/mozilla-embed-single.cpp	2008-03-31
17:09:18.000000000 +0100
@@ -641,12 +641,12 @@ impl_init (EphyEmbedSingle *esingle)
         gtk_moz_embed_set_comp_path (MOZILLA_HOME);
 #endif
 #endif // XPCOM_GLUE
-	/* Fire up the beast */
-	gtk_moz_embed_push_startup ();
-
 	/* Pre initialization */
 	mozilla_init_plugin_path ();
 
+	/* Fire up the beast */
+	gtk_moz_embed_push_startup ();
+
 	mozilla_init_profile ();
 
 #ifdef HAVE_GECKO_1_9
Comment 12 Christopher Aillon 2008-03-31 14:15:24 EDT
Aha.  Thanks bastien.  Fixed in epiphany-2.22.0-3.fc9

Note You need to log in before you can comment on or make changes to this bug.