Bug 429182 - streams can only play once
streams can only play once
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xine-lib (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
: 429449 429456 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-17 14:49 EST by John Levon
Modified: 2008-01-24 17:04 EST (History)
8 users (show)

See Also:
Fixed In Version: 1.1.9.1-3.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-24 17:04:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Levon 2008-01-17 14:49:45 EST
Description of problem:

After updating to be current with today's Fedora 8, amarok
can no longer play properly. When you start it, it can play
once or twice, and then skips playing anything else immediately.
It's not plugin specific, as it happens with both oggs and mp3s,
and restarting amarok helps until the same thing happens. It's
not specific to local file vs. stream either.

Moving amarok rc files out of the way doesn't help, nor does
choosing between ALSA or OSS

This was working without problems, probably before the 2008-01-17 updates.

Version-Release number of selected component (if applicable):

Jan 17 16:15:15 pent yum: Updated: pulseaudio - 0.9.8-4.fc8.1.x86_64
amarok-1.4.8-1.fc8

How reproducible:

Every time

Steps to Reproduce:

See above
Comment 1 Rex Dieter 2008-01-17 14:55:24 EST
worksforme.  I'm thinking this may have more to do with pulseaudio (which you
upgraded at the same time), less to do with amarok.

Comment 2 John Levon 2008-01-17 15:04:33 EST
Quite possibly, yes, but I don't see any problems with mplayer.

heishiro on #fedora also sees this problem.
Comment 3 Heishiro Mitsurugi 2008-01-17 15:09:27 EST
Same problem here.

[root@lnxbb ~]# rpm -qa|grep amarok
amarok-extras-nonfree-1.4.4-1.lvn7
amarok-1.4.8-1.fc8
[root@lnxbb ~]# rpm -qa|grep pulseaudio
pulseaudio-module-x11-0.9.7-0.17.svn20071017.fc8
pulseaudio-utils-0.9.7-0.17.svn20071017.fc8
pulseaudio-esound-compat-0.9.7-0.17.svn20071017.fc8
pulseaudio-module-gconf-0.9.7-0.17.svn20071017.fc8
kde-settings-pulseaudio-3.5-35.fc8
pulseaudio-libs-0.9.7-0.17.svn20071017.fc8
alsa-plugins-pulseaudio-1.0.14-5.fc8
pulseaudio-core-libs-0.9.7-0.17.svn20071017.fc8
pulseaudio-libs-glib2-0.9.7-0.17.svn20071017.fc8
akode-pulseaudio-2.0.1-9.fc8
pulseaudio-0.9.7-0.17.svn20071017.fc8

I tried listening to a radio stream. It works the first time, but if i select
another stream, the same problem happens.

I have to quit amarok and restart it.

Thanks.
Comment 4 Rex Dieter 2008-01-17 15:12:08 EST
Also,
rpm -q xine-lib
please, as it was updated recently too.  amarok uses it under the hood to play
all content.

I'll have to keep trying harder to reproduce.
Comment 5 Heishiro Mitsurugi 2008-01-17 15:15:23 EST
In my case,

xine-lib-1.1.9.1-1.fc8

Comment 6 John Levon 2008-01-17 15:31:49 EST
same here.
Comment 7 Heishiro Mitsurugi 2008-01-17 15:34:33 EST
I updated the system using yum update, there was a pulseaudio update, but still
the problem remains...

pulseaudio-0.9.8-4.fc8.1
Comment 8 Heishiro Mitsurugi 2008-01-17 15:45:55 EST
If i run amarok, then reproduce a radio stream and then change the stream to
another radio, the problem happens.

Now, in order to make it work again, i have to restart Amarok, or get into
Settings - Configure Amarok, and change the output plugin to ALSA. That solves
the problem until i change the stream again.

Then i can change the Output Plugin to Auto-Detect and it solves the problem
again, until i change the stream again... and so on...

Comment 9 Heishiro Mitsurugi 2008-01-17 15:48:48 EST
Now, the alsa-related files that i have installed are:

alsa-utils-1.0.15-1.fc8
alsa-lib-1.0.15-1.fc8
alsa-plugins-pulseaudio-1.0.14-5.fc8
bluez-utils-alsa-3.20-4.fc8
Comment 10 Kevin Kofler 2008-01-17 15:51:18 EST
Make sure your ALSA playback device (for both mono and stereo) is set to 
default, not hw:0,0 or something like that. It works just fine for me when set 
to default.
Comment 11 Heishiro Mitsurugi 2008-01-17 15:59:36 EST
They are both in default when i select ALSA. When in autodetect the dialog is
not available.

xine-related files that i have installed are:

xinetd-2.3.14-14.fc8
xine-lib-extras-nonfree-1.1.9.1-1.lvn8
totem-xine-mozplugin-2.20.1-1.lvn8
xine-lib-1.1.9.1-1.fc8
xine-lib-arts-1.1.9.1-1.fc8
totem-xine-2.20.1-1.lvn8
Comment 12 Heishiro Mitsurugi 2008-01-17 16:12:26 EST
If i double click on a stream, the problem appears, there's no audio at all and
amarok starts working slowly, but, if i just don't select anything, the song
titles played by the radio station (Club 977 the 80's Channel), appear on screen
just as if the audio was working normally, only that there's no audio.

Comment 13 Heishiro Mitsurugi 2008-01-17 16:17:47 EST
The problem doesn't happen if i play two mp3's from the hdd, but with Radio
Streams it happens all the time.
Comment 14 John Levon 2008-01-17 16:19:09 EST
It occurs for me with disk files as well. Are you sure you tried several times
(let the playlist finish an mp3 and move to the next one a couple of times),
Heishiro?
Comment 15 Heishiro Mitsurugi 2008-01-17 16:26:10 EST
I loaded 30 mp3's and tried jumping from one to the other, and it worked all the
time. Also tried waiting for a track to finish, and it worked perfectly. The
problem appears to me when i change from a Radio Stream to another. When i do
that, the audio stops working until i close amarok or until i "reset" xine
through the Amarok Settings menu.
Comment 16 John Levon 2008-01-17 16:36:28 EST
That's odd. Apart from this difference, the behaviour you report is exactly the
same as what I see.
Comment 17 Heishiro Mitsurugi 2008-01-17 16:40:45 EST
Yeah. I tweaked everything i could but i couldn't solve the issue. Try updating
pulseaudio, and xine, to see if you at least get to the point where i am. (mp3's
working, but radio streams fail)
Comment 18 John Levon 2008-01-17 16:47:30 EST
I'm fully up to date.
Comment 19 Heishiro Mitsurugi 2008-01-17 17:07:55 EST
I tried combining the playlist with mp3's and radio streams. When the program
gets to the point where a Radio stream is going to be played, the problem happens.

At that point, if i try to double click on an mp3 file, the problem remains, but
the unusual thing i see is that amarok starts "skipping" the files. It tries to
play an mp3, shows the title, and it skips to the next file and so on until the
playlist is finished.

Hope you guys can solve the issue... (Kramer in Seinfeld - The Contest... I'M OUT)
Comment 20 Rex Dieter 2008-01-19 15:48:05 EST
From all accounts, xine-lib handles all that, and is the likely source of issue
here.  Re-assinging.
Comment 21 John Levon 2008-01-19 20:08:06 EST
Again, it's not specific to streams for me, so I'm not sure the new synopsis 
is correct.

BTW, if I do xine /some/file.mp3 then nothing comes out although it appears
to be playing. Not sure if this is related as I never use this frontend.
Comment 22 Ville Skyttä 2008-01-20 05:43:44 EST
I see exactly the same effect as Heishiro, and indeed it looks like a xine-lib
issue.

Upstream seems to be aware of it, but is unsure about what the correct fix is:
http://thread.gmane.org/gmane.comp.video.xine.devel/17682

Anyway, because some users on xine-devel reported success with the change
mentioned in the above thread, I've applied it in CVS.  koji does not respond to
me at the moment so I can't push a build, but in the meantime I've put a local
x86_64 build for testing up at http://scop.fedorapeople.org/packages/ . 
Non-x86_64 users can do a local mock rebuild from the src.rpm there or from
CVS's xine-lib F-8 branch.

Please test and report back how it works for you.  It appears to work fine for me.
Comment 23 Kevin Kofler 2008-01-20 07:25:05 EST
The patch this is reverting:
http://hg.debian.org/hg/xine-lib/xine-lib?cmd=changeset;node=1867fae812913d2ad953fb91359f886620bf1cf1;style=gitweb
is one of Matthias Kretz's Phonon-related changes, I hope we aren't breaking 
Phonon badly by reverting it. :-( That would be a lose-lose situation, with 
either Amarok or Phonon broken.
Comment 24 Rex Dieter 2008-01-20 08:44:37 EST
*** Bug 429449 has been marked as a duplicate of this bug. ***
Comment 25 Neal Becker 2008-01-20 08:57:09 EST
(In reply to comment #22)
> I see exactly the same effect as Heishiro, and indeed it looks like a 
xine-lib
> issue.
> 
> Upstream seems to be aware of it, but is unsure about what the correct fix 
is:
> http://thread.gmane.org/gmane.comp.video.xine.devel/17682
> 
> Anyway, because some users on xine-devel reported success with the change
> mentioned in the above thread, I've applied it in CVS.  koji does not 
respond to
> me at the moment so I can't push a build, but in the meantime I've put a 
local
> x86_64 build for testing up at http://scop.fedorapeople.org/packages/ . 
> Non-x86_64 users can do a local mock rebuild from the src.rpm there or from
> CVS's xine-lib F-8 branch.
> 
> Please test and report back how it works for you.  It appears to work fine 
for me.

Just tested on x86_64 and confirm this fixes the problem.  Thanks!

Comment 26 Ville Skyttä 2008-01-20 09:27:06 EST
(In reply to comment #23)
> That would be a lose-lose situation, with either Amarok or Phonon broken.

That would be bad indeed.  Other fix/workaround suggestions welcome.  If Phonon
is the only thing suffering from the "discard buffers"-patchless xine-lib, that
seems clearly the way to go at least for < F9.

Hmm, if Matthias' patch sets audio output to "discard buffers" mode when closing
it, should the "discard buffers" mode be disabled again somewhere when audio
output is opened again?

John, Heishiro, please report whether the packages mentioned in comment 22 fix
the problem for you too.  And if someone has a setup where Phonon can be tested
with the patched packages, comments from that would be very welcome as well.
Comment 27 Rex Dieter 2008-01-20 12:07:03 EST
*** Bug 429456 has been marked as a duplicate of this bug. ***
Comment 28 Sean Bruno 2008-01-20 12:33:24 EST
The rpm's in comment 22 resolve my issues and I can confirm that they fix the issue.
Comment 29 John Levon 2008-01-20 17:45:00 EST
Works for me too, thanks for working this out so quickly!
Comment 30 Florian Sievert 2008-01-21 09:32:13 EST
I don't know if this helps, but... i have a self compiled KDE 4 trunk on my
system and just installed the xine-*-1.1.9.1-3.fc8-packages from koji. Looks
like phonon is still working, while the package fixes the stream problem.
Comment 31 Michael Best 2008-01-21 17:24:11 EST
I'm having the same problem.  How does one find the
"xine-*-1.1.9.1-3.fc8-packages from koji"  I reverted to the Fedora release
version of the packages.
Comment 32 Michael Best 2008-01-21 17:35:01 EST
Link to koji's build of xine-lib-1.1.9.1-3.fc8 
http://koji.fedoraproject.org/koji/buildinfo?buildID=32264
Comment 33 Fedora Update System 2008-01-22 11:03:26 EST
xine-lib-1.1.9.1-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xine-lib'
Comment 34 Fedora Update System 2008-01-24 17:04:17 EST
xine-lib-1.1.9.1-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.