Bug 429358 - sets encryption passphrase with a different keymap than it's read from on boot
sets encryption passphrase with a different keymap than it's read from on boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
NeedsRetesting
:
: 432398 443061 (view as bug list)
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-01-18 16:19 EST by Bill Nottingham
Modified: 2014-03-16 23:12 EDT (History)
5 users (show)

See Also:
Fixed In Version: mkinitrd-6.0.32-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 18:01:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2008-01-18 16:19:05 EST
Description of problem:

anaconda sets the encryption passphrase by reading what the user typed in, under
X with whatever X keymap is appropriate for the locale.

boot reads the passphrase with whatever keymap the BIOS is using, as we haven't
set any keymaps at that point.

That's going to cause issues somewhere.

Version-Release number of selected component (if applicable):

rawhide-20080118
Comment 1 Jeremy Katz 2008-01-18 16:49:25 EST
dlehman had been looking at this...  getting the ckbcomp stuff in for console
keymaps so that we can better match the X maps would make things a lot easier
Comment 2 Mr. Mizzen 2008-02-08 09:30:56 EST
Any passphrase with the special Hungarian Letters fails..... as above expected
it would.

Most of Hungarian keys will make an * when entering the passphrase.
However, none of the top row keys that use the <Alt GR> key function.
No *, just a beep.
Very odd as the top row keys normaly work with X just fine.
Comment 3 Dave Russell 2008-02-18 13:23:01 EST
Now that a default install for F9-Alpha uses encryption this issue with keymap
should (I feel) be raised to a higher priority (which I've done, let me know if
you disagree).

If we don't solve this, or at least tell users only to use ordinary numbers and
letters, we're going to have a lot of boxes that people install only to be be
told they have the wrong passphrase.

I know, I've just hit it twice :o) Then found this bug.
Comment 4 Jon Stanley 2008-02-19 23:41:39 EST
*** Bug 432398 has been marked as a duplicate of this bug. ***
Comment 5 Jon Stanley 2008-02-19 23:46:10 EST
Per the bug that I just dup'ed to this, this is also a problem if the user
wishes to use a Dvorak keyboard.
Comment 6 Patrick C. F. Ernzer 2008-03-04 09:18:50 EST
Problem (obviously) also exists with Finnish/Swedish keyboard
Comment 7 Jeremy Katz 2008-03-04 16:09:18 EST
dlehman committed something to support keymaps in the initrd and I'll be
rebuilding mkinitrd hopefully in the next hour or two
Comment 8 Jesse Keating 2008-04-01 16:22:23 EDT
Does this still happen?  Jeremy did a mkinitrd build a while ago, just need to
verify that it's fixed.
Comment 9 Jon Stanley 2008-04-02 11:58:53 EDT
I've noticed that there is a message that the keymap is loaded now.  Since I
don't have any keyboard other than US English, I can't test that it actually
loads some other keymap if configured to do so.
Comment 10 Jay Fenlason 2008-04-02 14:37:29 EDT
This is fixed on my F9/rawhide box now--it successfully loads the dvorak 
keymap and lets me type in my passphrase in the layout I used to do the 
install in.
Comment 11 David Lehman 2008-04-07 18:01:13 EDT
Closing based on comment #10.
Comment 12 Jon Stanley 2008-04-27 09:10:08 EDT
*** Bug 443061 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.