Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 430816 - Xinetd'd initscript contains syntax errors (uninstall fails)
Xinetd'd initscript contains syntax errors (uninstall fails)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xinetd (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jan Safranek
Fedora Extras Quality Assurance
:
: 430909 431104 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-29 17:45 EST by Stewart Adam
Modified: 2008-02-01 03:10 EST (History)
2 users (show)

See Also:
Fixed In Version: xinetd-2.3.14-17.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-30 03:31:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix initscript syntax error, link condrestart --> restart (342 bytes, patch)
2008-01-29 17:45 EST, Stewart Adam
no flags Details | Diff
another possible fix (372 bytes, patch)
2008-01-29 20:27 EST, Michal Jaegermann
no flags Details | Diff

  None (edit)
Description Stewart Adam 2008-01-29 17:45:55 EST
Description of problem:
Uninstall of xinetd-2.3.14-14.fc8.x86_64 fails because of an error present in
the initscript (also present in xinetd-2.3.14-16.fc9.x86_64).

The patch attached fixes the syntax error, as well as links condrestart to the
restart function so that the rpm scriptlets restarts xinetd.

Version-Release number of selected component (if applicable):
xinetd-2.3.14-14.fc8.x86_64
xinetd-2.3.14-16.fc9.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Update/remove xinetd when xinetd-2.3.14-16.fc9.x86_64 was installed
  
Actual results:
The scriptlet fails, package remains installed

Expected results:
The package uninstalls and where applicable condrestart restarts the Xinetd service

Additional info:
Comment 1 Stewart Adam 2008-01-29 17:45:55 EST
Created attachment 293353 [details]
Patch to fix initscript syntax error, link condrestart --> restart
Comment 2 Michal Jaegermann 2008-01-29 20:27:20 EST
Created attachment 293359 [details]
another possible fix

It appears that actually something simpler, like that, was intended
in ther first place.
Comment 3 Stewart Adam 2008-01-29 21:02:39 EST
<snip>
+    condrestart|try-restart)
 	condrestart <-- shouldn't this be "restart"?
<snip>
Comment 4 Jan Safranek 2008-01-30 03:31:07 EST
Thanks for the bug report! It should be fixed in xinetd 2.3.14-17.
Comment 5 Jan Safranek 2008-01-30 10:17:29 EST
*** Bug 430909 has been marked as a duplicate of this bug. ***
Comment 6 Jan Safranek 2008-02-01 03:10:02 EST
*** Bug 431104 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.