Bug 431366 - crond not running after upgrade to cronie
Summary: crond not running after upgrade to cronie
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: cronie   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
: 431367 432255 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-03 17:21 UTC by John Ellson
Modified: 2008-02-15 15:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-15 15:11:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Ellson 2008-02-03 17:21:49 UTC
Description of problem:
crond is not running after upgrade to cronie.  Something missing in init scripts?

Version-Release number of selected component (if applicable):
cronie-1.0-2.fc9.x86_64

How reproducible:


Steps to Reproduce:
1. upgrade to cronie
2. reboot
3.
  
Actual results:
no cron jobs run

Expected results:
cron jobs run as scheduled in crontabs.    

Additional info:

Comment 1 Jonathan Kamens 2008-02-05 02:31:45 UTC
*** Bug 431367 has been marked as a duplicate of this bug. ***

Comment 2 Marcela Mašláňová 2008-02-05 14:55:34 UTC
Thanks for report. It was fixed in rawhide.

Comment 3 John Ellson 2008-02-07 14:35:23 UTC
Not fixed as of cronie-1.0-3.fc9

crond not running after reboot

/etc/rc.d/*/*crond shows no runlevel links to start or stop crond

Comment 4 Marcela Mašláňová 2008-02-07 14:51:00 UTC
I've already fixed it and hope that now is really everything working.
Functional cron should be in version cronie-1.0-4.fc9

Comment 5 Marcela Mašláňová 2008-02-12 11:30:26 UTC
*** Bug 432255 has been marked as a duplicate of this bug. ***

Comment 6 John Ellson 2008-02-12 13:52:17 UTC
Agree with #432255

Still not starting.  No entries in /etc/rc.d/rc*.d/  after upgrade
to cronie-1.0-4.fc9

Is this because of damage caused by cronie-1.0-[123] ?

cronie should repair the damage.  Or at least warn the user that someting needs
to be fixed.

Comment 7 Marcela Mašláňová 2008-02-12 15:12:23 UTC
Thank you!

I test it for upgrade from vixie-cron on cronie, but forgot test it for
cronie<1.0-4 on cronie-1.0-5. Please test the cronie-1.0-5 and let me know.

The problem was in the rpm spec file.

Comment 8 John Ellson 2008-02-15 15:08:09 UTC
OK, thanks, now you can close it :)


Note You need to log in before you can comment on or make changes to this bug.