This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 432132 - Kopete 0.50.1 does not connect to google talk / jabber
Kopete 0.50.1 does not connect to google talk / jabber
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdenetwork (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Lukáš Tinkl
Fedora Extras Quality Assurance
: Reopened
: 436972 445117 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-08 19:03 EST by Teodosiy Kirilov
Modified: 2015-07-13 13:37 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-20 15:58:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Kopete output when connecting to google talk / jabber (5.33 KB, text/plain)
2008-02-08 19:03 EST, Teodosiy Kirilov
no flags Details
Kopete GTalk working (56.72 KB, image/jpeg)
2008-03-11 10:42 EDT, Lukáš Tinkl
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 154940 None None None Never

  None (edit)
Description Teodosiy Kirilov 2008-02-08 19:03:47 EST
Description of problem:
Kopete (0.50.1; kde4.0.1) can't connect with SSL/TLS encripted jabber (google 
talk). I don't even get the certificate authorization request.

Version-Release number of selected component (if applicable):
kdenetwork-4.0.1-2.fc9.i386
kdebase-4.0.1-3.fc9.i386
kdelibs-4.0.1-3.fc9.i386
qca2-2.0.0-1.fc9.i386
qca-ossl-2.0.0-0.3.beta3.fc9.i386

How reproducible:
Try using Kopete (0.50.1) with jabber/google talk

Actual results:
After a while the protocol is offline

Expected results:
Successful connection through the gtalk account


Additional info:
I've also tried to use kopete 0.50.1 on a Kubuntu with kde 4.0.1 - it worked. 
So I guess the Problem can be in the QCA / OSSL plugin. 
I don't know if it might be useful, but kopete says MSN was connected 
successfuly (I had no online contacts, so not sure if it realy worked)
Comment 1 Teodosiy Kirilov 2008-02-08 19:03:47 EST
Created attachment 294437 [details]
Kopete output when connecting to google talk / jabber
Comment 2 Gerald Cox 2008-02-26 23:53:14 EST
Same here, installed qca-tls-1.0-13.fc9.x86_64 but didn't help.  Looks like the
plugin is required.

Also, MSN is not connecting.  It is working fine on my FC8 system and with
Windows system using Pidgin, but doesn't work with kopete 0.50.1.

AIM, ICQ and non-SSL jabber accounts work fine.
Comment 3 Kevin Kofler 2008-03-11 09:49:16 EDT
*** Bug 436972 has been marked as a duplicate of this bug. ***
Comment 4 Gerald Cox 2008-03-11 10:19:57 EDT
Installation of 
qca-ossl-2.0.0-0.4.beta3.fc9.x86_64
resolves SSL message and jabber.org session connects;

however, googletalk and MSN still receive
"connecting" and then disconnect.  No other message
received.
Comment 5 Rex Dieter 2008-03-11 10:26:08 EDT
gtalk is known to not work, see also upstream report:
http://bugs.kde.org/154940
Comment 6 Lukáš Tinkl 2008-03-11 10:41:23 EDT
Hmm, connecting to Jabber/Gtalk definitely works for me.

qca-tls-1.0-11.fc8
qca-ossl-2.0.0-0.1.beta1.fc8
qca-gnupg-2.0.0-0.1.beta1.fc8
qca2-devel-2.0.0-1.fc8
qca2-2.0.0-1.fc8

Comment 7 Lukáš Tinkl 2008-03-11 10:42:47 EDT
Created attachment 297618 [details]
Kopete GTalk working
Comment 8 Gerald Cox 2008-03-11 12:28:45 EDT
are you running rawhide or F8?  I'm running F9 (rawhide) - so that may be the
difference.
Comment 9 Gerald Cox 2008-04-10 22:36:42 EDT
Just retested with kdenetwork-4.0.3-4.fc9.x86_64
Googletalk does not connect.  

Using:  talk.google.com and port 5223

Have SSL and Plain text authentication selected.

Interesting to note however that I am able to connect to jabber.org using SSL
via kopete.

I have no problems connecting to googletalk under F8 with kopete.  Am able to
connect under F9 using PIDGIN client with no issues.

Comment 10 Rex Dieter 2008-04-10 22:51:34 EDT
Problem is not fixed, but closed->upstream, which means only we're continuing to
track it there (not here).  Please make further comments there:
http://bugs.kde.org/154940
Comment 11 Kevin Kofler 2008-05-03 20:19:36 EDT
*** Bug 445117 has been marked as a duplicate of this bug. ***
Comment 12 Lukáš Tinkl 2008-05-31 07:16:28 EDT
I'm testing a fix for that
Comment 13 Fedora Update System 2008-05-31 08:06:14 EDT
kdenetwork-4.0.4-4.fc9 has been submitted as an update for Fedora 9
Comment 14 Fedora Update System 2008-06-03 03:33:17 EDT
kdenetwork-4.0.4-4.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Kevin Kofler 2008-10-20 12:20:25 EDT
So can we close this as fixed or does this still happen with current 4.1.x?
Comment 16 Teodosiy Kirilov 2008-10-20 15:43:47 EDT
It works for me since quite a while (June I think)... So I guess this issue can be closed

Note You need to log in before you can comment on or make changes to this bug.