Bug 433359 - Closing rxvt-unicode crashes X
Closing rxvt-unicode crashes X
Status: CLOSED DUPLICATE of bug 443299
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
: 443368 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-18 15:37 EST by Brad Walker
Modified: 2009-10-22 08:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-27 19:42:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log.old aftercrash from closing urxvt (21.85 KB, text/plain)
2008-02-18 15:37 EST, Brad Walker
no flags Details

  None (edit)
Description Brad Walker 2008-02-18 15:37:17 EST
Description of problem: Closing rxvt-unicode crashes X.


Version-Release number of selected component (if applicable):
rxvt-unicode.9.0-2xorg-x11-server-Xorg-1.4.99.1-0.19.20080107.fc9.x86_64.fc9.x86_64
xorg-x11-drv-i810-2.2.0-3.fc9.x86_64


How reproducible: Always


Steps to Reproduce:
1. Start X with GLX enabled
2. Run `urxvt'
3. Close urxvt window
  
Actual results:
The first time it crashes X and kicks back to GDM.
If done again without rebooting, it crashes X and locks the video.


Expected results: Window closed


Additional Info: Disabling the GLX module in Xorg.conf works around the problem
at the cost of performance.
Comment 1 Brad Walker 2008-02-18 15:37:17 EST
Created attachment 295205 [details]
Xorg.0.log.old aftercrash from closing urxvt
Comment 2 Brad Walker 2008-04-25 05:48:44 EDT
I can still reproduce this problem with these packages:

rxvt-unicode-9.02-2.fc9.x86_64
xorg-x11-server-Xorg-1.4.99.901-23.20080415.fc9.x86_64
xorg-x11-drv-i810-2.2.1-22.fc9.x86_64
Comment 3 Matěj Cepl 2008-04-25 09:06:59 EDT
Wov! It really works like charm, one wouldn't believe what urxvt can do ;-).
Comment 4 Dave Airlie 2008-04-27 19:42:17 EDT

*** This bug has been marked as a duplicate of 443299 ***
Comment 5 Matěj Cepl 2008-04-29 12:07:39 EDT
*** Bug 443368 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.