Bug 433546 - gcc 4.3 miscompiles ntfs-3g
gcc 4.3 miscompiles ntfs-3g
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
: 434660 434921 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-19 17:37 EST by James Ralston
Modified: 2008-02-26 19:39 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-26 14:43:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Ralston 2008-02-19 17:37:46 EST
I have a box that is dual-boot between Windows XP Professional and (currently)
Fedora Rawhide.  XP's C: drive is /dev/sda1; it is NTFS.

When I attempt to mount /dev/sda1 with ntfs-3g-1.2216-1.fc9, it fails with:

Failed to read $MFTMirr: Input/output error
Failed to mount '/dev/sda1': Input/output error
NTFS is either inconsistent, or you have hardware faults, or you have a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows TWICE. The usage of the /f parameter is very
important! If you have SoftRAID/FakeRAID then first you must activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for the details.

Per the error message, I ran chkdsk /f as instructed, but the error persists. 
(Unfortunately, using "-o debug" yields no additional debugging output.)

If I revert to ntfs-3g-1.2121-0.1.RC.fc9, everything seems to work fine; I can
mount /dev/sda1 with no errors.

Methinks ntfs-3g-1.2216-1.fc9 is broken...
Comment 1 Tom "spot" Callaway 2008-02-19 17:42:31 EST
Paging szaka to this bug.
Comment 2 Szabolcs Szakacsits 2008-02-19 18:01:11 EST
The latest development version of gcc 4.3 miscompiles ntfs-3g with the same
symptom. If you have such a compiler then assign the bug to the gcc developers. 

Afaik, so far they couldn't find where the problem is but if you stuck with the
issue let me know and I'll find the time to track it down and make a workaround
(currently I'm pretty busy with my day job and other matters).
Comment 3 James Ralston 2008-02-19 23:26:21 EST
I'm not 100% sure if ntfs-3g-1.2216-1.fc9 was built with gcc 4.3 (I can't see
anything obvious from inspecting the binaries or debuginfo objects), but based
on when it built, I strongly suspect it was.

Reassigning to component gcc and updating the description.

(No need to spend time hacking around this, Szabolcs; I can use the
ntfs-3g-1.2121-0.1.RC.fc9 package for now.)
Comment 4 Tom "spot" Callaway 2008-02-24 03:35:36 EST
*** Bug 434660 has been marked as a duplicate of this bug. ***
Comment 5 Szabolcs Szakacsits 2008-02-24 07:23:57 EST
Fyi, gcc has fixed the miscompilation bug and the fix will be included in the
next alpha gcc release: http://gcc.gnu.org/bugzilla/show_bug.cgi?id=35264
Comment 6 James Ralston 2008-02-25 11:43:52 EST
Yay.

Tom, while I suspect you planned to do so already, can you update this bug when
a correctly-compiled version of ntfs-3g hits rawhide?  (I'm using
yum-versionlock to prevent yum from upgrading ntfs-3g, so I won't know when a
fixed version hits rawhide...)
Comment 7 Tom "spot" Callaway 2008-02-26 09:14:02 EST
*** Bug 434921 has been marked as a duplicate of this bug. ***
Comment 8 Tom "spot" Callaway 2008-02-26 14:00:39 EST
Absolutely. :)(In reply to comment #6)
> Yay.
> 
> Tom, while I suspect you planned to do so already, can you update this bug when
> a correctly-compiled version of ntfs-3g hits rawhide?  

Sure. :)
Comment 9 Tom "spot" Callaway 2008-02-26 14:43:01 EST
1.2216-3 just finished building:

http://koji.fedoraproject.org/packages/ntfs-3g/1.2216/3.fc9/

Works for me, reopen if it doesn't work for you. :)

Comment 10 James Ralston 2008-02-26 19:39:00 EST
Seconded; 1.2216-3 works fine for me.

Note You need to log in before you can comment on or make changes to this bug.