Bug 434135 - moto4lin failed massrebuild attempt for GCC 4.3
moto4lin failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: moto4lin (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: jafo-redhat
Fedora Extras Quality Assurance
: Reopened
: 382171 440713 (view as bug list)
Depends On:
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 08:09 EST by Jesse Keating
Modified: 2013-01-09 21:57 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-17 10:17:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Make the desktop file validate (677 bytes, patch)
2008-04-01 00:14 EDT, Christopher Aillon
no flags Details | Diff

  None (edit)
Description Jesse Keating 2008-02-22 08:09:02 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=439730
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Tyler Owen 2008-02-26 07:03:51 EST
/var/tmp/moto4lin-0.3-7.fc9-root-mockbuild/usr/share/applications/fedora-moto4lin.desktop:
error: value "0.3" for key "Version" in group "Desktop Entry" is not a known version
Error on file "/builddir/build/SOURCES/moto4lin.desktop": Failed to validate the
created desktop file
Comment 2 Christopher Aillon 2008-04-01 00:14:15 EDT
Created attachment 299828 [details]
Make the desktop file validate

I would have committed and built this but ACLs are locked
Comment 3 Jesse Keating 2008-04-07 22:51:20 EDT
Submitted as http://koji.fedoraproject.org/koji/taskinfo?taskID=555896
Comment 4 Jesse Keating 2008-04-07 23:14:26 EDT
Well, I committed the desktop fix, but now it fails to find qmake in configure.
 Not sure what to do for that, will punt to the KDE team.
Comment 5 Rex Dieter 2008-04-08 15:53:16 EDT
*** Bug 382171 has been marked as a duplicate of this bug. ***
Comment 6 Rex Dieter 2008-04-08 16:03:48 EDT
fixed in rawhide.
Comment 7 Rex Dieter 2008-04-08 16:05:01 EDT
nevermind, no cvsextras access, my commit failed.
Comment 8 Rex Dieter 2008-04-08 16:10:40 EDT
scratch build with fixes:
http://koji.fedoraproject.org/koji/taskinfo?taskID=558347
Comment 9 Bug Zapper 2008-05-14 01:27:23 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Matt Domsch 2008-07-03 11:48:42 EDT
care to make a non-scratch build of this?
Comment 11 Matt Domsch 2008-07-03 11:49:05 EDT
*** Bug 440713 has been marked as a duplicate of this bug. ***
Comment 12 FTBFS 2008-09-05 12:14:03 EDT
This package has Failed to Build From Source for many months.  Per
http://fedoraproject.org/wiki/FTBFS, this package is now proposed for
removal from the distribution.  Please address this FTBFS bug
immediately, or this package will be removed from the distribution
within the next few weeks.

Thank you for your continued contributions to Fedora, and your
commitment to ensuring Fedora packages remain buildable from source
code.
Comment 13 Matt Domsch 2008-09-17 00:58:18 EDT
jafo - ping.  Several people have tried to help you resolve this bug since February 2008, but with locked ACLs, very few people (only rel-eng members) can.

Please see above for the scratch build which includes the fix for this bug.  Otherwise, we will be forced to remove this package before Fedora 10.

Thanks,
Matt
Comment 14 Sean Reifschneider 2008-09-17 03:34:18 EDT
The ACLs should be opened, thanks to Kevin for helping me figure that out.

Sorry, I haven't had much attention for this lately.  Thanks for your help on getting these issues resolved.

Sean
Comment 15 Matt Domsch 2008-09-17 09:01:04 EDT
Thanks Sean.

Rex, can you take your above scratch build and commit it to CVS and do a real build then?

Thanks,
Matt
Comment 16 Rex Dieter 2008-09-17 09:11:17 EDT
Looks like Jesse did it way back when...
http://koji.fedoraproject.org/koji/buildinfo?buildID=45624

Or would folks prefer a new/f10 build?
Comment 17 Matt Domsch 2008-09-17 10:00:15 EDT
Jesse tried, but it failed, and has been on the FTBFS list since then.  Rex, if you could do a new f10 build that should clear it up so we can close this bug.

Thanks,
Matt
Comment 18 Rex Dieter 2008-09-17 10:06:28 EDT
ok.

but I don't see any f10 failures at
https://koji.fedoraproject.org/koji/packageinfo?packageID=2572
?
Comment 19 Rex Dieter 2008-09-17 10:17:14 EDT
motolin-0.3-10.fc10 build underway. 

When finished, I'll go ahead and tag it.
Comment 20 Matt Domsch 2008-09-17 10:20:46 EDT
+ /bin/cat /builddir/build/SOURCES/moto4lin-0.3-crossplatform.patch
+ qmake
/var/tmp/rpm-tmp.pQPMvX: line 39: qmake: command not found
RPM build errors:
error: Bad exit status from /var/tmp/rpm-tmp.pQPMvX (%prep)
    Bad exit status from /var/tmp/rpm-tmp.pQPMvX (%prep)


in my build system...
Comment 21 Rex Dieter 2008-09-17 10:33:58 EDT
Your buildsys apparently doesn't source /etc/profile.d/qt.sh  (and older version of mock?)

Shrug, I put in a workaround in the specfile for that anyway.

Note You need to log in before you can comment on or make changes to this bug.