Bug 434528 - vtk failed massrebuild attempt for GCC 4.3
vtk failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vtk (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
: 440723 449426 (view as bug list)
Depends On:
Blocks: gcc43errors F9Upgrade
  Show dependency treegraph
 
Reported: 2008-02-22 11:33 EST by Jesse Keating
Modified: 2013-01-09 22:17 EST (History)
4 users (show)

See Also:
Fixed In Version: 5.0.4-21.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-14 10:41:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-02-22 11:33:42 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=451616
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Henning Norén 2008-02-22 18:00:41 EST
[ 59%] Building CXX object
Utilities/DICOMParser/CMakeFiles/vtkDICOMParser.dir/DICOMAppHelper.o
In file included from
/builddir/build/BUILD/VTK/Utilities/DICOMParser/DICOMParser.h:38,
                 from
/builddir/build/BUILD/VTK/Utilities/DICOMParser/DICOMCallback.h:32,
                 from
/builddir/build/BUILD/VTK/Utilities/DICOMParser/DICOMAppHelper.h:32,
                 from
/builddir/build/BUILD/VTK/Utilities/DICOMParser/DICOMAppHelper.cxx:29:
/builddir/build/BUILD/VTK/Utilities/DICOMParser/DICOMFile.h: In static member
function 'static uint DICOMFile::swap4(uint)':
/builddir/build/BUILD/VTK/Utilities/DICOMParser/DICOMFile.h:220: warning:
suggest parentheses around arithmetic in operand of |
/builddir/build/BUILD/VTK/Utilities/DICOMParser/DICOMFile.h:221: warning:
suggest parentheses around arithmetic in operand of |
/builddir/build/BUILD/VTK/Utilities/DICOMParser/DICOMAppHelper.cxx: In member
function 'virtual void
DICOMAppHelper::ImagePositionPatientCallback(DICOMParser*, doublebyte,
doublebyte, DICOMParser::VRTypes, unsigned char*, quadbyte)':
/builddir/build/BUILD/VTK/Utilities/DICOMParser/DICOMAppHelper.cxx:592: error:
'memcpy' was not declared in this scope
/builddir/build/BUILD/VTK/Utilities/DICOMParser/DICOMAppHelper.cxx:614: error:
'memcpy' was not declared in this scope
/builddir/build/BUILD/VTK/Utilities/DICOMParser/DICOMAppHelper.cxx: In member
function 'virtual void
DICOMAppHelper::ImageOrientationPatientCallback(DICOMParser*, doublebyte,
doublebyte, DICOMParser::VRTypes, unsigned char*, quadbyte)':
/builddir/build/BUILD/VTK/Utilities/DICOMParser/DICOMAppHelper.cxx:660: error:
'memcpy' was not declared in this scope
/builddir/build/BUILD/VTK/Utilities/DICOMParser/DICOMAppHelper.cxx:688: error:
'memcpy' was not declared in this scope
/builddir/build/BUILD/VTK/Utilities/DICOMParser/DICOMAppHelper.cxx: In member
function 'virtual void DICOMAppHelper::TransferSyntaxCallback(DICOMParser*,
doublebyte, doublebyte, DICOMParser::VRTypes, unsigned char*, quadbyte)':
/builddir/build/BUILD/VTK/Utilities/DICOMParser/DICOMAppHelper.cxx:713: error:
'strcmp' was not declared in this scope
/builddir/build/BUILD/VTK/Utilities/DICOMParser/DICOMAppHelper.cxx: In member
function 'const char* DICOMAppHelper::TransferSyntaxUIDDescription(const char*)':
/builddir/build/BUILD/VTK/Utilities/DICOMParser/DICOMAppHelper.cxx:1016: error:
'strcmp' was not declared in this scope
make[2]: ***
[Utilities/DICOMParser/CMakeFiles/vtkDICOMParser.dir/DICOMAppHelper.o] Error 1
make[1]: *** [Utilities/DICOMParser/CMakeFiles/vtkDICOMParser.dir/all] Error 2
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.22987 (%build)
Comment 2 Alex Lancaster 2008-03-11 08:58:45 EDT
Looks like ACLs are closed for other Fedora developers:

https://admin.fedoraproject.org/pkgdb/packages/name/vtk

Axel, could you possibly open up the ACLs so that others can apply a patch and
fix this?  It is causing broken deps in rawhide:

Broken deps for i386
----------------------------------------------------------
<snip>

        vtk-examples-5.0.3-22.fc9.i386 requires vtkdata = 0:5.0.3
        vtk-testing-5.0.3-22.fc9.i386 requires vtkdata = 0:5.0.3



Thanks.
Comment 3 Axel Thimm 2008-03-11 12:10:07 EDT
Hi Alex,

wouldn't you like to submit the patch for a review first?
Comment 4 Axel Thimm 2008-04-05 06:28:05 EDT
*** Bug 440723 has been marked as a duplicate of this bug. ***
Comment 5 Alex Lancaster 2008-04-07 09:13:52 EDT
(In reply to comment #3)
> Hi Alex,
> 
> wouldn't you like to submit the patch for a review first?

I thought that I might get time to do this, but unfortunately have not.  It
should be fairly straightforward, just search for each error in:

http://gcc.gnu.org/gcc-4.3/porting_to.html

and there's pretty much a straightforward fix.  This should be fixed soon,
however, as it it will cause issues on upgrade from F-8 as:

F8-updates > F9 (0:5.0.4-19.fc8 > 0:5.0.3-22.fc9)

as noted by Josh in recent post on fedora-devel-list

In any case, it would be good to open up the ACLs so that others could patch it
if you get busy.  (I've opened up all my packages).
Comment 6 Alex Lancaster 2008-04-12 09:30:12 EDT
Looks like a new rebuild has arrived that applies a patch by Orion Poplawski on
fedora-devel-list that fixes this:

http://koji.fedoraproject.org/koji/buildinfo?buildID=45989

Once this has been tagged f9-final by rel-eng.  I'll close this bug.
Comment 7 Alex Lancaster 2008-04-14 10:41:27 EDT
Apparently tagged now.  Closing.
Comment 8 Matt Domsch 2008-07-03 11:51:04 EDT
*** Bug 449426 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.