Bug 449426 - FTBFS vtk-5.0.4-21.fc9
FTBFS vtk-5.0.4-21.fc9
Status: CLOSED DUPLICATE of bug 434528
Product: Fedora
Classification: Fedora
Component: vtk (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
:
Depends On:
Blocks: FTBFS
  Show dependency treegraph
 
Reported: 2008-06-02 12:46 EDT by FTBFS
Modified: 2008-07-03 11:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-03 11:51:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log.bz2 (5.16 KB, application/x-bzip2)
2008-06-02 12:46 EDT, FTBFS
no flags Details
build.log.bz2 (36.30 KB, application/x-bzip2)
2008-06-02 12:46 EDT, FTBFS
no flags Details
root.log.bz2 (28.88 KB, application/x-bzip2)
2008-06-02 12:46 EDT, FTBFS
no flags Details
build.log.bz2 (36.00 KB, application/x-bzip2)
2008-06-02 12:47 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2008-06-02 12:46:04 EDT
vtk-5.0.4-21.fc9.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
Comment 1 FTBFS 2008-06-02 12:46:29 EDT
Created attachment 307455 [details]
root.log.bz2

root.log for i386
Comment 2 FTBFS 2008-06-02 12:46:41 EDT
Created attachment 307456 [details]
build.log.bz2

build.log for i386
Comment 3 FTBFS 2008-06-02 12:46:53 EDT
Created attachment 307457 [details]
root.log.bz2

root.log for x86_64
Comment 4 FTBFS 2008-06-02 12:47:01 EDT
Created attachment 307458 [details]
build.log.bz2

build.log for x86_64
Comment 5 Orion Poplawski 2008-06-02 16:17:02 EDT
Axel -

 How does this look as a fix:

diff -u -r1.10 vtk.spec
--- vtk.spec    21 May 2008 20:20:18 -0000      1.10
+++ vtk.spec    2 Jun 2008 20:11:27 -0000
@@ -1,6 +1,7 @@
 %bcond_without OSMesa
 %bcond_with qt4
 %bcond_with java
+%bcond_with check

 %{!?python_sitearch:%global python_sitearch %(%{__python} -c "from
distutils.sysconfig import get_python_lib; print get_python_lib(1)")}

@@ -288,8 +289,12 @@
 # Add exec bits to shared libs ...
 chmod 0755 %{buildroot}%{_libdir}/vtk-5.0/CMake/*.so

-%check || :
-#LD_LIBARARY_PATH=`pwd`/bin ctest -V
+%if %{with check}
+%check
+#Most of these fail due to no DISPLAY, but someone might want to run them by hand
+export LD_LIBRARY_PATH=`pwd`/bin
+ctest
+%endif

 %clean
 rm -rf %{buildroot}
Comment 6 Matt Domsch 2008-07-03 11:51:03 EDT
patch included in this report

*** This bug has been marked as a duplicate of 434528 ***

Note You need to log in before you can comment on or make changes to this bug.