Bug 434824 - KDE4 System Settings - No Method To Enter Administrative Mode
KDE4 System Settings - No Method To Enter Administrative Mode
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lukáš Tinkl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-25 12:54 EST by Gerald Cox
Modified: 2015-07-13 13:36 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-16 11:50:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Preliminary support for root privs in systemsettings (2.39 KB, patch)
2008-02-28 10:14 EST, Lukáš Tinkl
no flags Details | Diff
Fixed clock (date/time) kcm .desktop file (413 bytes, patch)
2008-02-28 10:15 EST, Lukáš Tinkl
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 151669 None None None Never

  None (edit)
Description Gerald Cox 2008-02-25 12:54:55 EST
Description of problem:
System Settings (KDE) does not have mechanism to enter administrative mode to
change system settings, e.g. cannot modify Login Manager (KDM). 

Version-Release number of selected component (if applicable):
kdebase-4.0.1-3.fc9.x86


How reproducible:
Enter system settings application.  No method provided to enter administrative
mode to change system settings.


Steps to Reproduce:
1.  From KMENU, Select Computer, Select Applications (System Settings)
2.  Select Advanced, Select System (Login Manager)
3.  Options are "greyed out" - no method provided to change
  
Actual results:
Options are "greyed out" - no method provided to change

Expected results:
Some method to enter root or administrative mode to modify settings

Additional info:
KDE3 has a problem with administrative mode, but at does have a method
to enter.  https://bugzilla.redhat.com/show_bug.cgi?id=434624
Comment 1 Lukáš Tinkl 2008-02-28 09:32:39 EST
Known problem but it hasn't been addressed yet at upstream - see 
http://techbase.kde.org/index.php?title=Projects/SystemSettings for details. 

Long story:
the module embedding and inter-process communication needed to achieve this 
was done using old QXembed classes and DCOP, both of them were simply thrown 
away when porting to KDE 4 with no replacement as of today.

I'll update the status here as soon as I know more about upstream plans.
Comment 2 Kevin Kofler 2008-02-28 09:49:58 EST
So what do we do? Add a menu entry to launch all of systemsettings under kdesu 
(or consolehelper or whatever)?
Comment 3 Lukáš Tinkl 2008-02-28 10:14:45 EST
Created attachment 296221 [details]
Preliminary support for root privs in systemsettings
Comment 4 Lukáš Tinkl 2008-02-28 10:15:32 EST
Created attachment 296222 [details]
Fixed clock (date/time) kcm .desktop file
Comment 5 Ngo Than 2008-03-28 09:00:49 EDT
*** Bug 439378 has been marked as a duplicate of this bug. ***
Comment 6 Rex Dieter 2008-04-16 07:56:57 EDT
%changelog
* Tue Apr 15 2008 Lukáš Tinkl <ltinkl@redhat.com> - 4.0.3-15
- workaround #434824: KDE4 System Settings - No Method To Enter Administrative Mode
...

Note You need to log in before you can comment on or make changes to this bug.