Bug 466156 - F10 System Lockup after applying Xorg Updates ATI Xpress 200M rs485
F10 System Lockup after applying Xorg Updates ATI Xpress 200M rs485
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-08 15:04 EDT by Gerald Cox
Modified: 2018-04-11 11:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-22 20:54:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg Log when failure occurs (69.42 KB, text/plain)
2008-10-08 15:05 EDT, Gerald Cox
no flags Details
xorg configuration file when failure occurs (874 bytes, text/plain)
2008-10-08 15:06 EDT, Gerald Cox
no flags Details
Xorg.0.log (84.66 KB, text/x-log)
2008-10-20 20:40 EDT, Gerald Cox
no flags Details
results of dmesg (28.67 KB, application/octet-stream)
2008-10-20 20:41 EDT, Gerald Cox
no flags Details

  None (edit)
Description Gerald Cox 2008-10-08 15:04:34 EDT
Description of problem:  System lockup occurs after application of xorg updates:

xorg-x11-server-Xorg-1.5.1-10
xorg-x11-server-common-1.5.1-10
xorg-x11-drv-ati-6.9.0-21

This was occurring previously and adding the "AllowEmptyInput" allowed a workaround, but that doesn't seem to be helping now.  The only way I am able to access the system is to boot in single-user mode.


Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-1.5.1-10
xorg-x11-server-common-1.5.1-10
xorg-x11-drv-ati-6.9.0-21

How reproducible:
System locks after login during an X session.  Same result whether I use GNOME or KDE.

Steps to Reproduce:
1.  Boot system normally
2.  Login using X
3.  
  
Actual results:
System locks up

Expected results:
Normal operation

Additional info:
Comment 1 Gerald Cox 2008-10-08 15:05:32 EDT
Created attachment 319781 [details]
Xorg Log when failure occurs
Comment 2 Gerald Cox 2008-10-08 15:06:11 EDT
Created attachment 319782 [details]
xorg configuration file when failure occurs
Comment 3 Matěj Cepl 2008-10-08 18:09:11 EDT
Does putting nomodeset on the kernel command line help?
Comment 4 Gerald Cox 2008-10-08 18:21:44 EDT
No, unfortunately not.  I am currently using nomodeset since I have a ATI R200.  If I do not specify the screen resolution is too large.  Before the latest updates I was encountering the issue I reported in:  464921 which was distortion on the right side of the screen.  With the latest updates I cannot use X at all, with or without the "nomodeset" parameter.
Comment 5 Matěj Cepl 2008-10-09 04:10:37 EDT
OK, just a workaround -- would switching to vesa help (via edit of xorg.conf or system-config-display).
Comment 6 Gerald Cox 2008-10-09 10:32:01 EDT
No, changed to vesa and still have the same issue.  System locks up a few moments after login.
Comment 7 Matěj Cepl 2008-10-09 12:22:56 EDT
Shut, vesa should really work.
Comment 8 Dave Airlie 2008-10-09 17:14:15 EDT
This isn't an r200 at all its an Xpress 200M rs485.

i.e. its the worst piece of crap ATI ever produced.

but we should try and get you running again.

In theory modesetting should work fine on that chip.

I'm going to rebase kernel/ati today so we'll see if they help the problem at all.
Comment 9 Gerald Cox 2008-10-10 11:26:17 EDT
Applied:

xorg-x11-drv-ati-6.9.0-25
kernel-2.6.27-0.398.rc9.fc10

Same issue, no improvement whether I have vesa or radeon specified in xorg.conf
Comment 10 Gerald Cox 2008-10-20 20:39:46 EDT
Applied:

xorg-x11-drv-ati-6.9.0-28.fc10.x86_64
kernel-2.6.27.3-27.rc1.fc10.x86_64
xorg-x11-server-Xorg-1.5.2-7.fc10.x86_64
xorg-x11-common-1.5.2-7.fc10.x86_64

Looks like booting without "nomodeset" parameter correctly identifies proper screen size, resolution... however, still getting lockup a few moments afer starting kde or gnome.  Same result whether or not I use nomodeset or vesa in place of radeon.  I've attached latest xorg.0.log and dmesg.  Let me know if there is any additional information I can provide to assist in getting this resolved.  Thank you.
Comment 11 Gerald Cox 2008-10-20 20:40:47 EDT
Created attachment 320950 [details]
Xorg.0.log
Comment 12 Gerald Cox 2008-10-20 20:41:17 EDT
Created attachment 320951 [details]
results of dmesg
Comment 13 Gerald Cox 2008-10-21 00:56:34 EDT
Found an issue with yum where errors were being received with PackageKit, appears some type of corruption was occuring.  Manually deleted the packages and reinstalled.  Now X session no longer locking, however receiving large text much the same as reported in:   Bug 435216 -  F9 - ATI Driver - Text too large.
Comment 14 Gerald Cox 2008-10-21 01:06:42 EDT
Workaround:

As per Bug 435216:

Add statement to Section "Monitor"
--->  DisplaySize 289 210

Add statement to Section "Device"
--->  Option "Monitor-LVDS" "Monitor0"

Please advise when further testing can be done so I can remove the workaround and validate.

Thanks!
Comment 15 Gerald Cox 2008-10-21 23:27:44 EDT
Lockup problem still occurring, just not immediately after login.  Please advise type of information which may be helpful to collect.
Comment 16 Gerald Cox 2008-10-21 23:43:06 EDT
Opened bug:   Bug 467983 -  F10 - ATI Driver - Text too large
to track large text problem.  This bug will remain for lockup issue.
Comment 17 Matěj Cepl 2008-10-22 19:06:42 EDT

*** This bug has been marked as a duplicate of bug 435216 ***
Comment 18 Gerald Cox 2008-10-22 20:10:03 EDT
Incorrectly closed.  This is not a duplicate of 435216.  This bug is related to a lockup situation which I am currently testing.  435216 was opened by me for a large text issue related to the F9 beta.  I've opened up another bug for the F10 beta to track this issue which is currently occurring.
Comment 19 Gerald Cox 2008-10-22 20:54:15 EDT
Appears lockup issue resolved with updates applied in comment 10, with further issues being resolved by manual circumvention of issue regarding packagekit referenced in comment 13.  Closing.

Note You need to log in before you can comment on or make changes to this bug.