Bug 435412 - Add virt-manager to transifex
Add virt-manager to transifex
Status: CLOSED WONTFIX
Product: Fedora Localization
Classification: Fedora
Component: Website (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Dimitris Glezos
A S Alam
:
Depends On: 467808 467810
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-29 00:48 EST by Francesco Tombolini
Modified: 2013-07-02 20:48 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-13 00:06:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Francesco Tombolini 2008-02-29 00:48:27 EST
Description of problem:

It would be useful to send translation to virt-manager using transifex.

Module name: virt-manager

VCS: Mercurial (hg.et.redhat.com)
branch: tip
Comment 1 Dimitris Glezos 2008-02-29 06:08:27 EST
Francesco thanks for bringing this up. The steps needed to be taken are
documented at http://fedoraproject.org/wiki/L10N/FAQ#add-transifex.

We need the maintainer's permission for this (CCing berrange).

Also, we'll need a contact point for an admin to create a VCS user on
hg.et.redhat.com for Transifex (CCing mmcgrath).
Comment 2 Piotr Drąg 2008-02-29 18:00:10 EST
Shouldn't virt-inst also be added to Transifex?
Comment 3 Daniel Berrange 2008-03-04 10:00:32 EST
We are not able to allow transiflex direct commit access to hg.et.redhat.com
because the firewall does not allow SSH traffic from the place where Transiflex
is running. 

The best that we can do is allow Transiflex read-only repository access so that
it can obtain the up to date .pot and .po files. We would then have to
periodically pull Transiflex data into the SCM repo ourselves.

And yes, virtinst needs to be managed the same way as virt-manager
Comment 4 Dimitris Glezos 2008-03-04 14:30:03 EST
Roger that. Currently we only support pushes, however the feature "Manually pull
from Tx periodically, instead of having it automatically push" is indeed a
popular one (yum wants it too, among others). Since this involves some serious
thinking and engineering work (auto merging, or, or...), its implementation
might take some time.

Until then, the simplest solution would be for your group to have a public hg
repo created at fedorahosted which Tx can write to, and use that to pull from
and Tx to push to. A second one would be to add support to just email the
submissions somewhere.
Comment 5 Ankit Patel 2008-10-07 03:09:54 EDT
Is there any progress on this bug, so far?

Fedora 10 translation submission due date is 21st October...
Comment 6 Noriko Mizumoto 2008-10-20 02:39:34 EDT
Hello Daniel

It is Software Translation Deadline tomorrow, 12-Oct.

Translators would like to pass their translated PO files of virt-*, and move on other translations such as documentation.
How would you like to receive them?

I can open new bugs for file submission against virt-manager, virt-df, virt-mem and virt-top components respectively. Others such as virt-ctrl, virt-inst and virt-p2v have not appeared in the component section, so those can be attached here.

Or can you specify the bug to attach or any alternate way?

Thanks
Comment 7 Piotr Drąg 2008-10-20 16:57:54 EDT
(In reply to comment #6)
> I can open new bugs for file submission against virt-manager, virt-df, virt-mem
> and virt-top components respectively. Others such as virt-ctrl, virt-inst and
> virt-p2v have not appeared in the component section, so those can be attached
> here.
> 

virt-inst package name is python-virtinst. Also I believe virt-p2v is a kind of Live CD, so it won't appear in Bugzilla.
Comment 8 Noriko Mizumoto 2008-10-20 20:46:29 EDT
Thanks Piotr!

Any translated files for virt-ctrl and virt-p2v will be attached here.
Rest I am creating new bugs.
Comment 9 Piotr Drąg 2009-06-13 00:06:12 EDT
Since there is no chance to add virt tools to Transifex, and we still have to do everything by hand, I'm closing this report.
Comment 10 Piotr Drąg 2009-06-13 00:06:32 EDT
Since there is no chance to add virt tools to Transifex, and we still have to do everything by hand, I'm closing this report.
Comment 11 Mike McGrath 2009-06-13 02:39:00 EDT
Have you guys considered developing virt-manager in a more community friendly / open way?  fedorahosted.org immediately comes to mind and supports transifex.  Just 2 cents.
Comment 12 Piotr Drąg 2009-07-03 16:07:32 EDT
Mass change of component from Transifex to Website, since all our websites are handled by Transifex now.

Note You need to log in before you can comment on or make changes to this bug.