Bug 435591 - RT2500 wireless - kernel 2.6.24.3-13.fc8 - scans, but cannot find networks
RT2500 wireless - kernel 2.6.24.3-13.fc8 - scans, but cannot find networks
Status: CLOSED DUPLICATE of bug 430038
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-02 03:42 EST by Ivan Virgili
Modified: 2008-03-05 14:44 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-05 14:44:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Virgili 2008-03-02 03:42:40 EST
Description of problem:
I updated from kernel 2.6.23.15-137.fc8 to kernel 2.6.24.3-13.fc8

The new kernels seem to be solving the problem I filed on bugzilla:
https://bugzilla.redhat.com/show_bug.cgi?id=427456

The link led flashes during scanning and, I presume, it would probably flash
during transmission.

Unfortunately the device does not manage to detect any wireless networks (even
if wireless router is less than 50cm from it).

If I start my computer selecting kernel 2.6.23.15-137.fc8, then the wireless
works, but I have the usual problem that the link led does not flash.

Let me know if you need more info.

Version-Release number of selected component (if applicable):
2.6.24.3-13.fc8
Comment 1 John W. Linville 2008-03-04 14:19:18 EST
Are you perhaps looking for a .11a access point?  If so, there is a patch in 
2.6.24.3-15.fc8 that might be helpful.  Otherwise, hopefully Ivo has some 
insight. :-)
Comment 2 Ivan Virgili 2008-03-04 15:22:24 EST
I have just installed 2.6.24.3-17.fc8
No luck !!! Link led works, but no network detected, therefore no connection.

My router is a 3Com 3CRWDR100A-72

I can confirm again that if I start my computer selecting kernel
2.6.23.15-137.fc8, then the wireless works, but I have the usual problem with
the link led not flashing. 
Comment 3 Ivan Virgili 2008-03-05 13:45:15 EST
kernel - 2.6.24.3-18.fc8.i686 and still no luck.

The card is a Gigabyte GN-WMKG

I have noticed that sometimes, with the new kernels, it does start.
I get the following errors:

Mar  5 18:30:35 localhost kernel: rt2x00pci -> rt2x00pci_alloc_reg: Error -
Failed to allocate registers.
Mar  5 18:29:26 localhost kernel: ACPI: PCI interrupt for device 0000:02:00.0
disabled
Mar  5 18:29:26 localhost kernel: rt2500pci: probe of 0000:02:00.0 failed with
error -12

I do not have such a problem with kernel 2.6.23.15-137.fc8
Comment 4 Ivan Virgili 2008-03-05 13:46:13 EST
Sorry I meant "it is not loaded"
Comment 5 John W. Linville 2008-03-05 14:44:17 EST

*** This bug has been marked as a duplicate of 430038 ***

Note You need to log in before you can comment on or make changes to this bug.