Bug 430038 - RT2500 doesn't scan
RT2500 doesn't scan
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
: 435591 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-24 02:24 EST by Chris Spencer
Modified: 2008-07-27 15:07 EDT (History)
7 users (show)

See Also:
Fixed In Version: 2.6.24.3-50.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-27 17:22:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of /var/log/message right after running ifconfig/iwlist (636.27 KB, text/plain)
2008-02-06 07:19 EST, Chris Spencer
no flags Details
Output of lspci -n. (741 bytes, text/plain)
2008-02-06 07:20 EST, Chris Spencer
no flags Details

  None (edit)
Description Chris Spencer 2008-01-24 02:24:25 EST
Description of problem:
Unable to start or use the wlan0 interface for a alink RT2500 802.11g mini-PCI
card. When starting the interface from system-config-network or "ifup wlan0",
all I get is:

 Determining IP information for wlan0...Firewall started
  failed.

How reproducible:
Every time.

Steps to Reproduce:
1. ifup wlan0
  
Actual results:
Interface fails to start.

Expected results:
Interface should start.

Additional info:
I've set the device to "managed" mode, and have the correct kernel modules
loaded (rt2500pci, rt2x00pci, rt2x00lib).

The setroubleshoot panel icon usually appears when I try to start the interface,
with the message, "SELinux is preventing touch (dhcpc_t) "write" to
(var_lock_t)." It also mentions "You can attempt to fix file context by
executing restorecon -v", but I'm still unable to bring up the interface after
running this command. I can't bring up the interface in either I currently have
SELinux set to Permissive mode enforcing or permissive mode, but I get that
SELinux warning/error nearly every time I try to start the interface.

$ uname -r
2.6.23.9-85.fc8

$ lspci | grep RaLink
03:02.0 Network controller: RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)

$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:11:09:C6:9E:CC  
          inet addr:68.82.253.159  Bcast:255.255.255.255  Mask:255.255.254.0
          inet6 addr: fe80::211:9ff:fec6:9ecc/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:585647 errors:0 dropped:0 overruns:0 frame:0
          TX packets:136276 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:430888130 (410.9 MiB)  TX bytes:8474299 (8.0 MiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4641 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4641 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:2613681 (2.4 MiB)  TX bytes:2613681 (2.4 MiB)

wlan0     Link encap:Ethernet  HWaddr 00:11:09:9C:0C:F9  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

wmaster0  Link encap:UNSPEC  HWaddr
00-11-09-9C-0C-F9-78-20-00-00-00-00-00-00-00-00  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

$ iwconfig
lo        no wireless extensions.

eth1      no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11g  ESSID:""  
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Tx-Power=27 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Comment 1 Dan Williams 2008-01-24 07:56:24 EST
What results do you get for manually configuring the adapter?  Something like:

ifconfig wlan0 up
iwconfig wlan0 essid <your essid> key <you wep key>

Keep running 'iwconfig' until the "Access Point:" field shows the MAC address of
your AP.  If it doesn't, try the iwconfig command again.

Then, after the card is connected:

dhclient -1 wlan0

Can you post the output here (hide your key if you like)?
Comment 2 Chris Spencer 2008-01-24 18:00:36 EST
I don't have an access point. That's why I'd like to bring up the interface, so
I can scan for nearby APs while roaming.

# ifconfig wlan0 up
# iwconfig wlan0 essid any
# dhclient -1 wlan0
Internet Systems Consortium DHCP Client V3.0.6-Fedora
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/
wmaster0: unknown hardware address type 801
Firewall started
wmaster0: unknown hardware address type 801
Listening on LPF/wlan0/00:11:09:9c:0c:f9
Sending on   LPF/wlan0/00:11:09:9c:0c:f9
Sending on   Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 18
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
No DHCPOFFERS received.
Unable to obtain a lease on first try.  Exiting.
Comment 3 Dan Williams 2008-01-24 18:21:57 EST
Bringing up the interface for manual scanning is just:

/sbin/ifconfig wlan0 up

After that, you can scan with:

/sbin/iwlist wlan0 scan

And when you have found the AP you wish to connect to, then you do the whole
iwconfig/dhclient dance.  The driver doesn't do any searching for APs,
connecting, and running DHCP.  That's what tools like NetworkManager do.

When you run ifup, you need to have configured an access point to connect to.
Comment 4 Chris Spencer 2008-01-24 19:18:52 EST
I know that. However, I don't get any results:

# /sbin/ifconfig wlan0 up
# /sbin/iwlist wlan0 scan
wlan0     No scan results

I have a second machine that detects 8 networks.
Comment 5 Dan Williams 2008-01-24 20:59:41 EST
If you don't ever get any results, then it's a driver issue.  Reassigning to
kernel.  Do you _ever_ get results?  What happens if you issue multiple scan
requests about  10 seconds apart?
Comment 6 Dan Williams 2008-01-24 21:01:00 EST
Also, what kernel version do you have?
Comment 7 Chris Spencer 2008-01-24 21:18:07 EST
I get no results, regardless of the quantity or frequency of times I run those
commands.

$ uname -r
2.6.23.9-85.fc8
Comment 8 John W. Linville 2008-01-25 09:23:50 EST
It looks like -107.fc8 is available in the updates repository now.  Please 
give that a try -- some important fixes for rt2x00 were added between -84.fc8 
and -107.fc8.

Can you recreate the issue with the newer kernel?
Comment 9 Chris Spencer 2008-01-26 14:22:26 EST
# uname -r
2.6.23.14-107.fc8
# ifconfig wlan0 up
# iwlist wlan0 scan
wlan0     No scan results
Comment 10 John W. Linville 2008-01-30 10:45:09 EST
Please attach the contents of /var/log/messages as well as th eoutput 
of 'lspci -n'...thanks!
Comment 11 Chris Spencer 2008-02-06 07:19:30 EST
Created attachment 294099 [details]
Output of /var/log/message right after running ifconfig/iwlist
Comment 12 Chris Spencer 2008-02-06 07:20:11 EST
Created attachment 294100 [details]
Output of lspci -n.
Comment 13 John W. Linville 2008-03-05 14:44:19 EST
*** Bug 435591 has been marked as a duplicate of this bug. ***
Comment 14 John W. Linville 2008-03-13 11:12:00 EDT
The kernels here contain an update to rt2x00 version 2.1.4:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=42735

Could you give those kernels a try to see if they resolve this issue for you?
Comment 15 Ivan Virgili 2008-03-13 15:57:49 EDT
Installed kernel 2.6.24.3-34.fc8
Card scanned and connected, but then stopped working.

Mar 13 19:53:45 localhost kernel: phy5 -> rt2500pci_bbp_read: Error - BBPCSR
register busy. Read failed.
Mar 13 19:53:45 localhost kernel: phy5 -> rt2500pci_bbp_write: Error - BBPCSR
register busy. Write failed.
Mar 13 19:53:45 localhost kernel:last message repeated 40 times
Mar 13 19:53:45 localhost kernel: phy5 -> rt2500pci_rf_write: Error - RFCSR
register busy. Write failed.
Mar 13 19:53:45 localhost kernel:last message repeated 7 times
Mar 13 19:53:45 localhost kernel: phy5 -> rt2500pci_bbp_write: Error - BBPCSR
register busy. Write failed.
Mar 13 19:53:45 localhost kernel: phy5 -> rt2500pci_rf_write: Error - RFCSR
register busy. Write failed.
Mar 13 19:53:45 localhost kernel: phy5 -> rt2500pci_rf_write: Error - RFCSR
register busy. Write failed.
Mar 13 19:53:45 localhost kernel: phy5 -> rt2500pci_bbp_write: Error - BBPCSR
register busy. Write failed.
Mar 13 19:53:45 localhost kernel: phy5 -> rt2500pci_bbp_write: Error - BBPCSR
register busy. Write failed.
Mar 13 19:53:45 localhost kernel: ADDRCONF(NETDEV_UP): wlan1: link is not ready
Mar 13 19:53:45 localhost NetworkManager: <info>  Deactivating device wlan1.
Mar 13 19:53:45 localhost NetworkManager: <WARN> 
nm_device_802_11_wireless_disable_encryption(): error setting key for device
wlan1: No such file or directory
Mar 13 19:53:45 localhost NetworkManager: <info>  (wlan1): exported as
/org/freedesktop/Hal/devices/net_00_0f_ea_61_78_42_0
Mar 13 19:53:45 localhost kernel: phy5 -> rt2500pci_rf_write: Error - RFCSR
register busy. Write failed.
Mar 13 19:53:45 localhost kernel:last message repeated 7 times
Mar 13 19:53:45 localhost kernel: phy5 -> rt2500pci_bbp_write: Error - BBPCSR
register busy. Write failed.
Mar 13 19:53:45 localhost kernel: phy5 -> rt2500pci_rf_write: Error - RFCSR
register busy. Write failed.
Mar 13 19:53:45 localhost kernel: phy5 -> rt2500pci_rf_write: Error - RFCSR
register busy. Write failed.
Mar 13 19:53:45 localhost kernel: phy5 -> rt2500pci_bbp_write: Error - BBPCSR
register busy. Write failed.
Mar 13 19:53:45 localhost kernel: phy5 -> rt2500pci_bbp_write: Error - BBPCSR
register busy. Write failed.
Mar 13 19:53:46 localhost NetworkManager: <info>  (eth0) supplicant interface is
now in state 2 (from 1).
Mar 13 19:53:46 localhost kernel: phy5 -> rt2500pci_rf_write: Error - RFCSR
register busy. Write failed.
Mar 13 19:53:46 localhost kernel:last message repeated 7 times
Mar 13 19:53:46 localhost kernel: phy5 -> rt2500pci_bbp_write: Error - BBPCSR
register busy. Write failed.
Mar 13 19:53:46 localhost kernel: phy5 -> rt2500pci_rf_write: Error - RFCSR
register busy. Write failed.
Mar 13 19:53:46 localhost kernel: phy5 -> rt2500pci_rf_write: Error - RFCSR
register busy. Write failed.
Mar 13 19:53:46 localhost kernel: phy5 -> rt2500pci_bbp_write: Error - BBPCSR
register busy. Write failed.
Mar 13 19:53:46 localhost kernel: phy5 -> rt2500pci_bbp_write: Error - BBPCSR
register busy. Write failed.
Mar 13 19:53:46 localhost NetworkManager: <info>  (wlan1) supplicant interface
is now in state 2 (from 1).
Mar 13 19:53:46 localhost kernel: phy5 -> rt2500pci_rf_write: Error - RFCSR
register busy. Write failed.

Still having two problems, but I will file two bug reports for those.
{error when you start your computer or insert the card}
{power LED off}
Comment 16 Ivan Virgili 2008-03-14 05:16:18 EDT
I can confirm that computer starts OK, card scans and connnects, but after one
minute or so it stops working (kernel 2.6.24.3-34.fc8).
I either get the error messages in comment #15 or most of the time the computer
then freezes.
Comment 17 John W. Linville 2008-03-14 09:35:30 EDT
Ivan, given bug 437392 (and bug 436603), I have to view comment 15 and comment 
16 with a wary eye.  Is anyone else experience problems like those?
Comment 18 Ivan Virgili 2008-03-14 14:50:52 EDT
John, it might even be a bad card.
At same time though if I start my computer using kernel 2.6.23.14-115.fc8,
sometimes I still get the error message on bug 437392, but if the card
loads fine, then it works fine as well (it does not stop working after a minute
or so). Unfortunately I do not have another card with that chipset to do other
tests.
Comment 19 Ivan Virgili 2008-03-17 15:38:31 EDT
I am having my card replaced.
As soon as I get the new one I will be able to check if the problem was with the
card or not.
Comment 20 Ivan Virgili 2008-03-27 14:36:30 EDT
I got my new card and everything seems to work fine.
Kernel 2.6.24.3-50.fc8
Comment 21 FedoraUser9000 2008-07-27 15:07:05 EDT
I have been experiencing a bug that seems very similar to the one described in
this report.  I am using FC8, but the same thing seemed to occur with FC9 (for
the brief time that I had it installed).

The computer is a Dell Dimension 2350.  It has a Linksys WMP54G Wireless-G PCI
Adapter.  It uses the rt61 driver.  The wireless works perfectly with Windows.

Although I had some problems with NetworkManager, I could get things working
fine in kernel 2.6.23.1-42 by using a manual startup.  (This is the kernel that
comes with the original FC8, before updates, BTW.)

On upgrading the kernel to 2.6.25.10-47 the wireless no longer works.  It does
not work on any of the later updated kernels (up to 2.6.25.9-4) that I have tried.

Here is what I am doing to connect:

sudo /sbin/ifconfig eth0 down
sudo /sbin/ifconfig wlan0 down
sudo /sbin/dhclient -r wlan0

sudo /sbin/iwconfig wlan0 mode managed
sudo /sbin/iwconfig wlan0 essid "LinksysNumber9"
sudo /sbin/iwconfig wlan0 rate 54M
sudo /sbin/iwconfig wlan0 channel 5
sudo /sbin/iwconfig wlan0 key on

sudo /usr/sbin/wpa_supplicant -B -w -Dwext -iwlan0 -c/etc/wpa_supplicant.conf

sudo /sbin/ifconfig wlan0 up
sudo /sbin/iwconfig wlan0 mode managed  # may be redundant
sudo /sbin/dhclient wlan0

When it fails the DHCPDISCOVER never gets an offer and times out, because the
wpa_supplicant never manages to connect.  This is confirmed by running
wpa_supplicant in debug mode.  When it does work (with the earlier kernel) it
quickly gets an offer and links up.

There is another bug, which I mention only because it may be related.  When
using that early kernel that works with wireless, the wvdial program works fine
and recognizes the modem and sets it up.  With the later kernels wvdial fails to
even detect a modem.  Since these are both network-related and fail for the same
kernels I wonder if they are related.

The wpa_supplicant.conf file that I am using, after trying a few different
configurations, looks like this:

ctrl_interface=/var/run/wpa_supplicant
ap_scan=1
fast_reauth=1

network={
   ssid="LinksysNumber9"
   scan_ssid=1
   proto=WPA
   key_mgmt=WPA-PSK
   pairwise=TKIP
   psk="secretkey"
}

So for now I can still use the old kernel (and I no longer use dialup) but I
would like to be able to start using the newer kernels at some point...


Note You need to log in before you can comment on or make changes to this bug.