Bug 436661 - x server crashes and crashes system after latest update
x server crashes and crashes system after latest update
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Depends On:
  Show dependency treegraph
Reported: 2008-03-08 16:27 EST by Ray Todd Stevens
Modified: 2008-06-11 18:08 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2008-06-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-06-11 18:08:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
log from failed sessions (5.13 KB, text/plain)
2008-03-08 16:27 EST, Ray Todd Stevens
no flags Details
this is how the update left the file (572 bytes, text/plain)
2008-03-08 16:30 EST, Ray Todd Stevens
no flags Details
I tried this file from a working machine using the same model of montor and keyboard. (766 bytes, text/plain)
2008-03-08 16:31 EST, Ray Todd Stevens
no flags Details
latest log (15.03 KB, text/plain)
2008-03-11 18:32 EDT, Ray Todd Stevens
no flags Details
my latest log (15.03 KB, text/plain)
2008-03-13 11:41 EDT, Ray Todd Stevens
no flags Details

  None (edit)
Description Ray Todd Stevens 2008-03-08 16:27:36 EST
I did a yum update on a system I am running fc9 alpha1 on.   Before the update
everything in this area was working fine.   Now when I boot I get to the x
windows stuff where it is supposed to bring up the xwindows login page.  
Instead I get a full system hang crash.  Everything stops.

This may be related to open bug 393061 as this particular machine was one of the
machines that experienced this problem.

I also see bugs 436636 and436585 which sound related, but not the same thing.
Comment 1 Ray Todd Stevens 2008-03-08 16:27:36 EST
Created attachment 297326 [details]
log from failed sessions
Comment 2 Ray Todd Stevens 2008-03-08 16:30:14 EST
Created attachment 297327 [details]
this is how the update left the file
Comment 3 Ray Todd Stevens 2008-03-08 16:31:25 EST
Created attachment 297329 [details]
I tried this file from a working machine using the same model of montor and keyboard.

This didn't work either
Comment 4 Ray Todd Stevens 2008-03-10 17:34:31 EDT
I noticed that the file I used from a working machine used a different graphics
card so I tried the section from the graphics card with no luck.

Any ideas on what I could try next.

Is anyone else experiencing this problem?

Comment 5 Ray Todd Stevens 2008-03-10 17:44:55 EDT
OK I think I am barking up the wrong tree on this being a xorg.conf problem.   I
tried system-config-display and it said it was trying a fresh config, but still
no joy.   It failed.

Comment 6 Ray Todd Stevens 2008-03-10 17:55:52 EDT
The more I play with this the more it seems like bug 436585.

I do have a i810 controler.
Comment 7 Matěj Cepl 2008-03-11 17:26:28 EDT
It looks like, but it isn't -- you have incomplete /var/log/Xorg.0.log, they
have crash with a backtrace in the log. Or am I missing something?

Moreover, why do you have ati driver set up, when you have i810? That doesn't
feel right.

Try to move /etc/X11/xorg.conf somewhere out of the way and restart X. What
happens? If it is something interesting, please, attach /var/log/Xorg.0.log from
that attempt as well.

Also, try to upgrade from koji -- xorg-x11-server-Xorg, and xorg-x11-drv-i810
plus whatever will be required by those fails. There is encridble amount of
patches, fixes etc. going to those packages every day, so things are changing
really rapidly. And again, let us know how it went.
Comment 8 Ray Todd Stevens 2008-03-11 18:28:30 EDT
I won't be able to do any real testing until tommorow when I am on site.

Did try to do the move xorg.conf to a new temp name thing with kind of similar
results.   Didn't check the log, but got the same error messages.

Caught the ati thing after I uploaded the file.   The file as recreated by the
automated system during the update is the "how the update left the file".  
After I noticed the different video card I did try a manual edit and replaced
the device section with the 

Section "Device"
	Identifier  "Videocard0"
	Driver      "intel"

section from the file as update left it.   Same result.

I also tried a version of the file for this machine from before the upgrade to
fc9 (from fc8).   Same result.   That file mentioned the i810 so that is why I
guessed that these might be the same.

I will try some debugging form here. and try and send you more results.

Comment 9 Ray Todd Stevens 2008-03-11 18:29:37 EDT
OK I tried to do the debugging.   Moved the xorg.conf file to a new name.   Here
is what I get when I try startx

[root@charon X11]# startx
xauth:  creating new authority file /root/.serverauth.24835

X.Org X Server (1.5.0 RC 1)
Release Date: 5 September 2007
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.18-53.1.6.el5xen i686 
Current Operating System: Linux charon 2.6.25-0.101.rc4.git3.fc9 #1 SMP Sat Mar
8 15:56:03 EST 2008 i686
Build Date: 07 March 2008  01:57:57PM
Build ID: xorg-x11-server 
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.

Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Mar 11 18:25:53 2008
(EE) Unable to locate/open config file
New driver is "intel"
(==) Using default built-in configuration (30 lines)
(EE) open /dev/fb0: No such file or directory
(EE) intel(0): Output VGA enabled but has no modes
(EE) intel(0): No valid modes.
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
giving up.
xinit:  Connection refused (errno 111):  unable to connect to X server
xinit:  No such process (errno 3):  Server error.

Which is the same thing I get all along.

Comment 10 Ray Todd Stevens 2008-03-11 18:32:50 EDT
Created attachment 297680 [details]
latest log

here is my latest log.	 Still no joy.
Comment 11 Ray Todd Stevens 2008-03-11 21:23:13 EDT
I will point out that this is also one of the machines for which I reported bug
Comment 12 Ray Todd Stevens 2008-03-13 11:35:17 EDT
I do wonder about the identification of this with the ati driver?

The use of the ati driver at one point here is my error because I transfered a
working file and forgot that while the same monitor and keyboard were in use,
that the video card was not the same.   The automated install and load processes
identify this card as an intel or an i810.   So if anything I would assume this
should be transfered to that group?

Comment 13 Ray Todd Stevens 2008-03-13 11:41:23 EDT
Created attachment 297946 [details]
my latest log

OK I have been unable to do an update for the last couple of days because of
mirror errors on all of the mirrors.   Hopefully this will fix itself sometime

In the mean time here is the latest log file from deleting the xorg.conf file
and then doing startx.
Comment 14 Ray Todd Stevens 2008-03-13 17:08:47 EDT
OK I have this working.   But it did take some work.   This is another issue
that might need to be in a "hints file" of some kind.

If you still have the xorg.conf file as created by the previous update active
you are going to get nowhere fast.   Same really annoying exit/hang.

If you delete the file and reboot after the update to the current stuff you will
in even bigger trouble.   In ended up having the run fsck three times to get a
working volume.   But I am a persistent and rather annoying dude at times.   So
I did a couple of reinstalls from a ghost.   

If you get this error set you need to delete the xorg.conf file.  yum update,
and  Then, and this, is really important and the key you will have to power
cycle the machine to get a clean system running.  But you do this and you will
be back up and running.
Comment 15 Ray Todd Stevens 2008-03-14 10:48:16 EDT
Additional testing run.   (ghost type programs don't make this hard)

Here is the deal.   If you try to do startx with the old drivers in place from
the command line, then it just exits with the above error.  (If you try a
inittab defaulted to 5 you get a hard hang.) 

If you then upgrade the drivers, and run startx again you get this hard hang.  
 If the drive volumes are "dirty" because they in the middle of changing,  (I
found out another process had started in back ground playing with copying files
around) this messes up the drive volume.

So probably everyone experiencing currently this error needs to know to reboot
after doing the driver update.   As long as the driver in the release is the
modern one, it look like this is ready to close.
Comment 16 Bug Zapper 2008-05-14 01:52:51 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
Comment 17 Ray Todd Stevens 2008-05-20 18:35:54 EDT
From what I can tell this has actually been fixed.   At least if the new modules
are in the actual production release one would think there would be no problem.
  Doesn't this need to be closed.   Maybe some documentation changes are needed.
Comment 18 Ray Todd Stevens 2008-06-02 16:16:08 EDT
Played with this some more on production 9 and this problem at least has gone away.

Still have the problem with the saves, and also an issue with the fact that the
autoconfig setting doesn't seem to work for any of the monitors we have in shop.
Comment 19 Matěj Cepl 2008-06-09 01:25:11 EDT
So this bug can be closed as CURRENTRELEASE, right?
Comment 20 Ray Todd Stevens 2008-06-11 09:53:16 EDT
I would think that closing this one would be a great idea.

Note You need to log in before you can comment on or make changes to this bug.