Bug 436872 - RFE upgrade to graphviz-2.20.2
RFE upgrade to graphviz-2.20.2
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: graphviz (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jima
Fedora Extras Quality Assurance
http://www.graphviz.org/Download_sour...
: FutureFeature
: 427376 436868 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-10 16:42 EDT by John Ellson
Modified: 2011-01-06 16:16 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-06 16:16:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
suggested new spec file (18.22 KB, text/x-rpm-spec)
2008-03-11 15:57 EDT, John Ellson
no flags Details

  None (edit)
Description John Ellson 2008-03-10 16:42:10 EDT
Description of problem:
graphviz-2.18 is now available from:
  http://www.graphviz.org/pub/graphviz/ARCHIVE/graphviz-2.18.tar.gz
hopefully in time for fedora-9?

This release contains mainly bug fixes.   No API changes should affect other
apps.  All graphviz-2.16.1-0.4 patches have been incorporated.   The
graphviz.spec in the tar.gz has been changed (more concise handling of distro
variations), but should work as is.   You may want to disable relocatabilty, but
it doesn't do any harm.  The R binding is not complete, so you may want to
disable that.  Language bindings:  perl, python, tcl, ruby, php, now installed
in the preferred locations of each scripting language.

The perl binding even works with perl-5.10 (albeit with one warning message)
Try:  /usr/share/graphviz/demo/modgraph.pl

See ChangeLog for more details.


Version-Release number of selected component (if applicable):
graphviz-2.18

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 John Ellson 2008-03-10 16:43:42 EDT
*** Bug 436868 has been marked as a duplicate of this bug. ***
Comment 2 John Ellson 2008-03-10 16:48:32 EDT
*** Bug 427376 has been marked as a duplicate of this bug. ***
Comment 3 John Ellson 2008-03-11 15:57:13 EDT
Created attachment 297665 [details]
suggested new spec file

This spec file contains the significant changes from the distro's spec file,
but retains your changelog.    I've left relocatability enabled - seems
harmless to me - up to you.

Hope this helps
Comment 4 Charles R. Anderson 2008-04-11 13:02:06 EDT
We're being hit by graphviz bug #828, as well as one that relates to GIF which
would be bug #1333 (but that isn't showing up in their bug reporting system for
some reason).

http://graphviz.org/bugs/b828.html

Upstream has said to basically upgrade because the bug is fixed in 2.18.

> > Number: 1333
> > Title:       Label Exceeds node in GIF
> > Date:        Fri Apr 11 11:20:21 2008
> > Subsys:      Dot
> > Version:     2.12
> > System:      x86-Linux-Fedora 7
> > Severity:    major
> > Problem: When a large label is used for a node, the label will exceed the node
> boundary when exporting as GIF. This can be reproduced in all programs (Dot,
> Neato, twopi...etc).
> > Input:
> >  digraph g {
> >     "test" [shape=box,label="this is the very long label that causes
> problems"];
> > }
> > Comments: I'm writing nodes that represent computers on a network and the
> hostnames are being clipped, so this is not unrealistic.
> > Owner: *
> > Status: *
> I cannot reproduce this with the current stable release, graphviz-2.18.
> Please upgrade.    We have rpms for Fedora-7 at:   http://www.graphviz.org/
Comment 5 Jima 2008-04-11 16:17:02 EDT
Tsk.  This bug originally came in too late to give me time to slip it in before
the Beta freeze.  Now that there's a bad bug related to it, it seems to be after
the Development freeze.  I'll proceed on getting this ready, but I'm not sure
it'll ship with Fedora 9; it may have to be errata.  Dangit.
Comment 6 John Ellson 2008-04-11 17:16:14 EDT
Shipping 2.18 in F9 would be nice, but #4 is actually reporting a bug in FC7
against graphviz-2.12 with a suggested fix of upgrade to 2.18.

Is FC7 still supported?

I haven't double checked, but I'm fairly sure that
the bugs referred to in #4 are also fixed in 2.16, but 2.18 would still be the
better choice if possible.

BTW I believe he is referring to Graphviz bug #s:
    http://www.graphviz.org/bugs/b828.html  (probably related but different bug)
    http://www.graphviz.org/bugs/b1333.html (still not showing up)

An errata release is fine with me.   Anyone that really needs a fix can
pick up our rpms from www.graphviz.org
Comment 7 Jon Stanley 2008-04-23 16:29:20 EDT
Adding FutureFeature keyword to RFE's.
Comment 8 Aleksey Nogin 2008-07-17 12:53:40 EDT
The latest stable version is currently 2.20.2.

This, BTW, is also a problem with EPEL, which still has graphviz 2.12.
Comment 9 Tim Niemueller 2008-12-14 11:46:23 EST
The packages from the graphviz website also put the Lua library to the right place for easy inclusion so it seems to fix multiple issues.

Is there a specific reason why you do not want to do the update?
Comment 10 Tim Niemueller 2009-09-29 06:30:41 EDT
By now there is already Graphviz 2.24, an we are at 2.20 in Fedora. Additionally, there are quite a few patches in CVS. Have they been upstreamed?

Graphviz support is really lacking in Fedora, in this regard Fedora is not that "leading the advancement". Are there specific reasons (incompatibilities on deps, lots of deps on graphviz that need recompilation etc.), or is it "just" a lack of man power? In that case the devel list could be contacted if there are more people to share the work.
Comment 11 Patrick Laughton 2009-12-18 12:59:52 EST
2.26.0 is coming to rawhide shortly; I'm rolling in as many bugfixes as I can find/fix.

Historically graphviz has been a bit of a time sink for me, as I'm not a user of it and don't understand much of its functionality.  Coupling that with my limited Fedora time, and it's a bad, bad situation.  I'm quite aware I'm very remiss in dealing with this.

If anyone has any interest in taking over maintenance of this package, I'm listening.
Comment 12 Tim Niemueller 2010-02-11 06:00:44 EST
Would you mind updating F-12? I'm about to propose a package for inclusion that requires Graphviz 2.22 or later for some patches that I submitted. From what I have seen it's API and ABI compatible and there was no SONAME bump, so the upgrade should be safe. I'm using it from the Graphviz repository without problems.
Comment 13 Jaroslav Škarvada 2011-01-06 16:16:04 EST
Currently there is graphviz-2.26.0 in f13 and f14 and the latest stable graphviz-2.26.3 will be pushed soon into rawhide, thus closing.

Note You need to log in before you can comment on or make changes to this bug.