Bug 43720 - libXIE is required (by mozilla)
libXIE is required (by mozilla)
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 43964 44122 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-06 16:46 EDT by Vladimir Kondratiev
Modified: 2007-04-18 12:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-11 22:28:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Kondratiev 2001-06-06 16:46:02 EDT
Description of Problem:
In build 4.1.0,
XIE support was removed.
however, mozilla uses this library.

How Reproducible:
always

Steps to Reproduce:
1. install XFree86 4.1.0
2. run mozilla
3. 

Actual Results:
mozilla fails complaining about missing shared libraries.
it's components/libgfx_gtk.so
requires libXIE

Expected Results:


Additional Information:
I am not sure who needs to act. I filled this bug to Mozilla as well.
Comment 1 martin.macok 2001-06-07 09:01:56 EDT
Try to recompile Mozilla from sources.
I have no libXIE*.so on my system with 
XFree86-4.1.0-0.0.1
and when I tried to "rpm -i" my older build of Mozilla (built against X4.0.3) it
tolds it depends on libXIE and refuses to install.
So I downloaded Mozilla sources (src.rpm) from:
http://ftp.mozilla.org/pub/mozilla/nightly/latest-0.9.1/Red_Hat_7x_RPMS/
   (it's much faster and much more stable then M0.9 was)
and "rpm --rebuild" it and now it doesn't depend on libXIE and install/runs
smoothly here.
Comment 2 Mike A. Harris 2001-06-07 12:29:06 EDT
XIE is obsolete and is officially deprecated by the XFree86 team.  It has
been removed from the rawhide packages so we can determine what if anything
actually uses it.  Mozilla is the only app to turn up so far, and Chris
has told me that they will be removing XIE support in Mozilla apparently 
for the 0.9.1 release. Unfortunately, this means Mozilla will be unuseable
on rawhide XFree86 until it is rebuilt without needing XIE.  A workaround
for you is to rebuild X with BuildXIE set to 1 in the spec file.  This is
what I have done at home, just for personal use until Mozilla is fixed.

Thanks for pointing this out to us though.  If you notice any other apps
that are broken either at runtime or build time due to XIE being gone,
please let us know.
Comment 3 Mike A. Harris 2001-06-07 12:30:56 EDT
Looks like we had a mid-air collision in bugzilla there..  ;o)
Thanks for letting me know that Mozilla 0.9.1 is out.  I'll need to update
my Moz now.  ;o)  The last few builds have indeed gotten much faster for
sure.  Perhaps because it doesn't need XIE now?  LOL!
Comment 4 Mike A. Harris 2001-06-08 12:09:07 EDT
*** Bug 43964 has been marked as a duplicate of this bug. ***
Comment 5 Mike A. Harris 2001-06-11 22:06:27 EDT
*** Bug 44122 has been marked as a duplicate of this bug. ***
Comment 6 Mike A. Harris 2001-06-11 22:28:02 EDT
Update:  The XFree86 team has specifically deprecated XIE and PEX
extensions officially.  They have been removed from the default builds
of XFree86 now, as they are way obsolete and mostly unused nowadays.
This is the original reason for removing these extensions and libraries
from our XFree86 packages.  It reduces bloat.

At the time I made the decision to remove XIE/PEX from our official 
packages - I was pretty sure that there would be nothing out there
that was important that should be using them.  Unfortunately, I was
wrong.  As millions are pointing out - Mozilla is linked to XIE.  I
discovered this *myself* prior to any bugs being reported, and contacted
our Mozilla developer.  I was told that Mozilla should never have been
using XIE, and that the XIE code would be removed ASAP.  Thus I left XIE
disabled because Mozilla would soon be updated to not require XIE.

Mozilla 0.9.1 was supposed to not have XIE requirement, but ended up 
still requiring XIE after all.  This was probably my misunderstanding,
although I've been told that the XIE code will indeed be removed real
soon now.

To make life easy on everyone else out there, I have decided to re-enable
the XIE/PEX extensions in our builds, but deprecate them.  What this
means is that software using these extensions, etc. will continue to work,
however they will officially be removed from a future release of Red Hat
Linux.  Our next release will probably keep XIE and PEX, but future releases
after that will likely not have them.

I will be adding deprecation warnings to the XIE/PEX extensions and libraries
that will get echoed to the XFree86 logs when they are loaded.  This should
be adequate enough to warn anyone using/needing this stuff that it will
be removed in a future release, but keep binary compatibility across all
at least existing Red Hat Linux 7.x releases, plus possibly one future
release or so.

XIE (X Image Extension) is truely obsolete, having a codebase that is more
or less unmaintained or developed for 10 years I am told.  The same goes
for PEX.  PEX is a 3D environment for X Windows, which is totally obsoleted
by the existence of OpenGL.  Neither of these extensions/libraries will be
officially supported by XFree86.org any longer, and there is no sane
justification for us to support these obsolete codebases either.

So this is pretty much a BIG heads up to any developers out there, or users
using programs that need XIE/PEX to speak up now and let us know what
applications you may be using aside from Mozilla that rely on XIE/PEX.

Summary:  The reason for this deprecation is that the official XFree86.org
team that maintains the XFree86 codebase has officially obsoleted it.  We
are only following suit as there is no way we can support something that
the official development team cant/wont support.

In the mean time, my next build of XFree86 4.1.0 will have XIE/PEX enabled
again.
Comment 7 martin.macok 2001-06-20 11:17:35 EDT
JFYI:
The XIE and gdkpixbuf were removed from Mozilla trunk 2 days ago
http://bugzilla.mozilla.org/show_bug.cgi?id=83920
So it's pretty sure it will not be in 0.9.2.

If anybody wants some build now, use the one from
http://ftp.mozilla.org/pub/mozilla/nightly/latest/

Note You need to log in before you can comment on or make changes to this bug.