Bug 437426 - aborts on device add
aborts on device add
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 437408 437651 438325 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-13 20:50 EDT by Bill Nottingham
Modified: 2014-03-16 23:12 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-31 12:00:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2008-03-13 20:50:36 EDT
Description of problem:

Happens about 50% of the time. If I unload and reload the iwl3945 module (*@$#@&
driver), NM aborts when the device is reloaded.


Program received signal SIGABRT, Aborted.
0x000000379c232f75 in raise () from /lib64/libc.so.6
(gdb) bt
#0  0x000000379c232f75 in raise () from /lib64/libc.so.6
#1  0x000000379c234ae3 in abort () from /lib64/libc.so.6
#2  0x000000317da4119b in g_logv () from /lib64/libglib-2.0.so.0
#3  0x000000317da41233 in g_log () from /lib64/libglib-2.0.so.0
#4  0x00000000004219fb in nm_signal_handler (signo=-16843009) at
NetworkManager.c:123
#5  <signal handler called>
#6  0x000000379c232f75 in raise () from /lib64/libc.so.6
#7  0x000000379c234ae3 in abort () from /lib64/libc.so.6
#8  0x000000317da4119b in g_logv () from /lib64/libglib-2.0.so.0
#9  0x000000317da41233 in g_log () from /lib64/libglib-2.0.so.0
#10 0x0000003180e0b0bb in dbus_g_connection_register_g_object ()
   from /usr/lib64/libdbus-glib-1.so.2
#11 0x0000000000426c66 in nm_manager_add_device (device=0x22b5230) at
nm-manager.c:1125
#12 0x000000000041f571 in create_device_and_add_to_list (creator=0x22aeb20, 
    udi=0x22b6f84 "/org/freedesktop/Hal/devices/net_00_1b_77_2f_c6_7a_0")
    at nm-hal-manager.c:307
#13 0x000000318260bcf9 in filter_func (connection=<value optimized out>, 
    message=<value optimized out>, user_data=<value optimized out>) at libhal.c:1072
#14 0x00000037a660eccb in dbus_connection_dispatch () from /lib64/libdbus-1.so.3
#15 0x0000003180e09605 in ?? () from /usr/lib64/libdbus-glib-1.so.2
#16 0x000000317da3747b in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#17 0x000000317da3ac5d in ?? () from /lib64/libglib-2.0.so.0
#18 0x000000317da3b18d in g_main_loop_run () from /lib64/libglib-2.0.so.0
#19 0x0000000000422122 in main (argc=1, argv=0x7fffd46a7618) at NetworkManager.c:353

Version-Release number of selected component (if applicable):

NetworkManager-0.7.0-0.9.1.svn3440.fc9.x86_64
Comment 1 Dan Williams 2008-03-14 17:29:29 EDT
ooh, neat.  I've been looking for a reproducer on this one; I sometimes got it
on resume from hibernate.  Thanks for the bt, will investigate.
Comment 2 Jeremy Katz 2008-03-16 12:56:12 EDT
*** Bug 437408 has been marked as a duplicate of this bug. ***
Comment 3 Dan Williams 2008-03-18 12:23:26 EDT
*** Bug 437651 has been marked as a duplicate of this bug. ***
Comment 4 Dan Williams 2008-03-20 11:04:03 EDT
*** Bug 438325 has been marked as a duplicate of this bug. ***
Comment 5 Dan Williams 2008-03-31 12:00:58 EDT
Pretty sure this is fixed in latest rawhide; svn3476 and later.

Note You need to log in before you can comment on or make changes to this bug.