Bug 437609 - synaptics touchpad tap not working
synaptics touchpad tap not working
Status: CLOSED DUPLICATE of bug 439386
Product: Fedora
Classification: Fedora
Component: synaptics (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
: 437702 439672 442798 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-15 02:03 EDT by Dan
Modified: 2008-05-21 10:55 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-28 08:40:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan 2008-03-15 02:03:38 EDT
Description of problem:
Tap on touchpad is not working at all - all other settings seem to work fine.

How reproducible: every time
  
Additional info: let me know what else you need, running fully updated rawhide
Comment 1 Andrew Farris 2008-03-15 04:04:02 EDT
According to list emails this was recently changed to be default behavior (no
tap configured).  You apparently need to add tap configuration to the xorg.conf.
 There is a pretty good wiki of synaptics configuration stuff here:
http://gentoo-wiki.com/HARDWARE_Synaptics_Touchpad

See comments at https://bugzilla.redhat.com/show_bug.cgi?id=434669
Comment 2 Andrew Farris 2008-03-15 04:23:59 EDT
My comment shouldn't have sounded like an authoritative response, its just a
suggestion as to why and something to look at.
Comment 3 Dan 2008-03-15 20:16:44 EDT
adding to xorg.conf works fine:

       Option "TapButton1" "1"
       Option "TapButton2" "2"

would like to register my disapproval for the default setting though :)

another note is that gsynaptics settings for tap don't work until those settings
have been added
Comment 4 Jake Walters 2008-03-26 10:37:17 EDT
+1 to Dan's comment..I've grown to rely on tap working out of the box :)
Comment 5 Thorsten Leemhuis 2008-03-28 13:15:15 EDT
*** Bug 437702 has been marked as a duplicate of this bug. ***
Comment 6 Thorsten Leemhuis 2008-03-28 13:17:30 EDT
(In reply to comment #4)
> +1 to Dan's comment..

+1 from me as well

And seems thimm doesn't like it as well -- for his opinion see Bug 437702, which
looked like a dupe of this one (and thus I marked it as one).

Note: the bug has a lot of good informations. Quoting one

>For anyone hitting this bug report and in need of restoring the upstream
>behaviour, please add
>
>        Option      "RTCornerButton" "2"
>        Option      "RBCornerButton" "3"
>        Option      "TapButton1" "1"
>        Option      "TapButton2" "2"
>        Option      "TapButton3" "3"
Comment 7 Thorsten Leemhuis 2008-03-28 13:19:23 EDT
Reassiging to ajax, as he according to Bug 437702 Comment 1 actually did the
change in the driver
Comment 8 Klaus Pedersen 2008-04-01 18:10:00 EDT
I have the same problem and partly managed to solve it by by adding an
InputDevice section for the touchpad to xorg.conf as described.

Unfortunately the default touchpad setting is restored after a suspend/resume
cycle (on this IBM T41 Thinkpad). That means that I get the opposite behaviour
of what I have configured i.e. EdgeScroll works while taps doesn't.
Comment 9 Richi Plana 2008-04-05 15:43:55 EDT
Just adding my "+1" to restoring previous behaviour since tapping on touchpads
has come to be an expected one. I wouldn't have been as vehement in restoring
the default if there was a GUI option to changing it. As it is, gsynaptics
doesn't seem to offer that switch control.
Comment 10 Adrian "Adi1981" P. 2008-04-21 11:12:47 EDT
Also +1 from me to turn tapping by default on.
Comment 11 Andrew Farris 2008-04-21 15:54:55 EDT
Tap worked for my be default in Preview x86_64 Live.  It does not scroll (two-finger, on a macbook this is 
really needed) but it does allow single and double taps.
Comment 12 Peter Bloomfield 2008-04-27 21:48:57 EDT
(In reply to comment #8)
> I have the same problem and partly managed to solve it by by adding an
> InputDevice section for the touchpad to xorg.conf as described.
> 
> Unfortunately the default touchpad setting is restored after a suspend/resume
> cycle (on this IBM T41 Thinkpad). That means that I get the opposite behaviour
> of what I have configured i.e. EdgeScroll works while taps doesn't.

I see that too (Thinkpad T43, synaptics-0.14.6-7.fc9.i386): taps work on first
boot, but not after suspend/resume.  Synclient still reports "TapButton1 = 1", etc.
Comment 13 Matěj Cepl 2008-04-28 08:39:13 EDT
*** Bug 442798 has been marked as a duplicate of this bug. ***
Comment 14 Matěj Cepl 2008-04-28 08:39:28 EDT
*** Bug 439672 has been marked as a duplicate of this bug. ***
Comment 15 Matěj Cepl 2008-04-28 08:40:18 EDT

*** This bug has been marked as a duplicate of 439386 ***
Comment 18 John Cox 2008-05-01 10:33:08 EDT
As suggested, I've modified xorg.conf but still tapping doesn't work.
Can someone look at this xorg.conf and tell where I've gone wrong?

Section "InputDevice"
        Identifier  "Synaptics"
        Driver      "synaptics"
        Option      "Device" "/dev/input/mice"
        Option      "Protocol" "auto-dev"
        Option      "Emulate3Buttons" "yes"
        Option      "LeftEdge" "0"
        Option      "RightEdge" "850"
        Option      "TopEdge" "0"
        Option      "BottomEdge" "645"
        Option      "MinSpeed" "0.5"
        Option      "MaxSpeed" "1.5"
        Option      "AccelFactor" "0.06"
        Option      "FingerLow" "25"
        Option      "FingerHigh" "35"
        Option      "MaxTapTime" "150"
        Option      "MaxTapMove" "300"
        Option      "MaxDoubleTapTime" "125"
        Option      "FastTaps" "1"
	Option      "RTCornerButton" "2"
     Option      "RBCornerButton" "3"
       Option      "TapButton1" "1"
      Option      "TapButton2" "2"
       Option      "TapButton3" "3"
        Option      "LockedDrags" "1"
        Option      "VertScrollDelta" "20"
        Option      "HorizScrollDelta" "20"
        Option      "SHMConfig" "on"
EndSection
Comment 19 Dejan Kitic 2008-05-13 17:14:59 EDT
And what happens after suspend/resume, it reverts to default again with no
tapping action!?

I ve tryed it and after suspend/resume, tapping stops to work again
Dejan
Comment 20 Axel Thimm 2008-05-21 10:55:53 EDT
(In reply to #bug 437702 comment #1)
> OK, looks like this one was intentional:
> 
> * Mon Mar 10 2008 Adam Jackson <ajax@redhat.com> 0.14.6-4
> - synaptics-0.14.6-tap-to-click.patch: Disable tap to click by default in
>   the name of accessibility.
> 
> I'm not sure this is really a good idea, since this is unexpected behaviour,
> both by upstream documentation as well as shipped documentation (e.g. the patch
> would have had to patch the man pages for example as well).
> 
> Instead it could be something that the gdm login screen could be turning on/off
> along with all the other accessibility items. Also if you really want the
> default to change then do it in teh created xorg.conf, not hardwired in the
> sources where no one will be seraching for this change in behaviour. If F9 ships
> out that way you will get lots of duplicates to this bug report.

OK, so we have 5 reports out of a total of 56 reports of all synaptics bug
reports ever filed. Not the bug raining day, but still a very unpleasant
experience with F9 and tapping.

Fixing it is easy, here is the patch
--- synaptics.spec~	2008-03-28 20:28:10.000000000 +0100
+++ synaptics.spec	2008-04-10 19:45:27.000000000 +0200
@@ -4,3 +4,3 @@
 Version:        0.14.6
-Release:	7%{?dist}
+Release:	8%{?dist}
 Summary:        Synaptics Touchpad Driver
@@ -14,3 +14,2 @@
 Patch1: synaptics-0.14.6-newx.patch
-Patch2: synaptics-0.14.6-tap-to-click.patch
 Patch3: synaptics-0.14.6-poll-delay.patch
@@ -55,3 +54,2 @@
 %endif
-%patch2 -p1 -b .tap
 %patch3 -p1 -b .polldelay
@@ -89,2 +87,5 @@
 %changelog
+* Thu Apr 10 2008 Axel Thimm <Axel.Thimm@ATrpms.net> - 0.14.6-8
+- Reenable tap to click.
+
 * Fri Mar 28 2008 Rex Dieter <rdieter@fedoraproject.org> 0.14.6-7

And for the ones too lazy to rebuild I've placed the fixed synaptics package in
ATrpms' testing area or you can get it directly from

http://atrpms.net/dist/f9/synaptics/

Bought my sanity back.

Note You need to log in before you can comment on or make changes to this bug.