Bug 437813 - Error running transaction - no reason
Error running transaction - no reason
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.2
ia64 Linux
low Severity low
: rc
: ---
Assigned To: Joel Andres Granados
Alexander Todorov
:
: 252353 437433 440637 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-17 11:23 EDT by Alexander Todorov
Modified: 2010-10-22 19:18 EDT (History)
8 users (show)

See Also:
Fixed In Version: RHBA-2008-0397
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:33:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen dump of UI (28.81 KB, image/png)
2008-03-17 11:23 EDT, Alexander Todorov
no flags Details
updates.img (1.00 MB, application/octet-stream)
2008-03-20 15:52 EDT, Joel Andres Granados
no flags Details
this is what was added. (1.26 KB, patch)
2008-03-20 15:52 EDT, Joel Andres Granados
no flags Details | Diff
list of rpm packages from 0317 tree (split media) (161.93 KB, text/plain)
2008-03-26 11:26 EDT, Alexander Todorov
no flags Details
list of rpm packages from 0320 tree (split media) (161.98 KB, text/plain)
2008-03-26 11:26 EDT, Alexander Todorov
no flags Details
diff between packages lists (129.19 KB, text/plain)
2008-03-26 11:28 EDT, Alexander Todorov
no flags Details
the variable screenshot (13.08 KB, image/png)
2008-03-31 11:54 EDT, Joel Andres Granados
no flags Details
error dialog with the actual reason - file conflict (45.14 KB, image/png)
2008-04-03 10:44 EDT, Alexander Todorov
no flags Details

  None (edit)
Description Alexander Todorov 2008-03-17 11:23:10 EDT
Description of problem:
A physical media install on a HVM xen guest led to bogus error message. The
message indicated rpm transaction error but not pointing out the reason.

Version-Release number of selected component (if applicable):
anaconda-11.1.2.107-1
rpm-4.4.2-48.el5
yum-3.2.8-8.el5

How reproducible:
not consistent

Steps to Reproduce:
1. Install RHEL5.2 Server snap#1 from CDROM
2. Choose all optional packages (except Virtualization)
3. Proceed with the install up to the 5th CD
  
Actual results:
Error message - see screen shot

Expected results:
Installation proceeds without error

Additional info:
Folks from RTT indicate that they've seen this issue on ppc, s390x and ia64 but
it wasn't reproduce-able.

Joel Granados advised that this could be caused by a faulty package which
crashes the RPM transaction. The package in question most probably is the last
package being added: kde-i18n-Ukrainian in this case.

anaconda.log doesn't indicate anything suspicious. I'll try to reproduce and
post more results.

Xen guest has 4GB of memory (on a machine with 16GB) so that's not a memmory issue.
Comment 1 Alexander Todorov 2008-03-17 11:23:10 EDT
Created attachment 298272 [details]
screen dump of UI
Comment 3 Alexander Todorov 2008-03-17 15:25:17 EDT
Reproduced 2 of 2 times. Steps to reproduce:

1) Boot of the first CD (Xen HVM guest, 4GB ram, 1 CPU)
2) Proceed to stage2
3) At package selection screen choose "Select all optional packages" for all
package groups. Deselect only Virtualization (as we're running on Xen).
4) Proceed with install changing discs as required
5) The error happens after the 5th disc is inserted and OK is clicked. Always
ends up at kde-i18n-Ukrainian package.

All ISOs pass checkisomd5 - tested on Dom0
Comment 10 Joel Andres Granados 2008-03-19 15:37:49 EDT
Just ran a loooooong test with
http://porkchop2.devel.redhat.com/rel-eng/RHEL5.2-Server-20080306.0/5/x86_64/iso/.
 The bug did not appear.  This tree is from 06.  and the last change to anaconda
for rhel5 was on the 6.  This change had nothing to do with the installation of
packages or the rpm stuff (it was done to fsset.py)  IMO there is something
going wrong in the distill phase of the tree compose.
Comment 11 Joel Andres Granados 2008-03-19 15:59:18 EDT
I do apologize, the last commit to rhel5 was Mon Mar 17 20:42:15 2008.  However
there are only two commits that actually change the code between the 6 and the
17.  None of them is rpm related.
I still think its something non-anaconda related.
Comment 12 Joel Andres Granados 2008-03-19 16:03:21 EDT
FYI,  the relative commits that I'm talking about are :
commit1 f92756b2dfeb4b0e5184a920a669143ca1a9c471
commit2 f9ada332e3dbbd8d5916093cd3b0d8419698f172
commit3 074d6099dde8f03bdc16bec19a37151eae5e0abc
commit4 fec477ef0c613cdd8d77a9c2fec6f066a6368b9e

The rest are older that thsee four.  and two of the four are version changes (no
code changes).  so the relevant commits would be 2 and 4.
Comment 15 Alexander Todorov 2008-03-20 10:05:43 EDT
(In reply to comment #14)
> Joel,
> seeing the bug with RHEL5.2-Server-20080306.0 tree with steps to reproduce from
> comment #3

That was ia64 ISOs. Joel and I will test with i386 and x86_64 as it might be
arch dependent (he hasn't seen it on x86_64).
Comment 18 Alexander Todorov 2008-03-20 12:40:17 EDT
CDROM install, snap #1: fails on ia64, passes on i386 and x86_64
Comment 21 Dennis Gregorovic 2008-03-20 14:46:56 EDT
Could someone provide a list of the packages that anaconda is attempting to
install when it hits the traceback?
Comment 23 Joel Andres Granados 2008-03-20 15:52:10 EDT
Created attachment 298740 [details]
updates.img

AFAIK, no traceback.  just a message. comment 1.
I observed that yuminstall.py does not consider all the rpm.RPMPROB* elements. 
I created a updates image in the hope that it will be more informative.
Comment 24 Joel Andres Granados 2008-03-20 15:52:37 EDT
Created attachment 298741 [details]
this is what was added.
Comment 26 Alexander Todorov 2008-03-21 11:19:29 EDT
Testing with the provided updates.img doesn't lead to any additional info. Still
the same blank error dialog. I can provide anaconda.log if needed.
Comment 27 Alexander Todorov 2008-03-25 10:13:27 EDT
*** Bug 252353 has been marked as a duplicate of this bug. ***
Comment 31 Alexander Todorov 2008-03-26 11:26:13 EDT
Created attachment 299175 [details]
list of rpm packages from 0317 tree (split media)
Comment 32 Alexander Todorov 2008-03-26 11:26:38 EDT
Created attachment 299176 [details]
list of rpm packages from 0320 tree (split media)
Comment 33 Alexander Todorov 2008-03-26 11:28:32 EDT
Created attachment 299178 [details]
diff between packages lists

I'm examining this diff to see if there were packages that changed from one
disc to another. Any other files to diff, e.g. comps.xml ?
Comment 34 Joel Andres Granados 2008-03-26 11:32:24 EDT
how about distill, did it change?

Still debugging this issue.  have no extra information.

with regard to comment 29.  I really see no relation between the changes in
anaconda and the transaction issue.
The changes where made to:

isys.c -> network related stuff
fsset.py -> partitioning and disk
iscsi -> internet scsi stuff
net.c -> networkrelated stuff.

these are all things that come before the installation of the packages and have
no direct relationship with the transaction stuff.
Comment 38 Joel Andres Granados 2008-03-26 15:53:01 EDT
(In reply to comment #37)
> dgregor,
> also I see in
> http://porkchop.redhat.com/rel-eng/RHEL5.2-Client-20080320.0/logs/checktree
> FAILED: compose.16 multilib
its actually
FAILED: compose.8 iso_sizes
> and two file conflicts. Are these relevant to this case? 
dunno.
Comment 42 Alexander Todorov 2008-03-27 06:20:08 EDT
*** Bug 437433 has been marked as a duplicate of this bug. ***
Comment 44 Joel Andres Granados 2008-03-27 06:28:09 EDT
(In reply to comment #39)
> And there's nothing on tty3 when you get the error?

I think the last line on the tty3 is the "adding package" message
Comment 45 Joel Andres Granados 2008-03-31 11:54:23 EDT
Created attachment 299733 [details]
the variable screenshot

The behavior I found is quite strange,	I have to look a bit more and run some
more tests but just wanted to add an interesting screen shot.

I let the transaction run (yum code) and checked the error variable after the
step,  the error var had tow errors.  Funny thing is that anaconda has no idea
of the error ever happening.  the exception was raised in yum code, it was
caught in anaconda code, but anaconda has no knowledge of what is in the error
variable (that the reason why it doesn't list anything in the error alert
window).

Moreover, the two files that apear in the error message, are the same ones that
appear in the tree checks in the trees.
http://porkchop2.devel.redhat.com/rel-eng/RHEL5.2-Client-20080306.0/logs/checktree

http://porkchop2.devel.redhat.com/rel-eng/RHEL5.2-Client-20080317.0/logs/checktree

http://porkchop2.devel.redhat.com/rel-eng/RHEL5.2-Client-20080320.0/logs/checktree

look for "File conflict"
Comment 48 Joel Andres Granados 2008-04-01 04:27:18 EDT
(In reply to comment #47)
> I could believe that the xulrunner-devel split across discs in the 0317.0 tree
> is the culprit.  However, if that's the case, then why did the installation fail
> at or around disc 5?  It wouldn't have hit the conflict until disc 7.

I'm actually hitting this on disc 7.

Comment 50 Joel Andres Granados 2008-04-01 05:55:43 EDT
ok, just commited this for rhel5.  The error dialog shows the reason for the
error now.
relative commit : 8e7302fc9215e566e0562da8e03be87b76e03e55
Comment 51 Joel Andres Granados 2008-04-01 06:01:03 EDT
should pop up in version 11.1.2.110 of anaconda
Comment 52 Joel Andres Granados 2008-04-01 06:02:10 EDT
sorry, thats 11.1.2.111.
Comment 53 Alexander Todorov 2008-04-01 10:36:52 EDT
*** Bug 436768 has been marked as a duplicate of this bug. ***
Comment 57 Alexander Todorov 2008-04-03 10:44:35 EDT
Created attachment 300259 [details]
error dialog with the actual reason - file conflict
Comment 59 Chris Lumens 2008-04-04 10:10:28 EDT
*** Bug 440637 has been marked as a duplicate of this bug. ***
Comment 62 errata-xmlrpc 2008-05-21 11:33:35 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0397.html

Note You need to log in before you can comment on or make changes to this bug.