Bug 437965 - kpdf segfault in Splash::fillGlyph2
kpdf segfault in Splash::fillGlyph2
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdegraphics (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Lukáš Tinkl
Fedora Extras Quality Assurance
:
: 438589 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-18 09:26 EDT by Robin Green
Modified: 2015-07-13 13:37 EDT (History)
6 users (show)

See Also:
Fixed In Version: 3.5.9-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-11 04:03:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 157777 None None None Never

  None (edit)
Description Robin Green 2008-03-18 09:26:54 EDT
Description of problem:
kpdf crashes for certain files. A fix is in KDE SVN, but there may not be
another release in the 3.x series from kde.org.

Version-Release number of selected component (if applicable):
kdegraphics-3.5.9-1.fc8

See external bug reference for details.
Comment 1 Rex Dieter 2008-03-18 09:50:36 EDT
> there may not be another release in the 3.x series from kde.org

rest assured, there *will* be.
Comment 2 Robin Green 2008-03-18 11:21:20 EDT
now that I read the reply to the bug report again, I realise that it said the
3.5.x series, not the 3.x series.
Comment 3 Kevin Kofler 2008-03-18 11:27:16 EDT
When talking about future releases, 3.5.x == 3.x. There will not be a 3.6 
branch and there will definitely not be more 3.4.x releases.
Comment 4 Fedora Update System 2008-03-20 10:44:03 EDT
kdegraphics-3.5.9-2.fc8 has been submitted as an update for Fedora 8
Comment 5 Fedora Update System 2008-03-20 10:44:44 EDT
kdegraphics-3.5.9-2.fc7 has been submitted as an update for Fedora 7
Comment 6 Fedora Update System 2008-03-21 18:03:50 EDT
kdegraphics-3.5.9-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdegraphics'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F7/FEDORA-2008-2558
Comment 7 Rex Dieter 2008-03-23 15:14:38 EDT
*** Bug 438589 has been marked as a duplicate of this bug. ***
Comment 8 Paul Smith 2008-03-23 15:34:30 EDT
Thanks, Rex. With

su -c 'yum --enablerepo=updates-testing update kdegraphics'

the problem was fixed.
Comment 9 Fedora Update System 2008-05-22 16:36:57 EDT
kdegraphics-3.5.9-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Antonio J. de Oliveira 2008-07-22 06:45:50 EDT
I had to uninstall Acrobat Reader, kdegraphics, re-install kdegraphics,
kdegraphics-extras, re-install Acrobat Reader, then mime types were properly
restored. It works now.
Comment 11 Kevin Kofler 2008-07-22 08:17:07 EDT
What you're seeing is not this bug, but bug 434685 (which is an Adobe Reader 
(acroread) bug, not a Fedora bug).
Comment 12 Antonio J. de Oliveira 2008-07-22 09:26:57 EDT
Thanks ;-)

Note You need to log in before you can comment on or make changes to this bug.